FP2: SIM: phone number field could not be edited

In the FP2 the phone number field is not editable, I can only edit the name of the SIM.

In the FP1 the number was editable and also the SIM could be given a different color. This last one I don’t mis, but I do miss the phone number showing with sim cards.


2 posts were merged into an existing topic: List of known bugs

I also can’t edit my phone number or my voice mailbox number. It seems to be “hard-coded” in the SIM card.

I don’t have a SIM in my FP2 yet to try reproducing this myself and also I’m not exactly sure what we’re talking about here? Can’t you edit the phone number for the owner id or can’t you edit the number displayed for your own sim?

In the first case I’d say it’s a bug if it’s reproducible, in the second case it would be a feature request.

@Lidwien If you consider this a bug it’s ok to add it to the list of bugs but the way to do that would be:

  • move this thread to the bugs category
  • edit the list and add a link to this thread
1 Like

I know, what Marco_P means, and it has nothing to do with the caller ID. It`s given by the provider as default. It is “hard-coded” in the SIM card. To make the caller id visible you have to open the telefon app.

In the FP1 go to Settings,
go to SIM management
tap on either the first or second SIM
now you are in SIM INFORMATION
and you can ‘Edit the SIM name’
‘Enter phone number’
‘Set background color’
‘Display number’

In the FP2 one can only edit the name fo the SIM. And the other three options of FP1 are missing.

1 Like

I added it to the list of feature requests.



  • Add phone number after the SIM name on the same line.

My SIM 1 is German (Congstar) and SIM2 Spanish (Yoigo). SIM 2 doesn’t show its number in the settings. But when I make a call, it’s correctly transmitted. The card is more than 2 years old and I got it cropped in an internet café to micro sim size. I think, the fact that the number is not shown in the settings is just an ethetic flaw, but it annoys me as well. As far as I remember, in my FP1 it appeared. I’m wondering now if the SIM is too old for FP2 or if this has to do with the fact that it has always been in roaming so far. Does anybody have a second SIM from another country and can please have a look if the number is shown?

Your number seems to be hardcoded in the SIM. That could explain why you don’t see the number in the settings.

But isn’t that normal?

I think so, but FP2 somehow doesn’t show the number in the settings.

Well, it shows my Congstar number as it should. This SIM is from november 2014. Anyway, the first week of february I’ll be in Spain, so maybe my Yoigo card changes its behavior there…

I have a SIM card from Hollands Nieuw and one from XS4ALL. Both don’t show their number in the settings.

I use an T-Mobile and KPN SIM in the FP2 and for both SIM cards no number is shown in the settings. SIM cards are already a few years old.

I have the same behaviour - a number is shown for SIM1 but not for SIM2, and I can’t edit the SIM2 number in settings. This is different behaviour to my FP1 which had the same SIMs (which had nano/micro frames, so now popped out to be smaller). In the FP1 I was able to edit/set numbers for both SIMs. (UK Virgin and EE)

The sim shows the wrong number!! The correct number works OK, I have not tried the number that the settings sim shows.

Hi there, I think I have rte same problem; just got new SIM from a provider and the SIM settings show the “new” number even though the phone now works on my “old” number. I’m only using one SIM. Did you solve your problem? Thanks John