FP2 Screen can't be reactivated during/after calls - See first post for Workarounds

Okay, so here’s my attempt at stopping dust from entering between the sensor and the glass:

  1. Open the phone and remove the display.
  2. Clean the inside of the opening for the sensor on the display unit.
  3. Take a small piece of electrical tape (or any other smooth and suitably thick tape).
  4. Place the piece of tape non-sticky side down on the opening of the display unit and press it a bit. This leaves an impression on the tape helping to cut a proper size hole in it. You could use e.g. paper as well to transfer the dimensions on the tape.
  5. Cut the hole in the tape using a suitable tool like a scalpel or a razor blade.
  6. Trim excess tape with scissors or somesuch. Make especially the side adjacent to the status led narrow enough to not cover the led.
  7. Now align the tape on the hole of the display unit glue side down and make sure it sticks.
  8. Put everything back together and hope for the best.

SInce I just finished doing this I can’t say if it’ll work out, but I’m armed with thicker tape and some foam insulation as the next attempts if necessary. :slight_smile:


Pics or It Didn’t Happen! :slight_smile:

OK :smiley:

On the right hand side, tape I used and the razor blade, and on the left hand side the next candidates:

Then the result, which, now that I look at it, shows how badly I actually cut it:

So the scalpel would have been better but I was too lazy to find it…


Nice workaround and pictures. I hope you can tell us in a few weeks if this has improved the handling! Thank you for trying and posting here!

I’ll keep you up to date. There are actually two FP2’s in the family and I need to do the same for the other one too, so there’s double the chance to check this out :slight_smile:

1 Like

Thanks for the help and sorry about complaining. I was in a rather stressed situation where I necessary needed my phone to work 100% and this stressed me a lot.

The thing is: I want to have the underlying problem fixed. I’ve had a lot of problems with my FP2. And since my phone calls are important to function well in my daily life I get stressed and mad when it doesn’t work. I am not really interested in the workarounds, but solving the the fundamental problem.

I bought the FP2 for a number of good reasons, but especially because I wanted stability in my phone life - I was annoyed with the fact that Samsung or HTC phones stopped working after 1½ year and I had to buy a new. Apart from that being a horrible waste I usually take a lot of time getting used to a new phone, new settings, reinstalling apps, new software etc. The fact that FP2 is designed to last for 5-7 years is upright amazing - but now I am starting to seriously wonder if I would rather have a new phone every 1½ year that works, when it works, or have a phone full of bugs that makes every phone call a pain for the next 5-7 years. This is what stressed me and I am sorry that you people, who help the best you can, should be victims of my bad mood and frustrations.


No problem, I understand your feeling, and completely agree that the underlying issue should be fixed. I’ve had my share of issues too, and while I can live with the workarounds provided here, it’s something I really want to see fixed at some point. So far FP has, in my opinion, a fairly good track record on addressing issues (e.g. screen flickering, bluetooth problems) that have affected quite a few people, but sometimes the wait is frustrating indeed. I’ve also had products with obvious defects since new with no support from the vendor whatsoever, so this is already better, but I think the limited resources of a small company show here in that some issues take longer to fix.


Just another status report: It had worked after cleaning, but not a week later the proximity sensor is broken again (reporting 0 all the time). I am using the “Sensor disabler” module of the XPosed framework now to fake a sensor value so the screen stays on during a call. I simply cannot open the phone to clean the sensor every week.

1 Like

When I make a call, and no one picks up on the other end, or I arrive at a answering machine, or one of these menus where you are supposed to press a number on your keypad, my display is black, and I can’t find out how to wake it up. None of the buttons work, and so far what I do is I pull the battery each time I want to hangup after a call. Needless to say, this makes the phone quite useless for making voice calls. Any suggestions? I have the Faiphone 2, with the latest software update.

I moved your post to this topic, as it discusses this issue. Most of the info that we know about on the Forum is summarised in the first post, though for some specific scenarios there are other suggestions throughout the topic.

1 Like

Hi all guys and girls!

I’ve read through the hole thread. I use a FP2. I’ve had the problem of not being able to use the phone during phone calls for some time. Thank you all for contributing with workarounds, great thanks!

I’ve tried cleaning the outside of the display, the inside of the display and also the proximity sensor but it doesn’t work. Though I bought a new top module. With the new top module it seems to be working better. Nevertheless, if it’s just a thin layer of grease (from my hands) on the phone the proximity sensor stops working.

As suggested as a possible fix to settle this issue would be to be able to manually permanently set the values of the proximity sensor.

And I would also say that it’d be best if Fairphone would officially say something regarding this issue because it seems to be a profound and widespread error.

Good day to you
Anton Thelander
Sundsvall, Sweden


“Reporting back”: In the meantime I had to clean the phone twice again and currently the issue reappeared, so I would need to open the phone again.

So this is not really a solution to the problem :frowning:

You could try something like this to prevent dirt from getting between the sensor and the glass.

Almost two week later everything’s still good with my electrical tape tweak. This is by no means conclusive, so I’ll report back again later. :slight_smile:

Check This ! HARD RESET !

So , whilst trying to fix a problme with a non working mic ( calls and recorders only working with speaker phone , ugghhhhh F$@£%£%%$£%$K ) I went for a hard rerset . sesnor is now back to normal ! ! . I dont know for how long though , fingers crossed .

1 Like

A release candidate is being tested in the beta section right now that introduces “Initial improvements to the proximity sensor calibration” so it might be worth testing to see if it fixes/reduces this issue.

See here how to get access:


PS: I’ll just mark this as a solution for a short while to increase visibility.
The sensor improvements are not included in the 1.5.1 release and are postponed to the next update.


Exactly my sentiments.

I would like to try the foil method but I currently end calls with the power button. How do you only switch of/on the screen?

Like many others my FP2 has also showed this problem.
Cleaning the screen did solve the problem but only for a short time.
Eventually I had to clean the screen daily and sometimes it only worked for an hour or less.
Needless to say this is an unbearable situation, it’s inconvenient and taking the phone apart
daily puts wear on the parts and I could easily break something eventually.

I’m not in a dusty environment which makes me think the problem i something else.
Could it be that restarting the phone after having it apart is what temporarily solves the problem?
Aka it’s not the cleaning of the screen but the restart that seems to solve it?
Makes me think it is a problem with the sensor and it’s calibration.
On one of the last occasions it happened to me I took the phone to bright daylight and then the sensor reacted again!
Looks to me that the sensor is not sensitive enough.

Downloaded a calibration app for the proximity censor but this did not help.
Downloaded another app “Proximity Fix” by rognaas, no interaction in the app, you just run it.
This actually worked, the proximity censor has behaved as it should for several days since I used the app!
Don’t know what the app does but I guess it resets the proximity censor in some way.

Ah! Thanks! I have taken off the display screen and cleaned and it’s ok again (for now :slight_smile: