FP2 Screen can't be reactivated during/after calls - See first post for Workarounds

Yes, you were right!

You have to change the setting of the power button in Settings -->Accessebility “Power button ends call” (disable the option).

Novski, wat is the manufactering date on both screens? Is there a color difference in the proximity window on the display? ie, lighter vs darker window? This proximity sensor issue can be related to a lot of factors. It’s all not as simple and straightforward as one would think. I remember Apple released their iPhone 4 in white version much later due to proximity problems, even during production and after replacing screens this remained a big issue.

I have been working in cellphone repair for a long time now so believe me, I know. Only way to finally tackle this issue is either a hardware mode (IE: raise the rubber bridge between the led and the receptor, make the sensor rubber so that dust cannot intrude, or a software mod. I think the latter will be the way.

Alfi

1 Like

how about now? :wink: – is it still working? it yes, then i will go for it :slight_smile:

and btw ("@everybody"): did you also notice that the “rubber ring” they put around the sensor (window?) to keep dust from coming in was tilted? (i think somebody else reported this here or in the other thread. it was definitely also the case in my phone…)

Thanks for asking, still working great!

Hi
I have the same problem the screen goes black as soon as I dial a call.
I’ve read all the posts above including the first one and looked at the pictures.
I’ve cleaned the sensor as described and the problem persists.
I’ve tried the aluminium foil solution and the problem persists.
To be honest the phone is totally useless for making calls to anywhere that requires a response to an automated system by entering numbers.
I only got the phone in February.
There must be something under some sales of goods legislation about an item being fit for purpose. Becasue this isn’t.
It doesn’t matter how fair it is if it doesn’t work - does it?

It’s called warranty. If a product doesn’t work, then it falls under warranty (so you can get it fixed for free, or replaced if necessary).

That said, have you installed the latest software update? Then you should be able to re-calibrate the sensor settings. Did this also not help?

I also have the same problem. You shouldn’t assume everyone that has the problem reports it. I, personally, was hoping a FP update would fix the bug, since it is such a big one… A shame this hasn’t been fixed yet. It makes the phone unusable to make calls! That is a big drawback for a phone…

Did you read the first post? There you’ll find a description on how to recalibrate the sensor which was introduced by the latest update.

1 Like

I tried the calibration tool, it always says “Block value<230, please ensure you have blocked sensor read state”…;i tried multiple times (yeah i blocked it…), i tried to clean the screen,ut it’s still not working, am i going to need to send it for repair ?

1 Like

Hi guys. I might have a solution to the problem.
I have had the same problem, not being able to hang up. Tried cleaning the inside of the sensor and used a sensor app to test. Still the same, first at 5cm and then getting stuck at 0cm when I put my hand over it and then remove the hand again. BUT! Then I tried to clean the frontside of the screen with a napkin and now it works again. Is not stuck on 0cm when I remove my hand. Don´t know if it will solve the problem forever, but it has worked for an hour at least ^^
My guess is that the sensor reacts to the fat put on the screen by our fingers. Not enough to trigger the sensor, but enough to keep it so once it has been triggered (just like someone said about dust in another comment). So try it, it might work :slight_smile:
(I haven´t read the whole thread and I appologise if I repeat something allready said)

I hope it will help more of you and that it will keep working for me! :slight_smile:

1 Like

Callibrating the proximity sensor worked just fine!
Thanks.

I just updated to 1.5.1 and tried the calibration tool, without any success (same problem as @Elipsus described): I blocked the sensor, started the calibration tool and it reads “Block value <230, please ensure you have blocked sensor beofore [no, that’s not my typo :slight_smile: ] read date”. So my proximitry sensor is not working at all or what?

Had that problem, too. I rebooted and tried it with different lighting situations (pressing thumb while blocking vs. just hovering above the sensor; strong light vs. desk lamp) and it worked.

Hello all,

I have got the same issue for months, quite annoying indeed.
The recalibration failed for me at first (error : “Unblock value is too high”).
However by blocking the sensor with full hand, I guess letting a little light in, instead of the finger, and not putting the phone under direct light for the unblocked check, things went smoother.
And it solved the issue! :slight_smile:
I hope it helps!

Has anyone tried the calibration on FP Open OS? As soon as I enter the last * in *#*#8765#*#* the number disappears from the dialer.

This fix hasn’t been implemented yet into the Open OS, so it won’t work there (only in the 1.5.1).

2 Likes

I’ve got the same problem, no matter the way I block the sensor, it says “Block value <230…”

And I got so excited when I read the Update notes :confused:

This does not work for me. When I dial the number nothing happens after “USDD Code Running”, in other words, the calibration app is never started. And I do run version 1.5.1.

2 Likes

I’ve moved your post here, as the topic that you responded to was in the FP1 section. Also, it appears there was a copy/paste error in the FP2 instructions posted there by mistake. Do the instructions in the first post of this topic (here) work?

1 Like