FP2 Screen can't be reactivated during/after calls - See first post for Workarounds

Could be an issue with the proximity sensor.

Are you on version 17.06.4? Fairphone OS or Open OS?

Hi Gerry, I’m on 17.06.04.

Reopening this topic, as the proximity sensor tool is fixed again. (With apologies to the previous three posters for moving the posts to the wrong topic initially).

Still …

I already miss the good old days, when the version numbers of Fairphone OS and Fairphone Open OS were different :slight_smile:

1 Like

Ivar, did you ever get this resolvef? I have same isssue. Once i start a call, screen goes black. I can talk, but i cant end call. I have to remove battery.

When I make a phone call, the screen goes immediately black and the only action possible is to hang up with the button near the camera. So when I’m asked by an answering machine to dial 1 for this, 2 for that, etc, I just can’t do it! That is highly frustrating!
Any suggestion on how to keep my screen active during a phone call?

As quite some posts have been moved here recently, here’s a summary of the current state of things:

  • Most of the problems with screens staying black as soon as you start a call are related to either issues with the configuration of the proximity sensor, or dirt in front of the sensor (or both).
  • In regular Fairphone OS, there is a tool to reconfigure the sensor. Official Instructions can be found via the troubleshooting tool (calls > my displays stays black during or after a call).
  • The tool for Fairphone open OS appears to be temporarily missing in action.

Hi everyone!

I have a serious and annoyng problem with my FP2: when I call someone, the screen turns all black and I can’t end the call, or do whatever I want (also, I cannot switch off the device). The only thing I can do is to remove the battery and turn it on.

It happens all the times. Plus, I cannot connect the FP2 to my PC, I just fixed the Bottom Schedule and I thought I will solve the problem… No, it still doesn’t work.

What can I do?

Hi @Giulia8,

check the post above yours by @Johannes, your problem sounds like a issue with the proximity sensor calibration data.

Regarding your other problem:[quote=“Giulia8, post:419, topic:11874”]
Plus, I cannot connect the FP2 to my PC, I just fixed the Bottom Schedule and I thought I will solve the problem… No, it still doesn’t work.
Could you elaborate a bit more, what exactly the issue is? What OS is running on your PC? Does the PC recognize any device at all? I assume you’re trying to connect by USB, right?

Good questions. Without knowing the answer to them I can only add that the most common connection issue reported on the forum (example topic) is actually a change in the default connection mode in Android 6. You need to set the connection mode to MTP on the phone explicitly - it is no longer stored as default.

If the problem is more complicated, we should start a new topic as this is a bit off-topic in this screen-issues topic.

Hi! I tried with two PC, my own is a Windows 10 software (I tought you had asked me this! :)) and one at my office, Windows XP. The Device does not work in both situations: of course, I use USB to connect the FP2 to the PC

Just to clarify:

  • You connect your phone to your PC via USB.
  • Then on your phone you can see a notification about your phone charging via USB and to tap on this notification to change the connection mode (perhaps you have to swipe down from the top to see it).
  • You tap there and change the connection mode to MTP.
  • And then your computer still doesn’t show the phone as it should do.

In that case you could try the following at least with Windows 10, I don’t know about Windows XP nowadays …

Do you know any app that does this?

Hi all,

I had the problem with the proximity sensor as well, where it wouldn’t reactivate the screen. For me the calibration did the trick and I could use the phone as expected (more or less - there were still some quirks, when the screen stayed black when I was outside on a sunny day; but hey…). Right now I have sort of the inverse problem: the proximity sensor only signals zero distance when I’m about 5 mm away from it, as opposed to the 5 cm which is the nominal threshold (measured with AndroSensor). I’ve gotten used to moving the upper left corner of the phone to my ear first, when making a call and keeping it there, so I don’t suffer from the problem a lot. But it’s still annoying. I’ve done the recalibration already a number of times but that doesn’t change anything. Does anyone have the same problem? Is there any other trick I could try to resolve this?
For what it’s worth: I got a new display module recently and it could be that the issue started then. But I can’t really say for sure.

1 Like

Well, I tried Screen Lock on my FP1 and used it for about a week. But honestly I consider it faster and more comfortable to just use the power button, than fiddeling around with the app.

I’ve had the same problem right after using the calibration tool for the first time. Always ended calls by accident because my ear turned the airplane mode on or simply hung up.
After some more calibration runs I’ve tried not blocking all the light in the first step and having the midday sun shining on the phone in the second step. The problem’s not gone but I think it’s a better. Still would love to be able to handle the Fairphone like any other smartphone when calling :smiley:

this happens to me too, not every call but maybe one in four. Its particukary annoying because so many companies want you to use the keypad to choose options, and of course with the screen locked I cant do that! ive lost count of the times ive just had to end a call by taking the battery out and rebooting, after waiting in a queue for ages…

Please go through the troubleshooting tool’s steps as suggested in the first post.

This just happened to me. Thanks to your post I went into settings ->maintenance and went through the proximity sensor calibration and reboot and now it works again. Thanks very much.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.