FP2 running very slowly

I’ve been having EXACTLY the same issue. Have tried deleting stuff, uninstalling/disabling apps, but no improvement so far. Also prefer to avoid a factory reset so hoping someone has a fix!

Welcome to the community forum.

You can boot the phone in safe mode to get a hint whether Apps might be the problem … https://support.fairphone.com/hc/en-us/articles/217869383.

A factory reset in the Android world only deletes user data and Apps and doesn’t touch the OS.
If a factory reset doesn’t help, you can go one step further and reinstall the OS from scratch … 🇬🇧 🇩🇪 ✏ Installing the Fairphone 2 from scratch in case of failure / Komplette Neuinstallation des Fairphone 2 im Fehlerfall.


Hi !
I have exactly the same problem ! I tried deactivating/uninstalling every useless app, and updating everything but it only gets worse… It all started a few months ago with a phone crash here and there, and now it happens pretty often !
For instance, every time I use the “record vocal message” function on whatsapp my phone crashes… It also crashes a lot by using google maps, and even (weirdly ?) by using my clock alarm/chronometer…
There is nothing more anoying than setting an alarm and then it doesn’t ring because the phone crashed :’)
I can’t imagine that there is no solution… Really hope there is a fast and simple one ! Hope I’ll find some help here ! :slight_smile:
Have a nice day (from France)

There isn’t really a “one button push and all is cured” solution. I recommend to everyone to check Settings > Storage and see how full their storage is. If you are using more than 25 GB of the internal storage, then you need to free up space – usually moving photos, videos and music to a MicroSD card* (or to a computer, if you don’t need the stuff on your phone permanently) is the way to allow your phone more room to breathe again.

* Please make sure your MicroSD card is set up as “portable”/“external” storage. Do not format it as extended internal storage, that would only mess up things.


I face the same problems. I reset the phone a few weeks ago, but nothing changed. I am only using 14 GB of the storage space, so that should not be the issue. I have no idea, what to do next. As it is know, its not convenient to use the phone anymore…

Are you perhaps using the app Facebook?
How old is your SIM card?
Give your battery a #dic:kickstart.

I do use facebook. Is there a problen with that?
But the phone crashes also while using other apps like instagram, camera, twitter, google maps, amazon music,… and sometimes even when I am not using the phone.
The SIM card is about 3 years old.
I will try to kickstart the battery.
Thank you for your suggestions!

Yes, Facebook is know for making the phone slow.
Consider to install F-Droid as an alternative app store.
F-droid provides Tinfoil for Facebook, Tinfoil for Twitter. These app are a light version.

The more apps run, the more heat the SoC produces, and the less efficient the performance will be to avoid overheating. (Was that understandable even for me?)

What does “I reset the phone” mean in your case? Did you do a “factory reset”? And after that did you restore a backup you made before? It sounds a bit like that because you mention to have again 14 GB of storage used…
I’m asking because if you restored a (maybe google based) backup it’s possible you restored the root cause for your problem…
After a factory reset I’d recommend you setup your device “from the scratch”…


Yes, I did a factory reset. I did not use a backup, I installed the apps again. And have a few pics and some music on the phone.
The storage space I could use is 29 GB, so I do not expect the phone to have such immense problems if you use half of the storage space.


I am enduring the same issues with a phone on Lineage. It started with Lineage 16 and the problem still occurs with Lineage 17. I wanted to try a clean install, but the issue occurs both with Fairphone OS (at least for @westwyk1392) and as @ronja26’s factory did not help, I guess that the problem rather is hardware-related.
Has anyone tried to install another OS to fix the problem? I wonder if a non-android OS would help, like UBports or Sailfish. Anyone gave it a try?

Yes good point, sorry, I read too fast and thought it had been tried.
I also see now that I forgot some words… I meant “the issue occurs both with Fairphone OS and Lineage”. That’s why I guessed that it could be hardware-related.
I have another Fairphone 2 that I can use, I will try to clone my phone to this backup phone to see if the issue still occurs.


This issue is definitely hardware related. I tried LOS, Fairphone Open and /e/ and in all three cases the freeze and artefacts occured:

Quick update: I have followed @AnotherElk’s advice and reinstalled everything from scratch.
I installed /e/ as I wanted to test it anyway. No problem at all since mid-January. I have even upgraded to /e/ Q today and everything seems fine so far.
I guess that the complete reinstall from scratch helped. To be sure, I should try it again and install Lineage instead, but I feel like I need a break from the Terminal right now… (I also installed Saifish in between to test it)

So my advice: If your FP2 seems slow, reboots or if the apps close themselves, just try a complete reinstall from scratch. And if it doesn’t help, try another OS just in case.


Grrr. Problems came back with /e/ Q as explained in another thread. I wonder if it is Android-10 related and I feel like downgrading to Android pie, but it doesn’t seem to be recommanded… I will address this issue in a /e/-related topic.

update: deleting the cache of most apps (through settings/all apps individually) worked and made it feel lighter too. Not perfect but brought an improvement.

For me it’s the opposite. My apps freeze more and more often, even apps like Signal, Mail (K-9) and the browser.
I’m still on /e/ because I waited for official Lineage 18 to move. I also considered moving back to Fairphone Open OS as I had problems on Lineage 17 too before trying /e/. I guess I will wait until Android 9 becomes official for FPopenOS and give it a try before going back to Lineage.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.