FP2 not recognised by Win10 for backup/OS installation after faulty update

Hi everyone,

First off, thanks very much for the kind support in this forum, and apologies if I have missed the solution(s) to this.

After trying to update my FP2 OS through the Fairphone Updater, my phone now will not start - it keeps going to the TWRP, and the message I keep getting is “Unable to find path /system
Full SELinux support is present”. Trying reboot -> system does not work.

Consequently, I tried using the bootloader to back up my phone data to my desktop (Win 10 Home) or reinstall the OS. I get into the ‘Fairphone/blue flashing light’ mode fine; however, Windows does not recognise my phone - it shows up with a yellow triangle in the device manager, but not at all in File Explorer.

I have tried:

  1. downloading all the latest Windows update packages (up-to-date now; no change)
  2. downloading Samsung and universal ADB drivers as instructed here and Google USB drivers, but when I try installing them through device manager (my phone is not shown in that dialogue as an option, so I am choosing ‘USB controller’ as instructed here), Windows keeps telling me that they are not suitable/does not find suitable drivers.

In case that is relevant, my FP2 was on a recent OS update (ca. a few months ago) and is 4.5 years old (purchased in Oct 2016).

Does anyone have any ideas for what to do?

Thanks very much in advance,


1 Like


First: There is no way to download files from the phone in bootloader mode. This mode only allows flashing or erasing partitions and such things. Try TWRP instead.

Second: If I’m interpreting the message from TWRP correctly, your “system” partition is damaged. You could try a manual re-installation: https://forum.fairphone.com/t/installing-the-fairphone-2-from-scratch-in-case-of-failure-komplette-neuinstallation-des-fairphone-2-im-fehlerfall/46728/2

1 Like

Not necessarily, depending on the TWRP version.
Fairphone for a while bundled a TWRP 3.1.1 with their OSes which gave this message without any important meaning or consequence.

An update getting stuck in TWRP was kind of notorious a while back and I guess one of the reasons why Fairphone have abandoned their own TWRP for the stock Android recovery bundled with their latest OS versions.
Anyway …


Thanks very much to you both for your thoughts, @thc and @AnotherElk , much appreciated!

I managed to do a backup in TWRP as thc suggested on an internal SD card.

I then tried, as Another Elk suggested, to re-install the update file through TWRP, and miraculously, that worked, and the phone is back up and running (I am doing a full back up as we speak/write). I guess that means the partition was not damaged, it was just that the update did not work smoothly the first time.

Thanks so much again!

All good wishes,



Just don’t use your SD-card as internal memory. Format it as external. Internal formatting can lead to data loss. There seems to be a bug, besides the general danger of a SD card failure. Just do a little searching in this forum. There is no easy solution, should you experience such an error. :wink:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.