FP2: no connection during fastboot from Win 10 PC

I tried to reinstall Android 9 on my FP2, as I have some issues with it.
(Issues: Random Reboots, Battery lifetime and sudden drop, weak telephone signal).

When I turn the phone in the fastboot mode, my PC can not connect to it. with

adb reboot bootloader
fastboot.exe devices
When I check the device drivers in Windows, there is only an Android Driver (no more mobile device, FP2-Driver). And this android driver (VID_18D1&PID_D00D) has an exclamation mark. When I try to make an update, Windows tells me, that this is already the best driver.

Any idea? Thanks in advance!

1 Like

I think you should use “Windows updates” and not “driver update” for this.
Look e.g. here:


Thanks Volker!
The issue was where to check the updates. NOT in the device driver section.
Reinstallation of Android 9 is done know :slight_smile:

The offical description was confusing (even if it is written in the text). On the left side pictures of the drivers and on the right of the update. https://support.fairphone.com/hc/en-us/articles/360042185512


I think the idea is to show you (on the left) how icon in device driver changes from icon with question mark to updated icon while Windows updates is done (on the right)…

1 Like

Now I can not enter my phone…
When finished the reinstallation, I removed the USB cable. Shut down. Put the SIM card into my phone, replaced the battery. Started and when I put in the code, the phone does not open.

Did you do a factory reset? Or is your intention to only reinstall the operating system without deleting your data?

1 Like

I made a factory reset a few days ago, as the reinstallation did not work.

So I’d recommend to do a factory reset again, now that the OS is installed.

1 Like

I can confirm, having encountered the same problem myself. Windows 10 users should use the general Windows update service (Settings > Update & Security > View optional updates > Driver updates). There are two drivers to update, Android Composite ADB Interface and Qualcomm (if I remember correctly).

Once you’ve rebooted, fastboot works fine! :sunglasses:
But the time I wasted messing about before I got there, doesn’t bear thinking about :sweat_smile:


With the correct driver update method and factory reset afterwards, now it runs again :slight_smile:

Next step will be to find out, what original issues are solved :wink:


The topic can be closed. The issue is solved.
One issue of my FP2 seems to be solved by the re-installation of Android: the random reboots.