English

FP2: new camera module stopped working (old one still works)

I bouht the new camera module in February 2018 fitted it end March. A month later the out of the blue, the phone stopped recognising it and would only allow selfies. I have followed advice here, updated my FP software, rebooted several times, taken the new module out, cleaned it, refitted. I also put my old camera module back in for a couple of weeks (it works- which makes me think it’s the camera not the phone which is the problem) and tried then putting the new module back in. Still no joy. I have now written to Fairphone. I have also tried calling.

I think I need a replacement. I was also about to order a new battery and think would be good if the 2 could be sent together. What is FP procedure? If I order a new camera will the first one be refunded?

They’re not answering the phone…

1 Like

Try tomorrow :wink: .

“Pentecost Monday is a public holiday in many European countries including Austria, Belgium, Cyprus, Denmark, France, Germany, Greece, Hungary, Iceland, Luxembourg, the Netherlands, Norway, Romania (since 2008), (most parts of) Switzerland, Ukraine and also in the African nations Senegal, Benin and Togo.”

Thanks! they did not say that in their message!

Since you had both modules in hand individually, could you make any mechanical difference out?
Were there washers with the new module or on both? If so did you always reused them?
Some users here reported when applying gentle pressure on the module the phone would recognize it properly.

Hi thanks! no I didn’t notice washers with the new module and it did work very well (until it didn’t- and it stopped for no reason/no change) so it’s not like there was anything missing.

I screw both modules equally tight, not sure what pressure would do. I was thinking as it did work originally, it might be something to do with a Fairphone software update rather than a hardware issue
?

I managed to speak to Fairphone but am no further along. Both verbally and by email, I just got a generic response telling me what I already tried with online troubleshooting. Very disappointing

I’m pretty sure it’s the update. 18.04.01. Camera stopped working immediately after. Does anyone know how to go back an update to check?

Failing that how does one return items and get a refund here?

Sorted now- established it’s a hardware issue and replacement being sent.

For information- it’s apparently not possible to go back an update.

Thanks!

That sounds very good.

I don´t know where you got that information from, but in general anyone with a FP2 can install whichever OS version supporting FP2, he likes. There is no simple button like “uninstall last update” or so, but with the proper software tools and of course OS packs it can be done. For someone who knows what he´s doing it´s no problem to up-/downgrade to any preferred version.

1 Like

Hi Patrick- thanks! I thought it would be worth trying and I had thought there might be an option like on Windows but it was Fairphone helpline who told me it was not possible. As the camera is under warranty am guessing I shouldn’t go against their recommendations, but still useful to know about that. Thanks again

1 Like

Just in case anyone is following this. There has been no further communication form Fairphone and no notification that a replacement module is on its way. Slightly disappointed…

I had the same experience with my new camera module. Maybe the module wouldn’t tested enough. Now i will try a replacement. At least for my display module, the replacement with the fairphone support team works fine.

1 Like

Hi, so have you gotten the replacement module yet? I am having issues with mine as well and just contacted FP today. Wondering if I should try going to the older OS version as mentioned, after reading your comment I think mine coincided with that as well, but it does seem to be a hardware issue as I get vertical colour lines and then an error saying can’t connect to the camera.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.