English

FP2 keeps rebooting after update. Can't rely on it for productive use. Need (downgrade) advice

I totally agree on that view.

So what shall we do right now? Support still didn’t answer my ticket from last week (Request #110855). Using drums to communicate until we receive our next update seems to become a feasible solution :joy:

1 Like

Indeed, I never installed 1.4.2.

I tried without SIM and it is still rebooting. However, it feels as if using WiFi increases the probability for a reboot.

From the behaviour I noticed on my phone, nearly every essential use of the phone (using the phone app, using the browser, using the messanger app, using apps that access the internet) increases the probability for a reboot. Wether I’m connected to a W-LAN or not never played a role there as far as I noticed.

[Edit]
Just tried your point out a bit. When I disable 4G and don’t use Firefox, the probability for a reboot decreases by disableing W-LAN.
I don’t think that anyone can use the following information, but for the sake of completeness: Everytime I open the URL “kicktipp.de” (a German betting game for the EURO 2016), the browser crashes after at most 3 page visits or even earlier.
[/Edit]

My FP2 is out of order since this update :

  • Several reboot.
  • Optimization of applications on each startup.
  • Black screen during about 30 seconds, than “loading” message and Fairphone logo before I can take the hand.
  • Battery very hot.
  • Localization icon appears with localization off.

I made a hard-reset, without success.

At this time my phone is in its box, and I’m using my old Nokia !

:rage:

I just had a great call with the FP support:

They are aware of the issue and really helped me. I was kindly asked not to write down the whole process, due to the fact that the procudure of fixing the issue could change during the next days or weeks.

So if you are facing the issue mentioned above right now, the solution is that you e-mail / call the support and agree on further steps with them.

BR
HonestJay

4 Likes

Ok, thats good news.

Did they give any hint how long they expected it to take until a official solution can be released?

Calling support seems to be quite cumbersome - for both, customer and support…

That’s just my absolutely inofficial interpretation of how things are going, but as far as I understood, they haven’t found a solution yet, what would mean, that a patching date is still unknown.

Great. Just great. Wrote the support now until I get an answer, I have to use my old samsung.

I have succeeded in downgrade to 1.3.6 by flashing the binary image from a computer, thanks to the procedure explained here (point 4).

My Fairphone is this back in 1.3.6 but all problems remain and it’s very unusual ! How it’s possible ?!

1 Like

Did you read the other posts in this topic?

Rapidly because some texts are very technical. But if you believe that the solution is there I can read all. But I already spent an half-day to search in forums, reset and install OS, and contact Fairphone by phone…

To make things short:
It’s not a software problem, it’s a problem caused by the firmware, which is, simply spoken, located under the software layer.

With the last update, a firmware update and an OS update were deliverd. So changeing anything on the OS will not help you.

If you follow my advice sent via PM and written in this threat (==> call the support), your problem will be solved. Re-installing, downgrading or anything else won’t help you, due to the fact, that there is no firmware downgrade available yet.

BR

1 Like

Could the support stop your phone from rebooting?!

1 Like

No, the response of the support was : “we don’t understand but we will examine your ticket” (https://fairphone.zendesk.com/hc/en-us/requests/112053).
After reading all this conversation, I confirm that I have all these problems, after a lot of reset, flashing, reboot and so…

Some discussions are about 4G and it seems relevant, because after reset and installing OS, my phone automatically opens the 4G, without my permission !

My baseband is nos : 4275.1-FP2-0-02

So you called the support and they said, that they don’t understand the issue?

If those problems occour since the 1.4.2 update (and if before, everything was okay), I would assume, that you are one of those, who are affected by the firmware update. Of course, I’m not an expert and so this is just an assumption which is only based on the facts I got here.

I found their response strange, but the phoneline was very busy, and I suppose they face to a lot of problems. I wait few days before to call them again. My ticket is full of images and videos to show what’s happen…

But it should be possible to copy the firmware to and from sdcard with TWRP. That is:
mount-> firmware, advanced - > Filemanager, click on the button bootom-right, chose copy folder.

Irina_spitznagel hasn’t yet updated and perhaps she’s able to help you ?

If there is a posibility to extract the Modem/Baseband firmware from a not-yet-updated device, this would be worth a try. However, I do not believe the Modem/Baseband firmware is easily accessible.

You have TWRP as recovery? Then give it a try …
… first to look at those files.
… second to copy them to sdcard
… third rename one small file
… fourth copy it back to the firmware-folder (just as test)