English

FP2 keeps rebooting after update. Can't rely on it for productive use. Need (downgrade) advice

Hi guys,

the last update made my phone unusable as a company phone. I’m also using the second SIM slot for my private SIM, what makes things even worse.

I installed the OS version 1.4.2 by using the simple mode of the updater app from OS
version 1.3.6. Since the update (I also re-installed the update again by using the updater app) the following things happen:

  • The screen sometimes flickeres
  • My phone restarted around 10 times per day, while using it. And around 2 times, when it was not in use.
  • I had absolutely no problems with the OS version 1.3.6

I opened a support ticket on thursday. Nobody replied yet. So today, I made a clean install. I made a factory reset from the recovery mode and wiped the cache. It took around 3 hours to, to re-install my apps, setting up the phone, etc. After having set up everything, the phone kept restarting. Although the phone app stayed black during a phone call and only “unlocked” the phone, if someone answered the call and hung up later.

@rick told me in the 1.4.2 update threat, that a manual downgrade would be possible. But after I reset the phone with all the settings I set up this afternoon, I tried a manual installation of the OS 1.3.6. But before the installation starts, I receive the following error:

Verifying update package...
Installing update
Can't install this package (Wed May 18 21:49:50 SGT 2016) over newer build (Mon Jun 6 12 53:42 SGT 2016)
E:Error in /sideload/package.zip
(Status 7)

Installation aborted

Has anyone an idea how I could fix my phone? For being honest, I don’t really care how, but I need a phone I can rely on. Downgrading would be fine. But I don’t know how. I would really appreciate, if I neend’t root my phone.

Any ideas?

[EDIT 2016-06-23]
If you are facing that issue, have a look at my #26 post: Right now, the solution is that you e-mail / call the support and agree on further steps with them.

1 Like

As you already lost all your data, I would say to back to the factory settings and from then on upgrade up to 1.3.6.

And that’s exactly my point (no offense) :grin:

I have no idea how to get back the factory settings. When I use the recovery mode like described in this article I’m still running on 1.4.2. And when I try to install the older update, I get the error message above.

So how can I downgrade? :slight_smile:

Flashing the binary images should overwrite the entire contents of the phone (though it would never hurt to wipe the cache partitions from recovery to make sure those are reset as well), without complaining about versions. Fairphone’s Support article on manual installs has advice on how to do this in Method 4. You will lose any and all data on the device (Just in case others try this).

Would be good to know whether downgrading makes the problem go away again.

1 Like

Thanks a lot for sharing. Didn’t see at first, that there are several ADB methods available.

I will try this in some days. At the moment, I’m running with a clean installation without contacts, calendar, etc. I will install app by app and backup folder by folder, to see if I can find out where the problem comes from… Guess, next week will feel like hell :wink:

Same problem here, the phone was working flawlessly with 1.3.6 until a few day ago when I updated to 1.4.2. Since then it keeps restarting on a short time scale. The phone is completely unusable a.t.m., so currently I have to use my old crappy Samsung again :frowning:

Concerning the downgrade, I tried that already, a fresh install of 1.3.6 using fastboot. This did not help in my case! Althoughthe phone was working very stable on 1.3.6 before, now, after the 1.4.2-update and a fresh 1.3.6 install, it is still rebooting regularly.

In case you identify a critical app, please let us know.

1 Like

That’s pretty interesting. Here is what I did. Perhaps we can find any similarities:

  1. Wipe data / cache and restart
  2. Active GMAIL Account / Stop Sync
  3. Install Signal / Threema / AntennaPod
  4. Import Threema / Signal Backups

==> Phone keeps restarting

That’s it. Due to the fact, that I synced some of my contacts via owncloud / CalDAV App on a previous installation, so I assume right now, that there could be a problem with some contacts. I’ll try it out today and will report.

I can’t figure out what causes the errors. I re-installed several times know. Whatever I do, the phone restarts. That was my last try:

  • = doesn’t cause the problem, because the phone restarts also if I don’t do that
  1. Wipe data / erase cache
  2. Enable W-LAN
  3. Login with GMAIL Account
  4. Turn off all Google sync activities
  5. Change Auto Turn-Off Display time to 30 minutes*
  6. Upload Contacts.vfc from PC to the phone and import contacts*
  7. Install Threema + QR Scanner Plugin
  8. Sync Contacts on Threema*
  9. Install Signal and made it my standard SMS App
  10. Install Antenna Pod*

Will downgrade now. Any other ideas yet?

That’s a total f**k up here! :joy:

Although I downgraded to 1.3.6, the phone still reboots from time to time. Support doesn’t answer my ticket. What can I do right now?

Google wants you to sync your contacts to Google. Do I see it right, that you don’t want to sync your contacts? If yes, how?

Thanks for that one, I made it a bit more clear above.

After login with my credentials, I went to Settings -> Accounts -> Google and pressed on MyMailAddress@gmail.com. There I deactivated all sync activities.

Regarding my problem it does not matter if I sync, import my contacts or do nothing of both. I tried all 3 settings after a clean install, but the phone keeps restarting.

I took a look at the update file itself, and this seems to be the first time it contains a firmware-update folder. In it is, is what I suspect is a Modem/Baseband firmware update along with some other files which could do similar things. This may be written to memory that is unaffected by flashing the binary images - though my knowledge on this is limited, so I could be wrong. As I cannot find a previous update that contains this firmware, I also wouldn’t know how to downgrade it.

@HonestJay Could you post what shows up in Settings > About Phone > Baseband version?
If anyone hasn’t (ever) updated to 1.4.2. (@Irina_Spitznagel?) , could you post which version you’re on and the baseband version as well?

Any comments from @rick on the (im)possibility of downgrading?

2 Likes

Well, I’ll eat my hat if that is not the reason. That, or a hardware failure, e.g. due to overheating during the update.

@HonestJay: Did you try to disable 4G? This helped slightly in my case. After disabling 4G the reboots happen less frequently than before, yet they still happen too often to use my phone for anything useful. (And the behaviour seems to be coherent with the Baseband firmware theory.)

My phone continues to reboot even without any sim card installed.

My baseband version: 4275.1-FP2-0-02

1 Like

Well, if that firmware is the reason, then why does my phone works flawless?

I had it with other phones: they crashed, when Google-apps could not do what they wanted. So try to deactivate such apps - especially Google-framework… By the way: it’s easier to deactivate Gmail then to deactivate sync everytime the phone starts.

Spielmops

Me too.

I can confirm on that one.

Also same on my side.

Would really appreciate some further information on the Modem/Baseband firmware update. Thanks so far!

1 Like

Yes, I haven’t run any update yet, I’m still on 1.1.7.
My baseband version is: .DI.4.0.1-00161-M8974AAAAANAZM-1

2 Likes

I guess it is a calibration issue that varies from phone to phone. You are probably just lucky enough to own a piece of hardware that works with the new set of calibration parameter. There have even been reports in this forum of phones that were problematic in the past and now run smothly after the 1.4.2 update.

I do not think Google apps are be problem here, I had reboot behaviour also with a fresh “Fairphone Open 16.06” installation, without any Google app installed.

2 Likes

To add to what’s above, this could also be dependent on the SIM that’s being used. There was a fix for some SIM cards not working properly with the FP2 in the 1.4.2 update; it may have unintentionally introduced some other incompatibilities that only show up depending on very specific conditions. If the phone runs fine in the absence of any SIMs, that would point to such an incompatibility, but as I don’t fully understand these updates it could just as well be something else.

To be clear, this is just a hypothesis to explain why the behaviour survives a system reset by flashing a new image. Given that the issues also exist in FP Open OS 16.06, I’m hesitant to blame it on a coincidental auto-update of other apps.

Though, checking the broadband version on 16.06 it seems that it still uses the same firmware as earlier versions.
At least on my 16.06 installation I have the same baseband version that @Irina_Spitznagel posted.

I also don’t see the same firmware upgrade in the FP Open OS files, though they do seem to packaged differently in general. If the baseband firmware is stored in memory that isn’t affected by overwriting from a binary image, then once you install 1.4.2 you’d be stuck with that baseband version until a new firmware update is packaged with a software update. If we assume that there is no baseband update in 16.06, installing 16.06 over 1.4.2 then wouldn’t revert the baseband version. But this is based on the assumption that @freibadschwimmer never installed 1.4.2.