English

FP2 keeps crashing - Endless reboot loop

My FP2 keeps rebooting at any random moment.

When this happens it gets stuck in the initial “FAIRPHONE - powered by Android” screen. Usually it keeps rebooting again and again in and endless boot loop and doesn’t go further from that screen, and then I need to remove the battery to stop the loop. In other occasions it makes it past that screen and goes on to the blue Fairphone screen.

In the blue Fairphone screen, sometimes (very few times) it goes on and starts the phone. Some other times it gets stuck half the way of the blue moving thing, and then it goes to this “Android is starting… Optimising app X of Y” (of note, the value Y keeps changing at each round). Sometimes if fully loads the blue moving screen and then still goes to “Android is starting… Optimising app X of Y”.

In the “Android is starting… Optimising app X of Y” phase, sometimes the process gets stuck and/or the whole thing reboots again, and back to scratch. Sometimes the “Android is starting… Optimising app X of Y” process finishes and finally the phone actually starts. Unfortunately, it will only work for a few hours and will eventually reboot and start all over again.

In this process, and in the few occasions when the phone is working, it gets very hot in the area next to the camera objective.

This all started about 1-2 months ago. For a while the phone would just get stuck randomly (both while using it or when resting) and I would have to take off the battery to restart it. It restarted normally and worked fine other than that. The phone was getting stuck once a day on average. By then I was running my phone on OS 1.12.0.
In the last 2 weeks it got much worse as I described, and all the things described above are happening at the moment. I literally can not use the phone.

I have gone through the FP2 troubleshooting, and tried several things including:

  • I have updated the OS to 18.1.0
  • I have done a factory reset (without restoring any backed-up data or apps), and tried to use my phone without installing any app other than the google apps that come by default.
  • I have removed the two SIM cards and tried to use the phone without any SIM cards on it.

None of the above seem to make a difference, the problems keep being the same.

Unlike many other users with a similar problem, my battery does load normally. It runs out of battery quicker than normal if I leave the phone on the endless reboot loop, but still last for 5-10 hours.

I have put a request to customer support but haven’t been contacted back yet, after 10 days.

Hopefully somebody can help me fix this problem.

2 Likes

Is this a beta version? Latest official release is 17.08.1 as of now.

General consensus in the forum is that you get faster results by calling them.

1 Like

Some slim cases had a problem with the power button getting stuck. It’s getting constantly pressed this way, and as a consequence the FP2 reboots again and again. You might want to check if this is the case with yours.

Other than that, I can only suggest to check the suggestions here:

I assume you already went through this, but for completeness sake: https://support.fairphone.com/hc/en-us/articles/115001041206-Troubleshoot-your-Fairphone-2-issue

2 Likes

Sorry about the 18.1.0 thing!! I messed up with the numbers, I meant 17.08.1 indeed.

Thanks for the tip, I’ll try calling them

The problem persists while turning on the phone without any case on, so I discard that.

I have gone probably through all threads with similar problems, and nothing made a difference:

  • taking out all sim cards (phone has no SIM cards or SD cards in and keeps doing the same thing)
  • happens at any moment, either while charging or not
  • Hard reset, and trying to use phone with no apps at all; same thing.

Basically, after the hard reset (factory reset), my phone is just like out of factory (no apps, no SIMs, no SDs) and keeps looping and crashing

Hey everyone,

after updating my phone to the mentioned OS version, I am running into the very same issue. Phone reboots after showing the “fairphone” logo for about 8-10 seconds.
The reboot cycle never goes past the 10s mark and keeps occuring.

  • I’ve factory reset the phone
  • Removed both SIM cards
  • Removed SD card
  • Removed hard cover
  • Removed battery and rebooted

Since this phone has only been replaced less than a year ago and I barely used it, it comes as a surprise.

Thanks for any advice,
Chris

Do you mean:

?

Why didn’t you update to the latest version?

Hey @paulakreuzer,

thanks for your reply!

I am currently running on 1.13.0 since I also tried and erased all data -> established factory mode.

The updater now is offering me to upgrade to 17.10.2 and after downloading and trying to install it gets caught in the vicious reboot cycle. Only solution is to remove battery and wait a few minutes. But then it did not update and still runs on 1.13.0.

Any ideas on how to fix this?
Best,

Chris

Then I’d try to update manually via recovery.

3 Likes

Excellent advice @paulakreuzer - we’ve solved the reboot issue and it seems stable for now. Thanks again for your help! Yay!

2 Likes

Hello there Maria!

I am so happy to discover your post since i have the exact same reboot loop at the moment and it drives me crazy not knowing the reason for this.
I was thinking to either change the software (by e.g. installing ubuntu touch) or maybe ordering a new hardware and replacing the thing that overheats all the time (the cpu is it?).
Did you find a solution foe your Problem yet?
Does anyone know if there might be an app running in the backround that causes the crashing and how i could find out which one?

Truly thankfull for any response!
Best,
Mia

1 Like

exactly the same problem for me, just rebooting randomly
all the times. It can be more than 20 times a day.

hope someone will find a fix

Please check out the #rebootsguide.
If you “just” have random reboots and no endless reboots loop as described here then you’d be right in this topic:

FP2 random reboots - see #rebootsguide for help

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.