FP2 Headphone Jack adapter CTIA to OMTP

I tried to get over the long standing problem that i have 3 iPhone headphones. Fully Audio functional but the Volume, Mic and the Button doesn’t work. Bader i have to pull out the headphone to if somebody calls me. So i checked the cabling and found a adapter on ebay. this one
So i ordered 3 and got them today. But else than expected it doesn’t work. Actualy its extreamly weard and i wol like to know what you think how thats possible…

If i listen to audio it works but sounds weard like phaseing, if i then press the button it sounds good as long as i hold it. Volume and mic doesn’t work. So i thaught the adapter might not be what they say it is.
so i cut one open and measured it. and its exactly what i expected.
Tip to shaft pin1-4 its like this: 1-1, 2-2, 3-4, 4-3.
So im puzzled about why.
If Fairphone says its a CTIA connector and the iPhone Headphone is also a CTIA as i now read here then why does the Mic not work? At least the mic should do its job, not?

It’s probably some kind of proprietary Apple-doesn’t-want-to-cooperate-with-Android driver issue… :stuck_out_tongue:

Edit: Found this in an ars technica forum:

[quote]Apple uses CTIA plug wiring, but is not CTIA compatible and the three button remote is why. There’s no room for that in the CTIA standard and Apple has implemented it in a way to ensure only Apple’s approved accessories can work properly.

You’re not going to be able to handle calls properly if you mix Apple anything in with standards-compliant anything else, it’s just how Apple implemented that remote. If you must use Apple stuff, the iPhone4/S style two button remote cables work fine on CTIA Androids. One of the buttons doesn’t work, but you expect that.[/quote]

1 Like

Thats realy awful!

The List of Headphones in this Forum has this sentence in Partly working Headphones:

Continuing the discussion from :pencil2: List of compatible Headphones and Headsets for FP2:

the full listitem:
Apple Earpods with remote and mic18 Corded in-ear. Sound out is fine, Buttonclick pauses music, but mic does not work. Tried 2 sets. Worked including mic on FP1.

I doupt that that is true. Can somebody check?
Regards, Novski

maybe this has to be worked over as well:

Continuing the discussion from :pencil2: List of compatible Headphones and Headsets for FP2:

[quote=“Douwe, post:1, topic:12268”]

Working hypothesis, waiting for an official statement:
FP1 uses OMTP (ground=1)
Official statement (01. Feb 2016):
FP2 uses AHJ=CTIA (ground=2)

A possibility is to use an adapter, e.g. this73.
more china-stuff has to be bought, remote buttons could stop working,
price (in my case again the same money as the headset did cost)

There is a chance that your headphone jack on the FP2 is broken (that means the microphone contact inside the jack is not connected). Please try it with third-party headphones. If these are also not working, please contact support and ask for a new top module.

1 Like

its on 3 x FP2 the same, that wold be a big coincidence…

Stil im wondering why the Mic worked on a FP1 with OMTP connector and does not on FP2 with CTIA to OMTP converter cable… makes no sence. so some part of the information in the List of Compatible Headphones and Hedsets for FP2 is wrong.