FP2: Google Messenger does not send any text messages


I would like to use Google Messenger instead of the default SMS/MMS app, as it remembers my selection of SIM1/SIM2 for a given conversation. (With the default messaging app, it is necessary to select the SIM with every single message that is sent - or re-configure the settings for a given SIM.)

Google Messenger is set as the default SMS/MMS app. While receiving texts (SMS) works just fine, Google Messenger does not send any messages: when trying to send the message, a short negative sound can be heard, but the text does not appear in the conversation history and the message is not sent over the air.

Any other experiences with Google Messenger on FP2?

Thanks and greetings!

Is your Privacy Impact enabled?

Yes, default configuration: I’m being informed about the privacy impact on first launch of an application.

Please go to the Privacy Impact again. Sometimes you have to re-enable the Privacy Impact more than once.


Google Messenger does not support Dual sim. I recommend you use Hangouts as your SMS app, or the default Android Messenger on your FP2.



Whether I check the Privacy Impact setting or not does not seem to make any difference here: Google Messenger keeps denying to send any messages.
It does seem to recognise that there are two SIMs installed, as it lets me select the one I want - only as soon as I enter some message text the SIM selection is replaced by the “Send” arrow. But pressing this only gives me an error-sound - nothing else happens.

1 Like

@anon12454812, while my version of Messenger recognises that there are two SIMs (but fails using any of them :wink: …), I cannot find any settings in Hangouts where I could configure / select one of the SIMs. For me, Hangouts always sends text messages using the 2nd SIM.

According to https://support.google.com/hangouts/answer/3441321, Hangouts is described not to support dual SIM cards. Have you managed to get it working with FP2?

@amers That’s true, I was wrong - Hangouts does not support Dual sim, that’s why the Android Messenger app was added so you are able to use dual sim for SMS on the FP2 :slight_smile:

Quick update: “Signal” has just added DualSIM support: http://sgnl.link/1LoIMUl

It defaults to SIM1.
SIM2 can (must) be selected by a long press of the send-arrow. This must be done every time you want to send a text with SIM2, but if you rarely use it like is the case for me, this works just fine. (I posted a feature request to have the app remember the selected SIM for each conversation - let’s see if they can add something like this some time.)

And it’s back to only one app for both secured messages and SMS texts :slight_smile:

UPDATE and correction: Signal already HAS a “sticky SIM” implemented:

  • It does remember the last SIM-selection for a given conversation when sending a text.
  • If the peer responds to the other SIM, this does not affect this setting.
  • (And probably: testing the SIM behaviour by sending texts from one of my SIMs to the other of the two in my phone, did not seem to help identifying the actual real life behaviour of Signal :slight_smile: …)

Hi everybody, I received m’y fp2 few days ago and still can’t send any message using messenger. I just have one sim installed. Thanks for your help. I’ve tried the privacy solution but without success.

1 Like

Hi @Edouard,

my “solution” was the new version of Signal (I have Signal installed and in use already anyway) so I neither need nor want Google Messenger anymore for my current situation.
However, I had opened a request with Fairphone support that included the problem with Google Messenger - as soon as I get an answer from them, I will keep this thread updated…

1 Like

Thanks for that, I also post a request to the support team.

Fixed with software update version 1.5.1: Google Messenger does properly send/receive messages on FP2 now.

Will keep using “Signal” though. :slight_smile:

1 Like

Finally! :wink:

I was using the Signal Messenger as well (after reading this topic), but now I will use the Google Messenger because of some features like muting a conversation (like publicity) or individual tones or colours for each contact - hopefully it will work :wink:

I installed the update yesterday and since I read in the changelog that Messenger is now supported - actually a system app - I gave it a try. Strangely it imported automatically all messages until April 3th…
So I did an export from Signal and then used the SMS Backup & Restore App to get the missing messages back. Worked very well.