FP2 goes off and blinks red LED

Hello there. (from a french FP user, so please don’t pay attention to the language) :sweat_smile:

I had twice the same issue since I received my FP2 two days ago :

  • the phone seems dead (no display, no led, nothing by pressing any button or connecting charger)
  • after randomly removing/putting back battery, and unplugging/plugging the charger I manage to get the LED blinking red (one blink a second)
  • after some time, the LED turns solid red, and if I wait enough time (for the battery to get a minimal charge ?) the phone will eventually turn on by pressing power button

It happened while the phone was connected to a power source. (and was actually charging when I looked)
Once while I was using it and without any message preceding the sudden shutdown, and once in the morning, after the phone being turned off for the night and charging for 8 hours : the LED wasn’t green (neither red) in the morning, and the phone wasn’t responding at all.

I tried several chargers/cables that all appear to behave well : the charge is successful when the phone is acting normally.
I couldn’t find the meaning of this quick red blink.
Could it be something with the battery ? I read here that in some cases a battery reset should be attempted, but that could be risky… and it might be unnecessary on a brand new phone ?

Any idea ?
Thanks very much for you help !!

I have experienced “the dead phone with blinking red” a few times. But it is always using the same chargers. I have one charger that this do not happen so I only use that one, but I do not know what the blinking red light is a sign of?

In some other posts I have tried to identify if my battery is broken (lasting only around 10 hours if not used). Is also your battery draining, or do you think you have a normal amount of time playing around with your phone after charging before the battery needs to charge?

1 Like

I had the same symptom with my new phone out of the box…
I guess it happens when the battery gets deeply empty.

I just saw the same with my phone. In my case, the “sudden shutdown” as you call it (I call it “freeze”) was caused by a somewhat common problem that the phone doesn’t respond to anything other than a long-press (~20s) of the power button…

See the related thread “FP2 Frequent crashes requiring reboot by holding power button >10s” for further details of that problem.

After having it plugged-in for a few minutes (I used my computer screen’s USB port for that), the flashing stopped (LED goes solid red) and the phone started and everything seems normal.

Therefore jaymanu’s reply appears to be correct.