FP2: Fairphone OS 19.05.3 release

@Pons, maybe a bit more practical help. I think it is just a failed/corrupted download. If rebooting does not bring you back to a working phone (allowing you to download again), try a manual install of the OS: https://support.fairphone.com/hc/en-us/articles/207914363-Manually-install-Fairphone-OS-for-the-Fairphone-2


Very good. I just now read “The user data will not be erased.”
I thought manual installs would wipe the phone. Learned something again :slight_smile: .

Thanks a lot, I will take a look at the presented possibilities!

https://support.fairphone.com/hc/en-us/articles/207914363-Manually-install-Fairphone-OS-for-the-Fairphone-2?fbclid=IwAR2ZAEMG0LKjCjTi5z8IzowTXVSQOVOZwCgop5XHTJYM4vW9DtrwsBVDjrc THE ANSWER !!! :slight_smile:

It happened the same to me. I’ve followed this steps to get back to 19.02.1, I hope it helps you: https://support.fairphone.com/hc/en-us/articles/207914363

Where can the binary of version 19.05.3 for the manual install be found?

1 Like

They only have the 19.02.1 version in the manual install page

That’s why I asked :wink: The FP-Open Files are already available, but with a different version number (19.05.2 instead of 19.05.3), cf…


Another case of being stuck in recovery here. Error E1004. Trying the revert back to 19.02.1 now.

Revert to 19.02.1 worked. Will postpone the update until it’s safe to do.

For the Fairphone Open files they needed only 2 steps, whilst needing 3 steps for the ‘normal’ version.

1 Like

Ahaaa, interesting… you learn something new every day :wink:

Any idea on that?

My phone froze in the “powered by Android” screen after rebooting the 19.5.3 update. I had to follow these steps: https://support.fairphone.com/hc/en-us/articles/207914363. It allowed me to restore the 19.2.1 OS version, the apps and Google data. You can download the 19.2.1 version from here: https://code.fairphone.com/projects/fp-osos/user/fairphone-open-source-os-downloads.html

It seems to be working fine, but I still haven’t updated it again to the latest version.

Honestly, I love the phone, but it has troubles almost with every update.

That’s part of the fun having a sustainable phone: you learn to understand the tech a bit better with every update :wink:

1 Like

Sorry, is it this one, at the bottom?


1 Like

Well, presumably I could switch to Fairphone Open on 19.05.3 first and then switch back to Fairphone OS… But that seems a little redundant :confused:

1 Like

@chrmhoffmann Is H.264 hardware video decoding already working in LoS :)?

Update went smooth as every update until now. Stayed somewhat longer in some of the screens it went through but with some patience it finally came up without any issues. This time it even didn’t optimize any apps which in the past caused quite some heat in the phone.

Hi, my upgrade went well, but afterwards Play Store got stuck again and again. I never made it to my apps to check for updates. I had https://www.makeuseof.com/tag/4-simple-fixes-google-play-store-problems/ and fixed it by de-activating the Play Store app (i.e. back to factory version) and getting it automatically updated after re-activating it. So if you experience this issue, I hope this saves you some time. :slight_smile:


Hmm, it gets stuck again.:face_with_raised_eyebrow: Is this general issue in/with the current Play Store app or one of those it depends on?