FP2: Fairphone OS 19.02.1 release

Fairphone OS 19.02.1 is now available. You can get it through the Updater.


Issues fixed since the first official Android 7 release (Fairphone OS 18.09.2).

Please report any (new) issues through the public bugtracker and upvote existing issues if you are affected. As usual, please specify the steps to reproduce, and provide as many details as possible.


My phone is now ‘Running Recovery Commands’, which previously was just displayed as a robot with gears?
It shows this red text at the top: unable to find partition for path ‘/system’

Also, in this mode I get an overlay saying ‘swipe to unlock’ but I can’t swipe, it does not respond to touch. Otherwise it seems the update continues without any problem.

1 Like

I can confirm my phone updated successfully after what happened above, and it boots correctly when connected to the charger. I’m using the old camera module and don’t have a second SIM in it right now so can’t comment on the other issues.

1 Like

Update went smooth with no issues. Thank you!


Thanks, people ! I had no problem with this new update, only the reboot takes longer.

1 Like

Initial Android7 release 2018.09.x updated itself to todays 2019.02.1 or so without trouble. via Wifi. Update went with a number of technical messages being shown onscreen, rather than logo or hiding stuff from the end-user. But everything went smooth as far as I can tell so far. Regards.

1 Like

Stuck on boot animation after update, rebooting doesn’t solve it. I foresee a night of troubleshooting…

Edit: had to go for the factory reset, grumble grumble.

What version were you coming from? Did you have any modifications to your system partition installed before updating?

On my FP2 with 18.09.2 installed, WIFI connected, and more than 50% battery capacity the download doesn’t start in Updater.

Is this a staged update once again?
Perhaps Updater and phone for some strange reason just don’t display that the download is going on?
What can I do?

I have tried four times and waited up to half an hour. And also rebooted the phone. This is the first time I have problems with FP2 updates.

The download was successful at work via company WLAN. What are the requirements checked by Updater before downloading the update? My WLAN has an average speed. It supports all common internet based activities and services. What can I change in its configuration in order to enable future updates at home?

Coming from 18.10.0. Xposed was probably the culprit here, if I had to guess. The system couldn’t be mounted while upgrading in TWRP. After it finished, the device rebooted into the eternal bootscreen.

I have backups for everything, so all is well.

1 Like

Everything went well. I came from the latest 18 version and had the 2G problem. Now it has been fixed and i could switch from 2G to 4G again.

Thx very much!

1 Like

At first encountered the same problem here (18.9.2, new cam module, single sim). After switching from 5 GHz to 2,4 GHz (!) update was downloaded swiftly. Installation took some time (esp. the initial boot screen, be patient). Phone is now up and running well. HTH.


If it would be staged, you would not see the update-possibility.
Well, I aint notified of the update. My updater still claims 18.09.2 to be the latest version.

Would I have to install that first?
Anyway, as I read of some problems regarding the update here in this forum and can’t afford to loose connection or spend hours on fixing my phone, I will wait some more. :wink:

Would I have to install that first?


FYI: The Fairphone Open OS update is discussed here. :slight_smile:

1 Like

I just realised that like an absolute idiot, I posted in the wrong topic. I’m on FPOOS, so my issues with upgrading are not FPOS-related.

Yes, sorry for cross-posting, misled by the question.

The question however is still interesting and probably applies to both systems: it appears to me now that if you use automatic updating then you need to pass through the intermediate updates to get to the latest one. I suppose that a manual update would avoid this hassle. Any experience regarding this specific matter?

It appears push messages from my bank (N26) are broken since the update. Does anyone else also miss push messages of one app or another? If not, I’ll have to blame the bank app for it.

1 Like

Thanks - the update worked flawlessly for me.
I just got a little bit taken by surprise by this “low-level-details”- screen on the the first reboot. For a moment this had been “oooohhhh shiiii…” to me - then I relaxed…
And the update fixed this annoying “shutdown-only-with-torchlamp-on”-bug I had with the new camera module.
I’m still amazed to have Android 7 on my phone and also amazed by the time a battery charge is now good for.
Thanks !

1 Like