FP2: Fairphone Open 19.11.2 release

Fairphone Open 19.11.2 is now available. You can get it through the Updater.


Issues fixed since the previous Android 7 maintenance release (Fairphone Open 19.08.1).

1 This release includes a new system setting for enabling OpenGL ES 3.0 support. On first boot you will receive a notification linking to the setting. You can also find it in Settings → Maintenance → Enhanced 3D graphics support.

Please report any (new) issues through the public bugtracker and upvote existing issues if you are affected. As usual, please specify the steps to reproduce, and provide as many details as possible.


Stuck in bootanimation, as usual with updates. I don’t know what the problem is, possibly something to do with Xposed?

I’ll leave it to attempt boot for a while, but I guess it’s another factory reset, which has reliably fixed the issue so far.

Edit: factory reset fixed it. And now, an evening of tinkering to restore all the settings.

I think manual installation would have done the job as well without losing settings, wouldn’t it? Anyway, this is why TWRP got the boot. :frowning:

1 Like

Nah, tried manual. A couple of times, with SD and SIM removed even, just to be sure. Upgrade finished successfully, no errors, nothing - and it just won’t boot. No clue what’s going wrong, but that’s what backups are for. I’ll have my FP2 back the way I like it in a few hours.


Hi there!

Update went flawlessly, as usual for me. Everything looks fine so far.
Thanks for the great job. :wink:

Update went fine.
But installing OpenGapps 7.1 arm pico fails.

Finally got everything back to normal. Wifi still a bit iffy on my Fritzbox (or whatever spelling suits the reader).

Update went smooth, phone started feeling hot immediately afterwards.
Activated OpenGL 3 and deactivated it a few times.
It doesn’t feel hot now, but the phone drains a full battery in about 4 hours.
Any ideas?

1 Like

This failed with the bundled TWRP version with earlier OS versions, too. I guess when it comes to installing stuff the bundled recovery only does OS updates.

Just install a recent TWRP from twrp.me again and try with that.

Odd, TWRP is giving error message “Invalid zip file format!” on both OTA and manual installation modes. Maybe because I had to manually upgrade TWRP (3.3.1-0) after installing 19.08.1?

Just to make sure, you do mean installing the update via fastboot when you speak of “manual installation”, right?


Which TWRP version are you using, and which file exactly did you try to install with TWRP?

Tried from TWRP (3.3.1-0), how stupid… Fastboot worked fine, thanks!


I tried that, but twrp.me is giving a error. I can’t reach the website, not on my phone, not on my computer.
Can you try it for me to see what is going on?

I can reach the site @AnotherElk linked to, but I for my part have always used this – apparently – more specific one anyway: https://dl.twrp.me/FP2/

1 Like

Strange I also can’t reach that website.
‘This site can’t be reached’.
“The IP-address of the server of dl.twrp.me can’t be found.

Works for me.

Have you checked if you might still have the .zip file somewhere on your SD card? Or should I upload it for you here in a PM?

O please upload it for me. It is not on my sdcard and restoring of the twrp-app through my Titanium backup isn’t working.

Little guide to reinstall OpenGAPPS Pico:

Update system
Reinstall TWRP:
Connect your Android device to the PC. Type the following into the command window to boot your device into bootloader/fastboot mode:
adb reboot bootloader
If your asks for permission to “Allow USB debugging”, tap OK.
Once your device boots into bootloader mode, type this into the command line.
fastboot flash recovery twrp-3.3.1-0-FP2.img
Hold power to power down, hold power and volume up to boot into recovery
Check TWRP configuration, reinstall OpenGAPPS from memory or SD card
Reinstall Xposed
Activate High accuracy location, agree to Google terms
Reinstall Widevine
Fix app permissions, disable G00gle Play services and G00gle Play Store permissions (except for location) block location for unnecessary apps

1 Like