FP2 doesn't boot

Hello everybody

I’m facing quite some troubles with my FP2 right now. It’s not possible to boot anymore. I get stuck in the very first black screen reading FAIRPHONE.
The animation doesn’t start at all. I’m able to go into fastboot mode (blue LED and three vibrations), but then nothing happens and I don’t see the device via adb / fastboot… when connected to my computer (Mac OS).
I can’t access recovery mode either.
OS is the most recent Fairphone OS Version, I took out both SIMs and the SD card.

But now comes the strange part: sometimes it works to start up for a really short time… Sometimes the animation appears and it crashes either after the start animation or I even get into the system but it crashes shortly after.
Yesterday I used my old battery pack and the phone was able to start and worked for quite some time until rebooting and getting stuck again…
So I thought it could just be a battery problem but:
I charged both battery packs and the animation of the charging battery when it’s plugged in appears (from time to time at least). And I don’t get any further from there.

Do you have any ideas how to fix this issue? I really need the phone…

Thanks in advance for your help!!

Welcome to the community forum!
Do you have a recent backup? I’m afraid you’ll have to try a fresh OS reinstall: :gb: :de: :pencil2: Installing the Fairphone 2 from scratch in case of failure / Komplette Neuinstallation des Fairphone 2 im Fehlerfall
If it’s hardware related, you might want to contact a #fairphoneangel to help you test spare parts. It might also be a problem with the core-module…
When plugging the phone without a battery, do hou have a pattern with 1. FP logo 2. Vibration 3. Blinking LED? If not, you have a hardware problem, either with the core-module or the bottom-module.

Did you already do a search on the forum? I don’t think you are the only one having such a problem and you could find valuable advice.


Hi Alex

Thanks so much for your answer!
I searched the forum before writing, and didn’t find a description that really matched my problem.
In the meantime I was able to start recovery mode once, but the phone crashed before I could do a backup…
Right before the phone started totally normally but crashed again after some seconds… I was able to see messages and stuff on the start screen but when I wanted to go into an app it crashed again.

I plugged the phone without the battery: I just get the logo, no vibration and no blinking LED…
If it’s a hardware problem, how is it possible that it works sometimes and sometimes it doesn’t? And is there any way to find out if the core module is damaged?

I don’t have a recent backup, I will try to work something out… (with fastboot, I’m not sure if there’s also a problem with Mac OS.)


It sounds as though it may be a battery contact issue - sounds a bit strange but I’ve seen issues similar to yours solved with a battery shim.

So please give that a try (I’ll edit this post to add an illustration of the shape and placement of the shim, as soon as I find it on my computer).

Also, I can recommend taking the phone apart to the bare modules, cleaning all the gold contacts, and then reassembling. We don’t know what the problem is right now, so let’s eliminate some easily fixable stuff.


You do get the logo. It might be a problem with the screen and/or the bottom module then, or the core-module, but that’s a bit hard to nail down. If nlthing that you tried or will try works, the it’s probably the core-module.
Did you already try opening up the phone and assembling it again? Cleaning the contacts of the modules with cleaning alcohol?
Do you have a #fairphoneangel in your vicinity that could help you test spare parts, or do you know anyone owning a FP2?

How old is your phone? Is it still under guarantee?

Thank you two for your immediate answers!
I used my lunch break to disassemble and clean the parts with alcohol- unfortunately no change…

@robbert.f: I’ll definitely try the battery shim - an illustration of how to do this would be very much appreciated. Or is there any kind of tutorial? I didn’t find anything with google…

I’m in Freiburg, Germany tomorrow and Thursday, I’ll get in touch.
I bought the FP2 in Spring 2017 so I guess there is no guarantee…

1 Like

I think my (vintage, antique) flatbed scanner may be giving up the ghost! It’s still legible, though.

The shims that FP produced were little pieces of plastic with an adhesive back, they fit precisely in the bottom of that battery bay. A couple of layers of paper tape or some such does the trick too, just stick it on and use a sharp hobby knife to cut off the excess.


Thank you so much!

Good news: Right now the phone runs again! After letting it charge for some hours until the battery was full, I started it again and it booted properly and is still running! :smile: Maybe the cleaning of the contacts helped or there’s something strange with the battery…
Now I backupped everything on an SD card - until now I didn’t insert the SIMs again but will do that later.
Fingers crossed that it keeps running and thank you so much for your help! Hopefully I don’t need to ask again tomorrow or so :wink:


Quite possibly a contact thing, happy to hear you got it working!

If you’re feeling adventurous (I can imagine you’re not, at this point), you can test whether the battery’s making solid contact by holding your phone vertically with the USB port pointing down, and letting the bottom of the phone fall on a hard surface. Not too hard of course, just give it a knock. If the phone reboots, the battery is loose.


I have the same issue but I am not able to check the adb/fastboot.

This happened after dropping the phone in water. The bottom module was not in the water, only the top 3/4 of the phone. We left it in rice overnight (just in case that worked).

The battery already had some issues, I had to build a charger for it. It feels like the battery is very slightly inflated, I am not really sure.

No FFAngels in my area.

Since the display module is a little damaged (we can traces of humidity between the glass and the screen) I’ve ordered a new one.

Any suggestions ?

#neveruserice (<- see link for how to handle water damage)

How old is the battery?
Warranty on the battery is 1 year, if you need an indication whether you could get rid of it for safety’s sake with a clean conscience.
There’s a #batteryguide, too.

The battery is two year old, the spin test doesnt spin much so I guess it’s not bloated after all :slight_smile:

About the rice, thanks, nothing got stuck after all, i dismantled every part to make sure it was really dry.

There may be contamination on the circuity from the water - assuming it was not distilled water or something - that could have been left behind after the water evaporated.

If you can get any to hand, 99% IPA would work well to clean everything; if it was me, I would disassemble the phone (unscrew all the modules), give everything a wash and scrub with IPA and a clean toothbrush, let the IPA all evaporate off, reassemble and see what happens. Of course, it may be some kind of permanent damage, but if it is simply contamination this should fix it. IPA is commonly used to clean electronics because it does not leave behind an electrically conductive residue and evaporates away very quickly. In fact it is sometimes used to remove water because when it evaporates it takes any water away with it too :slight_smile:

1 Like

Isopropyl alcohol I guess?

1 Like

Thanks, I did unscrew everything, wiped it with a tissue.

Since the screen appeared to have water stuck, I ordered a new screen but the issue remains (stuck on the fairphone logo with the blue led after 3 vibrations).

After another look I did notice some kind of red paint on the core module… Any ideas what it is ?

What you describe is fastbooting (three times vibration, blue LED). Maybe the lower volume button is stuck while the power button is pressed.


The red bits are water indicators. They were white, but turned red upon contacting water - no surprises there.

This does sound like it’s booting to the bootloader, like DeepSea said. Can you press and wiggle the volume buttons a bit to see if they’re stuck and can be loosened?


Maybe for some reasons there’s a problem with system installation. You might try a manual install of the OS…

1 Like

Yes, sorry I should’ve explained :slight_smile:

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.