FP2 doesn’t charge (even with new battery and bottom module)

My FP2 doesn’t charge anymore. After placing a new battery my phone was running for a while (there was still some energy within the battery). But its not charging anymore. This morning I’ve replaced the bottom module, but this doesn’t have any effect. The red charging light is on for a while (couple of minutes) but I’m not able to switch on my phone.

Welcome to the community Forum!

  • Did you have a look at the #batteryguide?
  • How long did you let it charge?
  • What happens when you plug your phone without the battery? Does it show fairphone logo, vibrate and show the blinking LED in a cycle?
  • You could try contacting a #fairphoneangel that might be able to help you test some spare parts.
1 Like

Hi Alex, Thanks for your response.
Ive checked the the batteryguide. Ive charged for ca 5hr, but notting happend the red led only swiches on for a short time.
When I plug my phone without the battery, nothing happens… does this mean that its something else than the battery/ a charging problem?
Ill try to contact a #fairphoneangel! Thanks for your help.

The problem might come from the core-module. Or you could have a second defective bottom-module or battery (which is possible, though statistically not likely).
I have had a similar problem with my phone, it was caused by a kernel wakelock. I had a big battery drain, and one day, it just didn’t want to charge nor switch on anymore, though the red light would switch on for 5 seconds and then switch off. The problem was with the core-module. Is your phone still under warranty?
I hope you’ll find a #fairphoneangel able to help you.

1 Like

You could also try it with a different USB cable and USB power adapter.
There might be something wrong with your cable/power adapter and thus the phone won’t get enough energy to start charging…


Unfortunaly its not related to the cable/ power adapter. Ive tried several ones.

1 Like

Have you tried several plugs, and not just one?

1 Like

Yes I did, Ive tried several plugs.


Hi I have the same issue. Can’t charge the battery. Red light is on for like 5 secs and then gone. Charging it without battery also doesn’t help. Just got my new battery and bottom module. It didn’t change a thing unfortunately.
Were you able to fix your phone by now?

It doesn’t do anything? It just stays black?
Then you probably have a hardware defect on the core-module…

1 Like

Hi Alex,
Thanks for your response.
Yes the screen stays black all the time. I’m afraid it’s the core-module as well…
Is there any way I can save my pictures I saved on the phone? I don’t really care about the actual phone as long as I can somehow retrieve my data.

I’m afraid not… Perhaps by retrieving the physical flash drive, but this should be let to professionals.
One day my FP2 had died after having had battery draining problems, I never managed to get the data on it back :man_shrugging: That’s when I learnt I should do regular backups of my data.

Thanks for your quick response!
That’s what I feared.
After my FP2 died, I also started doing more regular backups of my data.

1 Like

That would require additional hardware that you usually won’t have, but you could try to charge the battery outside the phone. Perhaps there is something wrong with the control circuits (Li-ions need control circuits to prevent overheating/overcharging) in the phone but the battery is still fine.

Something like this:

I have no experience myself with any of these chargers, I just wanted to add this piece of advise. Perhaps the battery could be charged normally once a certain base level of charging is done.

New batteries are pre-charged at about 50%, so if it stills doesn’t work, I don’t think it’s the battery. Also, if the phone doesn’t show any sign of life when plugged without the battery, that means the battery probably isn’t the (only) problem, and it’s a hardware issue either with the bottom module or with the core-module. In this case it seems not to be the bottom module, so…

I doubt they’ll be able to do anything, but did you check if there were #fairphoneangels in your vicinity?

Perhaps I formulated this imprecisely, a new battery shouldn’t be a problem, but the user manual of the Fairphone 2 already mentions that with completely depleted batteries you need a somewhat powerful charger to overcome the initial barrier while charging. And the battery control circuits count how often a battery got charged (although they should reset for a new battery) if I’m not mistaken. So, if you have a new battery, you use it until it is almost empty and then have problems to charge it again, it might just be the control circuits being unable to control the initial charging process. Red LED is an indicator of an almost empty battery because (on my phone) the LED is red only for 5% or lower. This doesn’t change the problem that this probably isn’t fixable.

1 Like

Thanks for that new piece of advice. I’ll consider that as well. It would be great if it rly were not the core module that’s broken. Although it seems highly likely that this is the issue. Tragic cuz the core module is the most complicated and expensive part to switch out/repair.

There are indeed a few in my area, not sure if they can help any more than you guys, but I’ll try. Thanks for the suggestion!

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.