FP2 does not automatically go into sleeping mode

I have my FP2 since the year 2017, and since 2021 I use it with Android 9.

Since about February 2022, I have the following problem. The phone does not automatically fall into sleeping mode, in other words, the screen stays on forever. It is possible to turn the screen on/off by the on/off button, but the phone refuses to go into sleeping mode by itself.

The problem was already present during Android 9 (since about February) and now with Android 10 it is still present.

I have tried the following things to solve the problem:

  • Off course, at “settings” → “display” → “sleep” I have changed the time until the phone goes into sleeping mode. Usually I am using 15 s of inactivity, but the problem remains if I select another time.
  • I have deactivated the developer’s mode. The problem still persists.
  • I have rebooted several times in safe mode and still the screen stays turned on.
  • I have removed the SIM and the SD card, but the problem is still present.

A factory reset is the last option for me, so I would like to ask you whether you have suggestions for troubleshooting this problem.

1 Like

Unfortunately I cannot provide a solution. I used to have a similar problem with an FP2 running LineageOS (16 or 17, I think). However, to be precise, the FP2 display would turn to very low brightness when “it was time” for sleep mode which I think we both would expect to be all black. Strangely, this problem disappeared through an update, upgrade or switch to a different OS at one point (I think in 2021 or even 2020) and it has not returned when I recently upgraded the device from Fairphone Open Android 9 to Fairphone Open Android 10.

Additional info (remembering it only now): I think the issue only occured when the phone was charging.

Others more knowledgeable than me: Might modem.zip be a suspect? If yes, how could Tuvok update this? (I was last told about how to some years ago when Fairphone OS still ran with TWRP as recovery)

P.S.: Found a topic where I previously reported my observation, see first link in lines 1 and 2.

2 Likes

@urs_lesse do you mean this? Release 19.11.2 · WeAreFairphone/modem_zip_generator · GitHub

If yes I think this was more for Custom ROM user

2 Likes

One thought reading Urs comments. @Tuvok do you use auto brightness? Maybe turn this off and see what happens

2 Likes

Indeed I was using auto brightness. I turned it off, rebooted twice, but the problem persists.

Have done the factory reset now. The problem is gone, FP2 properly goes to sleep.
New beginning now, with a nice like-new FP2…

4 Likes