FP2 bricked during update to 1.4.2 - no recovery mode

I’m using MacOS 10.11.5 El Capitan. I currently gave up and I’m waiting for the support to answer, hopefully during the week to come. I will try it from windows if you report some success, which I doubt very much.

If you all flash so much, why don’t you simply flash TWRP as recovery. If that works, you won’t have any trouble flashing the other images oder single images, doing backups and restores. And if you are working with TWRP be aware, not to flash any recovery-image - or tell TWRP to prevent that. Flasing the update via this recovery is under 15 minutes.

By the way: working with adb and fastboot is always the same on Mac, Win, Linux …

Update: After reseting the phone, it still bricks. So, it’s probably not a problem with the update…

What kind of reset did you do? Only after a hard reset you can eliminate a software isse.

1 Like

In my case, I can not go to the recovery mode, as the phone never gets out of the black “Fairphone powered by Android” screen.
The only communication channel that I can open with the phone is from computer to phone with the fastboot mode / protocol, which reports a successful flash of either the regular 1.3.6 OS, or the latest open source version, but no reboot occurs in either case, even after waiting for several hours. This fastboot reflash is somewhat the equivalent of a hard reset, isn’t it ?

As the only thing that I performed so far is software operations, I would say that my phone is soft-bricked. But then maybe there’s something wrong with the memory or some other hardware.

Sounds like you are in Fastboot mode (Power + Vol. down). If you want to get into the recovery, you need to press [Power] + [Vol. Up].

1 Like

Let me be more precise, I already several times to enter recovery mode (i.e. power + volume up press for ~10 secs): after the phone screen goes black for one second (tentative reboot ?), then lights up again with the “Fairphone powered by Android” screen, and does not change for hours whatsoever.

This is why I’m saying that I cannot enter the recovery mode.

You don’t need to press both buttons for 10 sec., it is sufficient to release the buttons once the phone vibrates.
Though I don’t know if that denies you to get into the recovery.

Since you have access to fastboot, you could try to only flash the recovery image. Unfortunately I can’t find the file for the latest release, but since you already tried to install the 1.3.6, the corresponding recovery image is available here; just unzip. If I’m not mistaken, you would then flash the recovery with the command

fastboot flash recovery.img

The whole archive would also be the proper file to flash from fastboot, if you want to install the 1.3.6. system (note, that for fastboot you should NOT use the *ota.img file).

If for any reason you’re unable to flash anything (like flash partitions messed up), you could try to run TWRP without flashing it :

fastboot boot recovery.img

instead of fastboot flash

@freibadschwimmer : thanks for your concern and help. I already tested what you’re suggesting.

@jaymanu: just tested your idea, trying to run the TWRP from the FP OS latest version. I’m getting an error when trying to boot either recovery.img and boot.img:

bassan:fp2-sibon-16.06.0-image-userdebug lomig$ fastboot devices
fbecf69c    fastboot
bassan:fp2-sibon-16.06.0-image-userdebug lomig$ ls -l
total 1234416
-rw-r--r--@ 1 lomig  staff         10 14 jui 19:06 android-info.txt
-rw-------@ 1 lomig  staff   14051328 31 déc  2008 boot.img
-rw-------@ 1 lomig  staff   12820796 31 déc  2008 cache.img
-rw-------@ 1 lomig  staff   15687680 31 déc  2008 recovery.img
-rw-------@ 1 lomig  staff  447111660 31 déc  2008 system.img
-rw-------@ 1 lomig  staff  142333212 31 déc  2008 userdata.img
bassan:fp2-sibon-16.06.0-image-userdebug lomig$ fastboot boot recovery.img 
downloading 'boot.img'...
OKAY [  0.481s]
FAILED (remote: bootimage: incomplete or not signed)
finished. total time: 0.482s
bassan:fp2-sibon-16.06.0-image-userdebug lomig$ fastboot boot boot.img 
downloading 'boot.img'...
OKAY [  0.431s]
FAILED (remote: bootimage: incomplete or not signed)
finished. total time: 0.432s
bassan:fp2-sibon-16.06.0-image-userdebug lomig$

Well that’s sad.

I guess that error message “remote: bootimage: incomplete or not signed” is not to be taken litterally, as 1/ FP2 bootloader is not locked and doesn’t enforce signing, and 2/ your file should be correct if you unzipped the official package.

Could you send us the result of a “fastboot getvar all” ? It might give us some more details about whats going on.

I’m afraid this is not good news…

bassan:~ lomig$ fastboot getvar all
finished. total time: 0.001s
bassan:~ lomig$ 

I’m wondering whether I should try installing an older version like 1.1.7, just to see if there’s any difference. Also could try installing another OS like Sailfish ?

You could try other versions.

Be aware that for installing Sailfish you will also need to have Android running first.

btw: Have you ever checked the checksum of your OS file that you downloaded? Maybe the file is corrupted?

Oops you are right, I’m also getting empty result with getvar all.
This feature might not be implemented in the FP2 bootloader, not an error specific to your phone.

1 Like

No boot with 1.1.7 either. There should be something bricked in the bootloading process, or the boot images are not correctly written, or…

@freibadschwimmer: I checked the md5 checksum for the two images that I tried to install, and they are correct.

I was about to update my FP2 but this thread is a bit scaring… Does this problem affect many users?

Judging on this thread, I’d say four.


OK, I will try updating my phone then… Don’t hesitate to cross your fingers :slight_smile:

Well apparently I was lucky (you can un-cross your fingers - thanks for that): the update went smooth and fast (30mn for download and installation). Kudos to the FP team and good luck for the people that had problems (I contacted FP return service for a DOA screen and they were great).

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.