English

🇩🇪 FP2 bootet unvollständig in Recovery Mode

Starten in Recovery bringt schwarzen Schirm mit grünem Android (liegend mit rotem Dreieck), darunter steht “No command” - was ist da nicht in Ordnung?

Nichts, das ist der Recovery Mode.

Es gab eine Zwischenzeit, in der TWRP als Recovery benutzt wurde, da gab es dann aber Probleme mit, so dass Fairphone wieder auf die einfache Android Recovery zurückgegangen ist.

1 Like

Ich dachte ich könnte mit den Vol +/- dann aus einem Menü auswählen und Android open von der sd-Karte installieren …

Um in den eigentlichen Recovery Mode zu kommen, ist es nun noch nötig, entweder mit kurzem Druck auf die Power-Taste oder mit gleichzeitigem kurzen (!) Drücken von Power + Lauter ins Menü zu gehen.

3 Likes

Fairphone Open kann (zumindest beim ersten Mal) nicht im Recovery Mode installiert werden. Das geht wohl oder übel nur über Fastboot.

https://code.fairphone.com/projects/fp-osos/user/fairphone-open-source-os-installation-instructions.html

1 Like

Ok, also das Drücken dieser Tasten bewirkt nix!
Zum eigentlichen Problem: ich habe ein USB-Kabel, mit dem ich mich mit meinem MX4 ohne Probleme mit meinem Laptop verbinden kann und Dateien kopieren.
Mit demselben Kabel kann ich das FP2 laden, aber nur mit dem Netzteil, wenn ich es aber an den Laptop anstecke, erkennt es das FP2 nicht und es lädt auch nicht …

Ah, jetzt bin ich im Recovery Mode mit Drücken: zuerst Power + Vol +.
Aber offenbar hab ich kein richtiges Image auf der Karte … Hmmm …

ich hab fp2-sibon-19.11.2-manual-switcher und im unterordner images gibt es ein system.img; ist das damit gemeint? Allerdings zeigt er mir nur einen leeren images-ordner an …

Hab ich da ein falsches Image?

1 Like

Danke urs_lesse; erkennt der die system.img nicht? Oder ist das die falsche Datei?

Die Datei ist nur für den Gebrauch auf dem Computer gemacht. Es steht einfach keine Datei bereit, die Du vom FP2 selbst aus installieren kannst.

Ok, ist klar.
Wieso erkennt der das FP2 nicht (im Fastboot Mode)?

Die Tastenkombination (Power + LEISER) hast Du gedrückt vor dem Verbinden von FP2 und Laptop?

Zuerst Leiser, halten und dann Power … dann erscheint das Fairphone logo in weiß und unten powered by android; und das bleibt stehen …

Das ist auch richtig so … dann Verbinden mit dem Laptop. Dann je nach Betriebssystem den Punkt 5 hier angehen:

https://code.fairphone.com/projects/fp-osos/user/fairphone-open-source-os-installation-instructions.html

oso@owhere:~/data19/peter/communication/fp2-2/fp2-sibon-19.11.2-manual-switcher$ sudo sh flash-for-unix.sh
[sudo] password for oso:
** Fairphone OS 19.11.2 Manual Flashing Script **

WARNING: Flashing this image wipes all user data and settings on the phone.

Validating files…
Validation complete.

WARNING: No Fairphone 2 found in fastboot mode.
WARNING: Make sure that a Fairphone 2 is connected.
WARNING: To check for devices, type ‘/usr/bin/fastboot devices’.

Do you want to look for a Fairphone 2 again? [(Y)es/(n)o]:

ok, habe ich (auf meinem alten Mac) leider auch immer. Bei mir klappt das nur unter Windows (10). Da kann ich dann nicht mehr weiterhelfen, bedaure.

1 Like

und das
/usr/bin/fastboot devices
gibt nix zurück …

Ah, Du benutzt Linux oder BSD? Probier mal, als root das Laufen zu lassen. Ist zwar unschön, hilft aber in der Regel am Einfachsten.

Ursache der Nichterkennung ist eine falsche (oder nicht vorhandene) udev-Regel oder ungenügende Rechte. Eine 100%-Lösung kann ich leider auch nicht bieten, da Vendor- und Product-ID verschiedene Werte annehmen können (siehe Systemprotokoll), aber Du kannst mal u.g. Regel probieren und prüfen, ob Dein User der Gruppe plugdev zugeordnet ist und ob Dir der Mode 0660 ausreicht oder zuviel ist:

# Fairphone 2 fastboot
SUBSYSTEMS=="usb", ATTRS{idVendor}=="18d1", ATTRS{idProduct}=="d00d", GROUP="plugdev", MODE="0660", SYMLINK+="fp2fb"
1 Like