FP2 battery dead?

I’ve had my FP2 for over 4 years now and have gotten used (even attached) to some of the issues it’s having, including with battery life. Last October I got a new one and I was pleasantly surprised by how much longer it was lasting. A few days ago, howeveer, something strange happened. My phone was in my bag (it was pretty hot) and when I took it out i saw that it’s battery is almost drained and was not charging. At first, the charging animation could be seen and the light was in red, then it started blinking softly and finally it completely went off. I can’t turn the phone on at all now :frowning: i tried different cables and adaptors, but none of them worked. I did the bloat test, but the battery doesn’t seem bloated. My SIMs are working fine on another phone.
Would anyone know if this is a battery issue or perhaps one with another module? Somehow the issues i’m having are different to previous experineces with rapid battery drops etc, so I fear it could be a different problem but don’t know how to diagnose it… Thanks so much in advance for any advice!

Have you tried letting it charge and keeping it switched off for an hour or two?

When the battery has run all dry, it’s standard that the LED should blink red first (indicating the battery has run all empty).

1 Like

If your phone does not charge after plugged in, it could be a bottom module issue which requies the bottom module being replaced.

Once you followed Urs’s advice, could you plug your phone in without the battery. If it doesn’t show the led, vibrates and shows the fairphone logo (perhaps not in this order though) in a cycle, then you have a hardware problem with the bottom module or the core-module.
Do you have a #fairphoneangel in your vicinity that could help you test spare parts? You might have a defective battery if you just bought it. Then you should contact support while it’s still under warranty. The #fairphoneangels can help you find the problem.

I have a 30% battery drain overnight, and I consider this to be too much. I have done plenty of tests, and I nailed it down to the core-module. SO I’m going to contact Fairphone support to change it (for a second time) as it’s still under warranty. If you have problems, even little ones, please try to solve them as soon as possible, and don’t drop the thing. Everyone should have a smooth experience, unfortunately, for a minority, it’s not the case (well, even though I acknowledge the FP2 has a bad battery life even when it works, but I shouldn’t have to charge my phone twice a day).

1 Like

It seems you deep discharged you battery. Since #deepdischarged is a bit too detailed in my opinion I added a short how-to here (similar to the steps provided by @Alex.A):

  1. Remove the backcover and the battery
  2. Plug the FP2 in (still without the battery)
  3. You should see the FAIRPHONE logo appear and the charging led should light up after a few seconds
  4. Put the battery back again quickly then
  5. The charging animation should appear after a few seconds
  6. Let the FP2 charge for a while (15-20 minutes) before you try to boot it up again

The procedure you describe is one of the two methods of the #dic:kickstart, which is a valuable advice, but not exactly the same thing as I was saying. The procedure I describe is to know whether the issue is bottom or core-module, or something else.

I have sinds yesterday the same problem. My battery does not charge (I have a fairphone 2) and my phone is completely dead. Also since a few weeks my phone said that there was not a simcard in my phone but there is. Now I want to remove the cover of my phone, but I do not know how to do that. It is a slim cover. Can anyone help me? By the way; I have my phone since februari 2016.

Welcome to the community forum.

1 Like

Ok. It worked. Thanks.

1 Like

Hello everyone,
I am having a similar problem with my fairphone2. I changed the battery and module 2 after going through the washing machine. After changing these two parts, the phone reboots well, loads, I can access my files. But once unplugged, the battery drains in less than an hour :frowning: Does anyone have any idea where the problem is ?

Welcome to the community forum!
I think the best woyld be contacting a local #fairphoneangel to test spare parts.
It may be the core-module.

Can you elaborate on this a little bit? How did you nail this down to the core module?
I just realized that my phone has a 30% drain overnight, too, with energy saving mode, BT off, WLAN off, mobile data off, only telephony still available. The built-in battery monitor shows the battery percentage decrease during the night is almost as steep as during the day. I doubt that this is the normal behavior in LOS. The top power consumers (browser with 1-2 tabs open, Conversations, FairEmail) are shown with 1-2% each. The battery is one year old (thus shouldn’t be too degraded), the phone however is much too old (almost 4 years) for any warranty on the core module.


I had a battery draining issue twice, and twice the core-module was the culprit.
First time: Process irq/288-wcd9xxx draining battery. The core-module was changed.
Second time: I suspected it to be the same type of issue (kernel wakelock), although the tests I had made for my first issue didn’t output any useful data. So I copied all my OS through TWRP, and put all my modules in the core-module of a second flawless FP2. The problem disappeared. Sent it in for repair, they put new core-module, and I’m still waiting for it to come back.

The thing is, I had these issues from the start, as soon as I got the phone.


Thanks for the feedback. Scrolling down in your link I found other people confirming that their overnight drain with LOS is in the same region as mine is. So I assume that from that perspective everything is as good as it can be with my phone, however I think that when the phone was new(er) and I was watching this even more carefully it lost much less overnight :confused:

Well, being under LOS 17.1, without my problems and on my second FP2, I never loose more than 10% battery overnight, and most of the time 3-5%. I think these are rather the normal values. Moreover, there was one person saying they had an important battery drain under LOS, so it’s not really representative.
Perhaps you could try a OS reinstall?


Just wild guessing of course and most likely a cause in very few cases.
Could it be, that the phone is over night stored in a place with really bad signal, so the battery drains, because it needs lots of energy for reception.
This can be tested of course by switching to flight mode and is irrelevant (at least extremely unlikely), when the problem suddenly occurs, though nothing has changed locationwise.

Anoterh reason could be some app, that is doing active background work and tries to connect regularly, even though data and WLAN are off.

But unfortunately, most likely it’s a more severe cause, as @Alex.A already posted.


Well… since we have moved a few years ago I even more wished my phone supported VoWifi. So yes, the reception is not exactly good, but we definitely have much worse spots in our flat :wink: I’ll give it a try as the effort is much lower than reinstalling the OS.

1 Like
@Alex21 Thanks you for your answers, 

My battery works well, i think the problem was that it was a new battery and that it was his first time!


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.