English

FP2 Android9 stuck on an empty lockscreen

I made the update to Android 9 yesterday after a long time on Android 7 with FP2.
Since then I randomly got stuck on the lockscreen.
It would display nothing (normally shows the time, battery level etc) and would not react to touchscreen actions. Buttons did work though, so I was able to turn on the (empty) screen, change the sound volume and to shut-down/restart. Weird thing, the touchscreen did work to select the “restart” option.
When restarting everything works fine. Until the next random time stuck on the lockscreen.
It’s really like I can’t unlock, and all informations are hidden.

I just tried to deactivate Google Screen lock service (which had admin rights to “determine the quality of the device’s screen lock”), I also deactived Google Pay which has also admin rights. I believe this is new to Android 9 because I had not seen those options before.
I’ll see if the issue still happens after that.

It looks like a bug anyway.
Maybe related but looks different: Fairphone 3 stuck at lockscreen

This sounds like what the phone should do when you hold it to your ear for a call.

Please see whether calibrating the proximity sensor helps … Settings - System- Maintenance - Proximity sensor.

Actually I still see the background image, the screen does turn on when I press the power button. Except that it’s completely empty.
It’s not black and it will react to the phone buttons (the volume menu pops up if I change it).

I still got the bug so it was not related to Google service.

But while trying to swipe to unlock in all directions, at some point it worked, unlocked and displayed everything. I’m not sure what was the move…

-------- Message d’origine --------