FP2 Android: 6.0.1 > Standby timeout settings don't have any effect

I have this issue: https://forum.fairphone.com/t/solved-display-sleep-timeout-is-limited-to-30-seconds/20617/24
… it is not solved for me as with
settings put secure sleep_timeout -1
I get a no permission exception and there is no
su command installed (Terminal emulator from the Play Store).

My phone just came back from the repair center, I upgraded to Android 6.0.1.

  • Would someone consider providing a fix with the next update?
  • Should every FP2 user root his/her phone to get this done?

You’ll have to root your phone in order to have su. You can do it temporarily this way (use rooted boot.img instead of the TWRP image). See here for more information about rooting.

Please be aware, that you may not be able to update your phone the “normal way” afterwards… But it is possible this way.

This is a community forum. Please direct such questions at the Fairphone support.

Thank you very much.
I might root one day, but not for this thing.
I going to submit a bug report.

Did you have a look at this thread?

There a factory reset did help.

Thank you all for your quick replies.

However I just submitted an offical bug report.
If someone would like to refer to it, the reference number is 179163
Reason: I would like to have a solution for the non geeks with the least effort for ordinary people.


Maybe a new issue in the bugtracker should be better. Where can your bug report be found?

Anyway I have the same problem and fixed it with the solution of @Wico.

Dear all,
I’m experiencing this as well and raised it on the bugtracker: #92 Standby timeout settings don’t have any effect

If anyone can add to it with their experiences it would help.
Thank you!

After updating to 18.01.1 it’s still the same, more than 30 sec is not possible!
This is really annoing, I wonder what these updates are for…

On the FP2 of my wife, setting of sleep timeout is possible.

I was adviced to do a factory reset to solve the problem.
But I refuse to do this and lose all my data, also I don’t want to root my phone.

I just want a “normal” update on the OS to fix this!!

I 've noticed that the sleep timeout works with another user that I have on the phone.

So it could be something specific or perhaps an app that I have/use with the main user ? :thinking:

Just to keep you informed.

The root cause of the problem seems to be the same for everyone who has this problem.

My intention was to open a ticket to get this solved for everyone.

I had opened up
which had been closed as ‘solved’.

But the problem is still present.

So I opened up this follow up:

Then the bugtracker would be a better option, see below. Also, tickets can only be viewed by you and Fairphone support staff, so there is no opportunity for others to add data.

Thank you @Johannes.

And yesterday Rick replied on the bugtracker :slight_smile:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.