English

FP2 and Mac image capture or android file transfer

Hi!
I am trying to use my Mac´s image capture and android file transfer to move photos and videos from my phone to my laptop. However, it seems that neither one of them does not recognise my phone and can´t find it. I don´t wont to use cloud upload, ´couse my cloud is full. Is there some setting I have to tap on on my phone or why is this?

Hi,
From Fairphone’s troubleshooting:

Install Android File Transfer

Before connecting your Fairphone to your Mac make sure to install the Android File Transfer driver.

Launch the driver and save it in your Mac Applications.

Now connect your Fairphone 2 with a USB cable to your Mac and:

  • open the top-down menu;
  • select the notification panel ‘USB for charging’;
  • select ‘File transfers - Transfer files to Windows or MAC (MTP)’;

A pop-up window named ‘FP2’ will appear on your desktop. You are all set to start transferring your files!

Thanks, but can you clarify this bit? Which top-down menu? From phone or where? The one that comes down on phone screen when swiped down? I don´t have any “USB for charging” there.

Yes, the top-down menu on the phone. It should look something like that (with the usb icon):


(image taken from https://its.truman.edu/docs/connecting-to-the-secure-wireless-network-with-an-android-phone-or-tablet/)

When you tap on the message, you should see something like this:


(image taken from https://www.makeuseof.com/tag/connect-phone-tablet-tv-using-usb/)

Be sure to use a data usb cable. If you don’t use a data cable, your phone will charge, but you won’t get a connexion to the computer. If you can’t make it work, try to change cable, any cable from another phone/tablet etc.

Nope! I don’t have that icon. I wonder why?

la 3. elokuuta 2019 klo 16.13 chrisse via Fairphone Community Forum noreply@fairphone.com kirjoitti:

Are you sure? It should look like a system message. Maybe if you scroll down all the way down your screen (not only half way like on my first picture)?

You can also try to find the USB mode in your settings. While your phone is connected to the computer, go in the settings and search (with the magnifying glass on top of the setting menu) for “usb”. One of the first options should point you to the menu where you can change the usb mode.

And if necessary, try to turn on developers options: settings/about phone/ tap on build number 7 times.
Once you have it on, you can change setting “USB configuration” from “charging” to MTP (settings/developers options/ networking/select usb configuration --> MTP (media transfer protocol)

Yeah I am absolutely sure. My top-down menu looks different from you picture and there are no that option, nor can I add that from the “pen”. Also, searching “USB” from the settings menu gives me no results. I also checked, if some important push notification was turned off, but it wasn´t. I´ll try the developer option next.

Ok, this gets weirder. I did this and found the USB config tab. It turns out, MTP is on and has been all the time.

Well, weird it is!
But there is a difference from the USB preferred mode (in developers settings) and USB mode: the first one is what you want your phone to do when you connect it to the computer, the second one is what you are doing right now.
If you don’t mind, could you post screenshots:

  1. Your drop down menu when the phone is connected
  2. Your search results in the settings (when the phone is connected to the computer) when you search usb

So far I´ve tried 2 different cables. Bot charge, but neither pops up the notification you are talking about. I am on developer mode and MTP is on. I´ve also tried restarting the phone.

Sure, hold on. I take the shots.

It seems I´ve reached my first day post limit. Here´s a link to the photos.https://drive.google.com/drive/folders/11ocgK5K69a3OOIrdpajczlsKd3KtbpK8?usp=sharing

Hi. Difficult to tell what the menus mean in Finnish.
I would advise to start everything again from scratch:

  • start the phone over
  • reinstall android file transfer on the computer
  • check that preferred USB mode is on MTP
  • enable USB debugging
  • connect the phone

If nothing pops up in the drop-down menu, try to find the USB mode in the settings (something like USB preferences, not the preferred mode in developers options).
You could also try to reboot the phone while connected to the computer.

Other than that I am out of clue, sorry. If it doesn’t work, try to find a fairphone angel next to where you live to make some more tests (like on another computer, on a PC, in a car, etc).

Thanks for your help.

I am pretty sure now that I have gone through every single tab in settings and the only things related to USB in any way are choosing USB configs, USB debug and cancelling it, check USB installations and something about USB sound routing. (Not sure if these are how they are translated to english.) Nothing about USB preferences.

I´ve already tried installing Android file transfer to two computers but the result is same.

I suppose I´ll try USB debugging and if that doesn´t help I try resetting to factory defaults.

It’s a shame it doesn’t work. Before factory reset, I would try

  1. the phone on different computers (a pc for example, not only mac) and another phone on the computer (to exclude problems with your computer)
  2. wipe the cache in recovery mode (turn off the phone, unplug all cables, then turn on the phone by pressing AT THE SAME TIME power and volume up. Select “wipe cache partition”. The message “Cache wipe complete” will appear once it’s done. Reboot the system.

oh, and if you really need to transfer files in the meantime, you can use apps like this one to do it via the WiFi.
It is also possible to copy all the files you want to transfer on the SD card and to put it in your mac with an adapter (you may have one in a drawer, they often come with mini SD cards).

Thanks! I’ll try the cache wiping.

su 4. elokuuta 2019 klo 15.39 chrisse via Fairphone Community Forum noreply@fairphone.com kirjoitti:

Have you made sure your phone was unlocked when you tried? The menu option only shows up when phone is unlocked (security reason).
If it really was unlocked then I’m quite sure neither of the two data cable is an USB data cable. You might check this out with another Android phone.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.