FP1(U): USB connector / part number and order information

Hi all.

My USB connector broke a while back. I took the phone to a local mobile phone shop and they fixed it for £25, which I was happy with. It’s been fine since then, which was about 4 or 5 months ago.
The man who fixed it said it was much more difficult to fix than most phones, as there was very little space around the USB connector.
Having this done has probably voided the warranty for the phone, but it was either that or buy a new motherboard, which isn’t cheap.



I don’t believe your connector fits very well. I don’t recommend it.

The original part is from Shenzhen’Linkconn’Electronics (http://www.linkconncn.com/), but it does not appear on theier website anymore.
A footprint compatible part is manufactured by Molex and available from Farnell via
MOLEX 105017-0001.
Good luck, soldering the little something is quite a challenge.


With a good soldering iron and someone experienced in soldering, I would say that is possible. In my last internship I was soldering contacts equally small by hand

Hi Martin,

Where are you in the UK / which phone shop was it? I just tried to get a local phone shop to fix mine and they’ve made the problem worse - my phone won’t turn on any more! I’m hoping I can find someone who can fix this as it wasn’t backed up

Thank you!

Hi Joelle.

I just used a local shop in Bradford around the corner from my work. I just chose that one because it was convenient and because I couldn’t find any bad reviews of it in the Web. The guy who fixed the USB port said that it was trickier to fix than most phones because there was very little space for him to work with.

If Bradford’s any use to you, I’ll find out the shop’s details and let you know.

How that helps,


Congratulations to Nicedears ! You did a perfect solder job.

I tried it myself and left behind a battlefield. I haven’t tested the proximity sensor yet. It got quite a battering.
Farnell offers the correct replacement for the Fairphone USB socket: [Molex 105017-0001][1].

I think I found while trying to remove the old connector a flaw in the layout design of the motherboard. It was really hard to get the surplus solder out of the THT holes for the two back pins of the connector housing. There were no thermal reliefs for these holes, therefore the solder joint wasn’t optimal in the first place, because the planes around the holes sucked the heat out of the joint before the solder melted properly.

I filed these two pins of the new connector a little tinner in order to fit in the not empty holes.
Attached are a few pictures of my little soldering adventure. At least the USB port did work after the replacement, although looking at the pictures one might guess otherwise …

The disjointed housing pins and the lifted SMD pads.

Backside of the disjoind housing pins. Note the hole with the ripped out pin still inside and the lack of thermal reliefs.

The battlefield after the operation …

Good luck to everybody else trying ! :v: :wink:
[1]: http://uk.farnell.com/molex/105017-0001/micro-usb-2-0-type-b-receptacle/dp/2293836


Thanks Martin,

I’m in York so not a million miles away, however I found another phone shop in York and it looks as if the first place killed my phone. :frowning:

Thanks anyway!

Just for sake of completeness: If you did not find my previous post in other threads, here you have my suggestion to check (in addition to my post above):
Try to clean your USB connector of the FP1 - it solved my charging problems completely:

Cheers, Robert

1 Like

Whoa, That was a battle,
My MicroUSB port got unsoldered as many of you know the problem
So, I followed this tutorial:

unsoldered everything
Cleaned every pad
I had BAD LUCK and 2 of the pads where broken, so I had to scratch some of the plastic to uncover some copper beneath.
Then, I resoldered the microUSB …

It really really was a pain, but I took a scope, a microsoldering station and lots of patience !

I am unsure if the proximity sensor or the light sensor got destroyed … they may have but at that point it was
No phone
a phone without proximity sensor and light sensor (which to me seemed a better option !)

I hope this helps !


After successfully soldering the mini-USB housing back onto the motherboard, I wanted to share my little work-around.

Starting condition: Entire housing was loose. When I removed the motherboard, the housing came off by itself. The four socket-pins of the housing were intact, leaving four holes in the motherboard.

Challenge: Solder the housing firmly onto the motherboard, while connecting the five tiny contacts (I just had a very standard soldering iron).

Solution: Bend all five contacts outward to ensure they would really touch the contacts on the motherboard. While pressing the entire housing into the four holes with some pliers, I soldered the bigger two front socket-pins from the backside of the motherboard.

Notes: It took a while to get the remaining metal to melt. But once it did, it filled the gap between socket-pin and the motherboard nicely and firmly. It’s important to position the housing, the outward-bent five contacts and the pliers well.

1 Like

Pictures! :slight_smile: (Only if you have taken any. No need to open it up again).

I find it really frustrating that this fault on the FP1U cannot be included in the guarantee. FP asks that you return your phone for them to inspect to see if it’s your fault or a manufacturing issue. I emailed them two weeks ago and still no reply. My girlfriend had the same issue with hers but to be without your phone for weeks and to risk having to pay for it to be mended if they deem it your fault just seems ridiculous. And very curious that it’s user error as we both developed the same error within weeks of each other.
Our solution was to buy a spare battery and a universal battery charger but it feels extremely UNFAIRphone to have to buy more STUFF.
If we tried soldering ourselves we could destroy the phone.
I don’t think I’ll be getting a FP2, despite the improved modular nature, as the customer service is terrible.

1 Like

How am I supposed to fixe it ?
I did try with other cable, it’s not that, the connector is just dead. it was working hazardously since weeks. I tried to tighten it, and to put some contact cleaner, it worked a bit better for a time, but now, it’s dead for good.
I’m not going to buy a new mother board just for a rigged micro usb connector.
Can any one tell me which usb connector I should buy, where and how to replace it ?
It’s a very common issue on any electronic device, so I’m surprise you cannot buy a spare part for that on Fairphone shop…:frowning:

If you don’t want to microsolder a USB connector yourself, please contact a local repair shop.

Maybe there is even one already in your area, that has experience with a FP1:

Well Actually I would consider solder a Usb connector, but I guess if it has to be microsoldering it’s out of my league then… too bad, I always like to do things myself better.
I will have to consider a tour to the Smartphone Klinik then…
Thanks Stefan.

1 Like

Good point to check for dust and clean the connector, Robert. I had charging problems (but no loose connector). Cleaning the connector out with a needle released loooots of dust and solved the problem!

1 Like

Bordering scary :no_mouth: … I have now noticed the Molex USB connector in a tailored side bar ad in our German Facebook group.


Great :’( i also have a broken usb plug (have the phone from preorder. So a long time but still is not fun)

When pushing the cable upwards it works but normal plugged in not anymore. Bad to see that it is this type of design. What would be a great solution is a seperate battery loading station. I don’t use the usb plug for different things than chargeing.

Some repair shops offer to repair USB connectors. Maybe there is even one in your area on our community list already:

thanks for the quick reply. Im going to check with the german shop (is most nearby)