FP1(U) Manual Install not working


My Fairphone Updater keeps constantly crashing: “Faiphone update unfortunaltly stopped” bumps up quite frequently. When I access it, it flashes a white screen and stops again.

So, I decided to hard factory reset my phone. Which worked, but Fairphone Update still crashes.

Ok, I turned to https://fairphone.zendesk.com/hc/en-us/articles/202478028-Manually-install-Fairphone-OS-software-update-version-Cherry-1-6 to install my phone manually.

I copied the zip and started to install it.

However, right after checking the progress bar when installing comes up to around 30% and then stopps “Update aborted” or something similar.

I wiped cache and data to no avail.

I do now have a factory resteted Fairphone with a non working Update. =(

What can I do?


Have you tried keeping the screen “active” permanently for the duration of the installaion?
How-to: settings > developer options and tick “keep screen on” and then start the update with your phone plugged in" (see ✏ How to update your Fairphone 1(U))

1 Like

Thank you for the reply.

Regarding the Fairphone Updater: it crashes on starting in less a second. And as for the manual install the screen does not fade. So, I didn’t try to check this option, since the screen does not turn off.

1 Like

@dyle: Just to be sure, you are updating in recovery mode, as described in the how-to, or have you just downloaded the zip manually and install from within Android?

@ben: yes, I followed the manual at the link. Even more, I did a factory reset in recovery mode beforehand.

Make sure, you are using the correct version of Fairphone OS 1.8.7. Note that there is one for the old partition layout and one for the new partition layout. Then download the file again. It might well be with a 200MB file that it got corrupted during download.

Mhm, I once applied the partition layout earlier. I’m not sure, but it must have been Fairphone 1.6.x. I’m pretty sure I picked right Zip-File.

However, I grabbed myself the Fairphone of my wife. And there everything works. I’m thinking now of some hardware malfunction beyond repair.

Are there an chances I can detect this (hardware error)? I once run the HW-Test stuff (Volumne Button down and Power up) but didn’t come to something suspicious.

Did you try this? …

Yes. Twice. The first download been corrupted. The second succeeded.

However, I keep my wife’s phone, which is working.

And your wife stays without a phone? :frowning:
Well, a pity you couldn’t solve the other device’s problems.

Uhm, no. She wasn’t satisfied with the Fairphone User experience and got herself a iPhone recently.

But it’s ok. I really think there’s a hardware problem. Maybe related to some corrupted memory areas. This could explain my problems.

Ok. If you do not need the other phone anymore, Fairphone offers free shipping, if you donate it to them for recycling purposes.

1 Like

Oh, great! I didn’t know of this one.

Thank you.

1 Like

It will work so.

Hey Guy,
i had 8 hours trouble to install it Correctly.

So i hope my tipps will give u the same result in 30 minutes.

My topic was to Update vom
1.6 to 1.8.7 .
The automatic update nerver works for my phone.

So For the First it is to know that you can download the Update on the Computer. That put it on the SD Card or on your Phone in the Folder Download.

Second. There are to Update files that are requiered.
The first is the

the Second “FP1-Fairphone_OS_v1_8_7_Partition_upgrade”.
Short, the First is the OS and the second ist a “Partition upgrad”.

Link here: https://fairphone.zendesk.com/hc/en-us/articles/201189497-Fairphone-OS-multiple-versions-

After downloading it and put it on a place in the Fairphone. You have to shut down the Phone.

When you hold at the same time, the Volume Up-Button and the ON-Button. Wait 10sec.
There will a Screen with android robot. If not put short one more time on the On-Button.

The Scroll with the Volume down- button, Start with the up-Button.

Apply update from the “Download” folder on the Fairphone’s internal memory. Do this by choosing “apply update from sdcard”, and navigate to the “Download” folder. Select the .zip file (make sure you select the .zip file starting with “FP…” not “._FP…”) in there and press the Volume Up button.

So i hope u will be faster than me.

Maby you could write a Helpfile on at other topic.

I think this is exactly the procedure explained in the support article. Except that you didn’t wipe the cache.

1 Like