English

FP1: Power button does not work anymore

Tags: #<Tag:0x00007f05df978f60>

Hi Everyone. I got a FP1 and my bower button does not work anmore. I’ve had a look inside to get rid of the dust that bight have blocked the button. That wasn’t the problem. Is there any possibility to turn on the phone without the power button. Do I have to buy a new mother board? Is it possible to change only the power button and solder it on the old mother board?

thanx to everyone in advance

Hi. I don’t think there is much hope, but let’s check a few things first. Hopefully the switch is not really broken, maybe the “outside” switch cap just “slipped” a bit?

The thing is called “tactile switch” for a reason. Can you hear and feel it if you press it? What happened before it stopped working? Did the phone fell down or have you opened the case before?

You can see the switch on upper right corner on the picture made by ifixit. The switch will be difficult to replace on the first “licensed design” FP1. It was not made for replacing parts on the board. But it could be possible. Similar to the USB connector I fear. Someone mentioned a shop that did that well here, maybe that shop will also replace a switch?

In the FP shop exists the power button, but I don’t know if this would help here, as it is only the mechanical part…
Cheers, Robert

Yep, that’s the “outside switch cap” I was talking about. If the phone was opened or fell down and the “switch cap” is not aligned with the switch on the board anymore he should be able to hear/feel this. But if the “switch/cap” combination feels right … the problem could really be cause by the hardware switch on the board. Maybe he will be able to tell us more.

The rubber backings must fit into the channels in the assembly.” (see step 13 at ifixit)

Hi everyone,

first of all, thanks for your help.
it’s def. the hardware swichs. i’ve checked the rubber switch cap. it was in the right place. the phone didn’t fall down. when the button was still working it begun to be sluggish. I needed more and more force to push it down. finally it won’t work at all. so if there’s no way to replace the hardware switch, i assume I need to buy a new main board. or does anyone know what kind of switch it is? is it a piezo actuator that produces a certain voltage when compressed? if so, which voltages is needed? than I could use a battery and a voltage and a voltage provider and turn on the phone from time to time with the mentioned device.

thanks in advance for you kind help.

Too bad. I think it’s just a “stupid” switch, nothing fancy.

I guess it’s important to find a switch with the right measurements that can be ordered to your country and the right tools to replace it. (Or in short a good phone shop!).

The site I linked to above is pretty close. I think you can use the measurements from there, double check with the board and try to buy a similar one online (it’s hard to buy this stuff online as single items).

So I think you will have to ask phone repair shops that have the right tools and know how to order stuff if they will do this job for. A few good ones were mentioned here, they replaced the usb connectors … just search for this topic here.

On the other hand you have to decide if it is really worth it. Maybe you can ask the support regarding warranty? Normally such a switch should be able to handle a lot of action …

Update: I just saw this post, someone got it working again by using contract cleaner spray. He also links to another post that explains that the Samsung Galaxy Note GT-N7000’s switch fits that is available on ebay and people made a movie about. :slight_smile: Maybe also something you could try? I would try contacting FP first and contract cleaner spray later :smile: Good luck!.

2 Likes

Hello thoms,

did you contact the FP support on this issue?
Could they tell you, which power switch you have to get, i.e. which phone/tablet is using the same switch?

Hi there,

just fyi: I recently successfully replaced my broken power button with the one mentioned above. It was not super easy to solder but it worked. It helped to have solderwick at hand to remove the old button.

And: The button was like 3€ on ebay instead of 118 for a new motherboard ;-).

Best,
Benni.

2 Likes

Hello,
I can’t start my phone (FP1 Second Batch - No protection case). When I press the power button nothing happen, i try to hold at the same time the volume button but nothing …

I put the cable for the battery, the red light is on, and turn green at a point. And when I take it off, the screen turn on and show battery at 100% . When I take off the cable I’m able to unlock my phone, but if I want to lock it again, I can’t use the power button, I need to wait until it’s lock again.

Can this problem be under guarante ? What are the solutions to solve the problem ? It can be juste the power button to replace ? Is it possible to buy somewhere else than on the spareshop the power button (it’s out of stock … https://shop.fairphone.com/spareparts/volume-and-power-button.html )

Thanks in advance

Benjamin

Unfortunately replacing the power button (the plastic piece you see outside of your phone) won’t do it. It only transfers the pressure to the little white button inside the phone:

Press to see original picture. Source

This white button is soldered to the mainboard and cannot be replaced easily. You have two options:

  1. Buy a new mainboard (about 118€, not environmentally friendly).
  2. Take your FP to a mobile phone repair shop and ask if they can fix your power button. It is reported that some of these repair shops can micro-solder these connections within the hour.

Please tell us, when you’ve found a solution. :slight_smile:

PS.: I also found some workarounds, which could be interesting for you.

1 Like

Have a look at this topic FP1: Power button does not work anymore, there are some hints on how to repair it.

2 Likes

Thanksfor the answers, I will check with a phone repair, for the moment I use this app : https://play.google.com/store/apps/details?id=com.teliapp.powervolume
And it’s work pretty good.

2 Likes

I have a similar problem with my FP1 first batch, the power button stopped working altogether this morning, I did not do anything special to the phone (no fall, nothing that I can think of).

To lock and unlock, if you use the F-Droid app store, you can use WaveUp as a partial workaround:

WaveUp (Turn the display on by waving) - https://f-droid.org/app/com.jarsilio.android.waveup

It allows you to lock and unlock your phone by using the proximity sensor (you can sort of see the little circle to the left of the top speaker). It works surprisingly well and has features to also unlock when you take the phone out of your pocket, and lock after the sensor is covered for a second.

It is a partial workaround as it does not allow you to use the power button shortcuts, and does not turn the phone off and on.

I will look into the option listed here and will let you know how I go.

What does it take to micro solder? Do you need a different soldering iron, and a different solder wire material?

Update: … and the button works again after 9 days of using WaveUp as a workaround. No idea how that happened. It is really surprising as it really seemed the hardware was gone forever, all of a sudden. Now it works completely fine, all the time. :no_mouth:

Be aware that WaveUp can drain your battery.

Hello!
First, thanks for the tips and ideas because I had the same problem.
I tried the app recommendation of Benjamin_Wittorski , which unfortunately did not work for me .
Then I tested this app :
https://play.google.com/store/apps/details?id=com.mobilesilicon.app.vup
Great, now I can turn on my Fairphone over the volume control.
Thank you for the post and the help!!

I can confirm that the Galaxy Note N7000 i9220 button works for the Fairphone 1 :slight_smile:

This is the button I bought: http://www.ebay.de/itm/361256806473

Here you can see the old, original button:

After removal:

And the new button soldered on:

Works perfectly! And prevented another FP1 from being dumped, for the price of €1.69 :slight_smile:

11 Likes

Great! Could you talk a bit about what kind of soldering tools you used? It might encourage others to try this as well :wink:

A friend of mine that has a bit more soldering experience than me soldered it on. But he used a regular soldering iron and leaded solder. Tweezers may also help.

1 Like