FP1: Macadamia 1.9.9-pre3 Alpha (Android Kitkat)

I have a list of bugs and issues that I found on the pre1, this week I will try to install pre2 and see if they have gone :).

1 Like

re: endless boot loop while trying to get into recovery: Probably an install issue when another boot loader is used. I fixed that by wiping the phone.
re: Fairphone Updater: even with the vanilla install, the updater crashes. (same as for uudddu). Maybe it relates to some google stuff that is not installed? Well - no harm done; can’t install google, but can live a while without it. Only some apps that I restored via Titanium will get outdated over the time.

The Updater crashes for me every time I reboot the phone after installing the pre2 Image. It is started by the system and crashes directly after I’ve unlocked my simcard.

Little extract from the bugreport.txt:

09-07 10:25:23.824  1604  1801 I am_proc_start: [0,2518,10089,com.fairphone.updater,broadcast,com.fairphone.updater/.BootBroadcastReceiver]
09-07 10:25:23.970  1604  1912 I am_proc_died: [0,2497,com.android.email]
09-07 10:25:23.984  1604  1616 I am_proc_bound: [0,2518,com.fairphone.updater]
09-07 10:25:24.129  1604  1884 I am_create_service: [0,1106201080,.UpdaterService,10089,2518]
09-07 10:25:24.279  1604  1615 I am_crash: [2518,0,com.fairphone.updater,13155909,java.lang.SecurityException,Invalid value for visibility: 2,Parcel.java,1465]
...
09-07 10:25:36.401  1604  1838 I am_proc_died: [0,2518,com.fairphone.updater]
09-07 10:25:36.634  1186  1186 I sf_frame_dur: [Application Error: com.fairphone.updater,16,1,0,1,0,1,1]

I’ll send the complete bugreport.txt via E-Mail soon and reference this comment.

I installed the update. Everything went fine

BUT

I can’t dowload anything from google store (Don’t know what I did, messed around with Titanium Backup a bit) and I still can’t synchronize my fitbit trainer via bluetooth… not detected (which is very unfornunate).

Otherwise so far so good!

Edit: Error DF-DLA-15 can’t download with F-Droid either… any ideas?

1 Like

Did the whole thing again and this time I froze gapps I don’t need… It’s working.

I would really like a tutorial about what apks I can Uninstall and what I have to keep (but that’s another story)

I did as you did but (as you can see on the previous post) I must have deinstalled too much!

So would you be willing to make a list of what can be deleted and which application should be kept in order for the market to keep working? It would be great!!

To be honest, I don’t know either which parts of the GApps packages are essential and which are disposable. That’s exactly why I left a lot of stuff in the updater.

If you find out which ones are safe to remove, I might look into it again. A good starting point might be the OpenGApps micro and nano packages.

I know that’s what I did with the first version. But I tried to install opengapps and it didn’t work… Maybe because I didn’t install another recovery?!?

The recovery we ship does not support OpenGApps. You might have more luck wich CWM recovery.

@evidemment
CWM recovery could be downloaded from the xda-post linked to in this forum post, but Basketbuild is down at the moment.

If you trust @flgv , you can still download the recovery.img from there: [FP1(U)] Link to latest cwm recovery version

I used the apk to fix writing rights to the SD card (which worked before) but now it doesn’t work. So I can’t record my pictures on my SD card with Open Camera.

Is it related to the new ROM version?

The netapp sd fix app is one of the few things that worked alright for me with this new release. Maybe apply it a second time? OSMAnd can access its maps now.
But I didn’t try openCamera - does openCamera improve image quality so much?

But, additionally, battery lifetime is MUCH better now (maybe the missing google apps are helping here). The GPS fix comes quite fast and is not as bad as with the original version. Positive.

Not tested: Bluetooth.

Kind regards
Jörg

1 Like

I still didn’t update to the new alpha, but in the current version battery life is so bad I’m considering going back to a stable version, but if you say this new version improves things, I may update mine. Does the battery still jump from around 60-80% straight to 15%? Did you have the issue with the GPS turning on by itself and sucking all life out of the battery? If so, does this still happen?

Hello,

did you restart your phone? I had to reboot it to allow OSMAnd access to the sdcard, before it just complained about insufficient privileges.

Hello, I have tried applying the update, but when I tell the Updater app to reboot to apply the update, it says
File not found: /cache/fp_update_.zip. But the file is there, and I even tried to re-put the file there manually using adb and rw remount, and it still doesn’t see the file. I will probably install the update through recovery instead.

EDIT: OK so I have tried applying the update using recovery after wipe cache and wipe dalvik cache, and it did not work for some unknown reason. However, after rebooting back in pre1, I tried once again the update process with the Updater app, and it worked! I don’t know if I simply needed to reboot before, or clear the cache partition, but something did the trick.

Here are quick comments so far for my experience of pre2:

  • The settings are in french, hurray! :slight_smile:
  • The Updater app always now instantly crashes when I start it :frowning:

Yes I did. . . Opencamera still gives me a message “impossible to save image”.

The update went fine and also the fix for gapps works without problems.
After the update I was confused cause the updater-app still says I’m using pre1.

I can confirm that the settings are now in the choosen language and not in english.
Using a second sim-card doesn’t make any problems till now and I also think the battery problem is getting better but not completly solved.
GPS is better too but not perfect.
After restarting the phone messages like “E-Mail wurde beendet” appear, not only saying email but also different apps (not everytime)

That is strange. I’ve been curious and installed 1.33 via F-Droid and changed the storage path to /storage/sdcard1/DCIM/Camera and took 2 photos which correctly appeared in the selected folder, the camera app also displayed correctly that I’ve over 25GB space available there. Is that measurement correctly displayed to you?
I’m sorry to say but I’m out of ideas for now, maybe looking through the logs with adb could help but for that I don’t think I’m the person to ask for help with that (still lacking experience with that).

1 Like

I had the same problem. I just installed the gapps package provided by jftr again via sd-card and after that I was able to connect to my google account. Now everything works fine like with alpha pre1.

No, I didn’t have these issues yet; battery seems to be consistent. But, as the updater crashes and I don’t have any other method to install the google apps, this isn’t really helpful. Maybe the former google app did more evil things than we all know.
For the first time ever, I had 2 days of battery life now.
So - if you know how to get back in case something goes really wrong, the current alpha is one of the best versions for FP1 (along with the crmHoffmann inofficial version).