FP1: Macadamia 1.9.9-pre3 Alpha (Android Kitkat)

Do you trust flgv? :wink: Because McAffee doesn’t… :sweat:
I think I do trust him…

What did you install?

I’ve installed the Open Camera App, here’s a Screenshot. I hope that’s the correct App, otherwise could you provide a link to it? Here’s the one for the one I installed: Open Camera @ f-droid.org

I have no rights for the SD card. Titanium backup doesn’t work either… :frowning:

Can you verify with adb that the setting is correctly set?

Just run adb shell in a terminal, after that you should be able to follow the output below.

* daemon started successfully *
shell@FP1:/ $ su
root@FP1:/ # cat /system/etc/permissions/platform.xml | grep -A 5 WRITE_EXTERN
    <permission name="android.permission.WRITE_EXTERNAL_STORAGE">
        <group gid="sdcard_r"/>
        <group gid="sdcard_rw"/>
        <group gid="media_rw"/>
    </permission>

You can always check whether it’s the same file as offered by chris by comparing MD5 sums. Have a look in the XDA thread.

I might have forgotten to update the version string :flushed:

Please give me an adb bugreport after you experience this.

@evidemment, @joergschulz, @Kuraron,
can you please give me more information about the SD card issue?
What does not work?
How are you trying to achieve it (step by step instructions)?
What is the expected outcome?

It’s possible that your cache partition was full.

We’re on it. Does it start immediately when you start it? For me it only crashes if I go into advanced mode.

If it crashes immediately, please send me an adb bugreport. Thanks

I installed the gapps package like sven.affeld told me and I didn’t have the "e-mail wurde beendet " message since i did the installation

1 Like

Ok, I’ll try to write down the issue for @evidemment

With Android 4.4.x the permission to write to the SD Card is removed. Apps can still read it but not write to it. In the case we discussed here it’s the Open Camera APP which can not write to the SD card anymore.

If one adds <group gid="media_rw"/> to the <permission name="android.permission.WRITE_EXTERNAL_STORAGE"> entry in the systems permissions (see console output in my last post) the behavior of Android 4.2.x can be restored (it lifts the introduced restriction). This can be achived by using Apps like NextApp SDfix as it re-adds the missing permission.

With the last post I tired to figure out whether or not this change was performed correctly on the phone @evidemment owns. The output was taken from mine where all works as expected.

This permission change is the reason why I asked earlier if such a fix could be introduced into the official updater.

As a shorter summary:

  • Android 4.2.x: Apps like OpenCamera and Osmand can store their data on the SD card and apps like syncthing can read/write.
  • Android 4.4.x: Apps can not write to the SD card as the permission was removed afaik the can only write in app specific folders on the internal memory. Pictures taken with OpenCamera can have to be stored in the internal memory.
  • Android 4.4.x with permission fix: Apps can write on the SD card again.

I hope this helps, if further or other information is required, please ask :wink:

PS: I know this step is intended as a security increase as App X can no longer delete files written by App Y, but some apps need to to such actions. I think the biggest problem is the change what apps can do or don’t do by performing the upgrade from 4.2.x to 4.4.x. The situation was improved with Android 5.0 (per-app based permissions to the complete card or single folder) as far as quick search told me.

5 Likes

Thank you for the detailed write-up.

After having done some research I will try to sum up the issue with my own words:

  • FP1 exposes SD card as secondary external storage.
  • Android 4.4 started enforcing permissions on external storage.
    • All applications have read/write permissions to their dedicated path (e.g. /sdcard/Android/data/<package>)
    • Any other path is only readable.
  • These permissions are requirements for Android compliance tests (CTS).
  • Some apps such as OpenGapps offer the option to select any directory as storage location.
  • However, writing files (i.e. pictures) to SD card fails because Android makes it only readable for apps.
  • On rooted phones workarounds exist to enable these capabilities.

I understand that it would be more convenient for some users (like the bunch of you :slight_smile: ) to automatically enable it. However, there are reasons for these permissions and just breaking them for every user is probably not the best option … especially since we strive to be as compliant with CTS as possible.

Hopefully this is not too big of an issue for you because of the workaround.

3 Likes

Sounds correct to me, but in the current case we discussed here in this topic it could be the case, that the workaround does not work. I hope we can get more details from @evidemment to figure out what or why something has gone wrong.

I unistalled the Nextapp SDfix and installed it again. Problem seems to be fixed.

2 Likes

I came across a bug. I’m not sure if it’s related to the beta version but I’m guessing it might be since I haven’t come across it before (that I know of). Anyway, here it is:

I wanted to record videos on snapchat and send them to a couple friends. What they received however, was a video containing pixels/static. You couldn’t recognise any images in the videos. Okay so I thought maybe my Snapchat app is at fault, using my second phone I could send videos without any trouble. Reinstalling didn’t help. I shrugged it off cause I don’t really send videos anyway.
Today, however, I wanted to send a video, that was recently sent to me, via Whatsapp. I wanted to shorten it to 10sec. When the video finished uploading it only contained pixels/static.
I then used the little Whatsapp camera shortcut, recorded a video, sent it and this was uploaded perfectly fine. I then tried opening this video that I just recorded myself from my gallery, and sending it again (without shortening). Also worked perfectly fine.
Then I tried sending the very same video one more time. Only this time I cut it down to a few seconds before sending. All that was sent was static.

Hope my explanation gives you an idea of what I mean. I do believe I was able to send shortened videos via Whatsapp before I installed the beta. But I’m not 100% sure of it.

I can recreate these if you think they might be related to the beta version? I can also upload the videos as examples or do other kinds of tests.

3 Likes

Applied the update and rebooted. Once the phoned had finished updating all the apps, it went into a loop with the message `Unfortunately, com.android.provision has stopped’

Things are still running in the background: I can access apps via notifications (e.g. when a new email arrives, I can view it in K-9, but when I return to the home screen / launcher, I’m back in the loop.

I’ve tried deleting the cache but no joy.

Any ideas? Please don’t ask me to do a factory reset :slight_smile:

OK - the message was caused by the SD card permissions problem. Fixed that and now trying to get back to where I was before I started messing :slight_smile:

Oh dear! I’ve applied the update, re-installed and run the SD fix app, and I’m getting the ‘com.android.provisioning has stopped’ message again,whether or not the SD card is present.

Can anyone give me any clues how to get the phone working again?

Thanks

for me the only solution had been to wipe the phone and reinstall the update.
It had nothing to do with the SDCard but it had to do with some google services not running.
Up to now I didn’t reinstall any Google services, so: If you want to have a google free phone: THat’s the way to go; else you might start with a vanilla FP install and update to beta from there. Maybe this allows for Google services to be installed, I don’t know.
Bet you have all your important data elsewhere, so you can go now…

Thanks. I’ve reverted to the working -pre1 system and will make sure everything is backed up (twice - Titanium and from recovery) then wipe the phone and try again. But I may leave it for another day, whie I get o with my life :slight_smile:

1 Like

@petefoth, can you please give a detailed overview how you got your into the broken state?

  • What version of Fairphone OS did you run before you updated?
  • Did you have Google Apps installed?
  • Which Google Apps (the one provided by the installer, OpenGApps, anything else?)?
  • What recovery are you running?
  • When did you install the SD card fix first?
  • What version of Fairphone OS did you update to?
  • Did you reinstall any GApps package?

Thanks.

OK. But this is from memory because, having retired from by software engineering job, I no longer keep a journal or logbook :slight_smile:

First time, I used the Updater app to install FP1-Fairphone_OS-1.9.9-pre2-ota, by browsing to the fil in ES FIle Explorer, clicking on it and choosing to use Updater. When the update was done, the phone rebooted, and the ‘provisioning has stopped’ message appeared. That was when I first posted message 192 above.

FP1-Fairphone_OS-1.9.9-pre1-ota

Yes. I think it was open_gapps-arm-4.4-nano-20160810. I think that when I upgraded from crmHoffmann’s lates ROM the installed open_gapps continued to work, but it is a while ago so I may be mis-remembering

On the first attempt, https://basketbuild.com/uploads/devs/chrmhoffmann/fp1-kk-stock/recovery.img.
Then, after the upgrade, replaced with cwm-fp1-kk.0.1.img as basketbuild had been down

After the first upgrade failed - because of the ‘provisioning has stopped’ problem - I restored 1.9.9-pre1. I removed the SD card and installed and ran the SD card fix.

1.9.9-pre2

No. I did restore a Titanium backup - all apps and data. After doing that all the apps were present. They may have been there before I did the restore

My current state is that I am running 1.9.9-pre1 after restoring a system backup from recovery. I really want to get to the point where I am running 1.9.9-pre2 without having to manually reconfigure all the apps I use. I’m not sure whether the best way will be to restore apps and data from Titanium, or restore the data from recovery. If no-one else knows, then I will experiment :slight_smile:

Thank you for all the work you have done on this. I do appreciate it :slight_smile:

3 Likes

Unable to install FP1-Fairphone_OS-1.9.9-pre2-ota.zip

My system is now functioning properly again, running FP1-Fairphone_OS-1.9.9-pre1-ota with open_gapps-arm-4.4-nano-20160810 (see note).

When I try to install the update as described at the top of this post. after

updater returns to its main screen and displays a message box saying

I’m happy that my phone is now working as expected with the 1.9.9-pre1, but a bit sad that I can’t try out the new version. also a bit worried that I won’t be able to update when the release candidate is available.

Any suggestions about how to get 1.9.9-pre2 installed would be welcomed :slight_smile:

Note: With the latest open_gapps-arm-4.4-nano-20160915, the phone would go through the ‘Android is upgrading…optimising app x of 40’ cycle every time it was powered on