FP1: Macadamia 1.9.9-pre3 Alpha (Android Kitkat)

Of course…!!!:grin::joy: … not!

I’m just constanly surprised of differences of my battery life. I don’t seem to pin down why battery is behaving as it is.

Anyway: We can conclude that battery life and battery life prediction did not improve with the new fixes. I have to look into different angles.


I think the battery life prediction got at least a bit betters since pre3. In pre2 20% battery left was like “you have one minute left and can watch the battery ticking down”, now 20% lasts much longer.
But it’s still not perfect, so another fix could help. And please don’t forget the GPS issue…

Can you give details on what the fix that you found includes?

I was a bit confused because I thought a file named gps.conf should exist in every android directory and I couldn’t find one, so I just made one by myself and placed it at system/etc/ with:


It doesn’t make a huge difference but I believe it helps at least a bit.

Then I searched for a way to update EPO-files regularly but I couldn’t find the option in the system, so I installed an app like “MTK EPO GPS Fixer” (there are many more) and updated the files this way.

Now I’m not sure if the gps.conf is enough to update AGPS-data regularly.
In Location Engineer Mode the GPS now fixes in about 3 seconds (in “hot”-mode) and stays connected even in buses and trains, but every other app has a much more unstable GPS connection and I don’t quite know why… maybe because the CPU is more busy and the GPS doesn’t have enough priority to work stable, but I can only guess :confused:

1 Like

How can we better help you, @jftr? I’m willing to set up a “controlled experimental environment” if that’s good for something.

Thee thing is that my friend keeps asking me about the KitKat update and all I can say is that we are still in alpha… :confused:

A post was merged into an existing topic: Battery level drops in FP1(U) alpha

I don’t know if it is a bug. But when i get an sms it normally was shown as a notification with the contact name. With the pre updates it often shows just the number even when there is a specific name. I often have to go into the sms folder to see who sent the sms. I know it’s maybe a bit unspecific, but maybe someone can confirm his behaviour.

I never had this. You hear this behaviour sometimes on the forum, but it happens in all environments. Most probably there is something messed up in your software.

First of all I’d advice you to clear your cache (fastest way is to go to Settings > Storage > Cache) and, if that doesn’t work, you might need to clear your contacts database and/or do a hard reset.

Today it appeared for me for the first time that the on/off-button didn’t react at all. Had to take out the battery to restart. Worked after the restart. So i guess a software and no hardware problem.

@Stefan will try the cache clearing at least.

The on-off-button can be cleared by clicking one of the volume-keys. After this the power button should work just as well again.

My additional workaround is the Gravitybox-setting “turn screen off by double-clicking the status bar”. It also makes the power button last longer, as you only click it half as much. :blush:

1 Like

Hello all and @jftr,

I just want to say thanks for the port and beta but sadly I am no longer being able to help you as spare parts are more or less gone at the moment.[quote]In the meantime we can only apologise for the fact that we can’t provide them at the moment and we are not able to offer you a repair of your Fairphone 1.[/quote]I feel kind of sad leaving you all at this point and maybe someday I can be back…

Sorry for staying silent a long time, but I had some problems finding words.
Thanks again and good luck!


I’ve got a similar problem, my Micro USB port broke and I tried to fix it by soldering but failed (the port is nearly unreachable) and a new Motherboard costs about 120€, so I give up and buy a new phone. Since the Fairphone 2 won’t be delivered before the end of January, I have to buy another phone.
But I won’t forget your commendable approach to build a conflict free and modular phone and might be back with Fairphone 3 in a few years. I wish you good luck with your KitKat alpha and hope you can fix the remaining bugs soon, because some of my friends still have a working Fairphone 1 and keep asking when you guys finally finish this update :slight_smile:


Sad to see you leave, @Kuraron and @Sujus, but - of course - I understand.


Just found out here that this could be SIM related. Read more in the support article. In any case I don’t think it’s got anything to do with the alpha.


Hi, because some apps didn’t work with Andorid 4.2 anymore I decided last week to upgrade to 4.4.
I cleaned the cache and upgraded from 1.8.7 directly to 1.9.9-pre3. Everything worked fine.

I also installed Gapps via the fairphone updater, but there are some problems.

  • Everytime I start the fairphone some google apps randomly will close (e.g. “google play kiosk” wurde beendet; “Google Play Bücher” wurde beendet).
  • I cannot install the google keyboard (for swype)
  • I have the battery problems like it was mentioned before (e.g. drop from 40% to 15% within second)
  • the app “my phone explorer” does not work
  • I do not get any push notifications

But besides the battery charging status that are minor problems. Thanks for provding the update!



A few days ago, I installed the 1.9.9-pre3 ROM on the FP1U. The process was:

  1. Cleaned and wiped stock ROM 1.8.7
  2. Flashed CWM recovery from XDA-developers forum via adb shell
  3. Flashed unofficial ROM fp1-kk444-CH-0.9.7 by chrmhoffmann from XDA-developers forum via CWM recovery
  4. Flashed OpenGApps via CWM recovery
  5. Used it fp1-kk444-CH-0.9.7 for a couple of days
  6. Flashed 1.9.9-pre3 stock ROM via CWM recovery (apparently, only recovery was flashed)
  7. Flashed 1.9.9-pre3 stock ROM via stock recovery (now the whole ROM was flashed)
  8. Flashed CWM recovery from XDA-developers forum via adb shell
  9. Flashed OpenGApps via CWM recovery

So far I have been using 1.9.9-pre3 with latest OpenGApps for a couple of days and the device performs great, except for one thing:

To the best of my knowledge, the hardware supports Bluetooth LE, but I can’t be sure whether it’s the OS or the app.

Thanks for your work on updating the stock OS for the FP1U and I hope this Bluetooth LE issue can be fixed!

1 Like

rogerpueyo This is a known weakness with the 1.9.9-pre releases. It has its own thread at https://forum.fairphone.com/t/bluetooth-connections-are-unstable-in-fp1-alpha/22003




I installed the pre3 a few days ago and noticed the following bug:
If I go back from airplane mode, the SIM card will not automaticly be unlocked. The same thing happens when I reboot the phone.
To unlock the SIM card I have to call somebody or go to the preferences.

Doesn’t happen here. Might be a faulty sim card. How old is yours?