FP1: Macadamia 1.9.9-pre3 Alpha (Android Kitkat)

Today it appeared for me for the first time that the on/off-button didn’t react at all. Had to take out the battery to restart. Worked after the restart. So i guess a software and no hardware problem.

@Stefan will try the cache clearing at least.

The on-off-button can be cleared by clicking one of the volume-keys. After this the power button should work just as well again.

My additional workaround is the Gravitybox-setting “turn screen off by double-clicking the status bar”. It also makes the power button last longer, as you only click it half as much. :blush:

1 Like

Hello all and @jftr,

I just want to say thanks for the port and beta but sadly I am no longer being able to help you as spare parts are more or less gone at the moment.[quote]In the meantime we can only apologise for the fact that we can’t provide them at the moment and we are not able to offer you a repair of your Fairphone 1.[/quote]I feel kind of sad leaving you all at this point and maybe someday I can be back…

Sorry for staying silent a long time, but I had some problems finding words.
Thanks again and good luck!


I’ve got a similar problem, my Micro USB port broke and I tried to fix it by soldering but failed (the port is nearly unreachable) and a new Motherboard costs about 120€, so I give up and buy a new phone. Since the Fairphone 2 won’t be delivered before the end of January, I have to buy another phone.
But I won’t forget your commendable approach to build a conflict free and modular phone and might be back with Fairphone 3 in a few years. I wish you good luck with your KitKat alpha and hope you can fix the remaining bugs soon, because some of my friends still have a working Fairphone 1 and keep asking when you guys finally finish this update :slight_smile:


Sad to see you leave, @Kuraron and @Sujus, but - of course - I understand.


Just found out here that this could be SIM related. Read more in the support article. In any case I don’t think it’s got anything to do with the alpha.


Hi, because some apps didn’t work with Andorid 4.2 anymore I decided last week to upgrade to 4.4.
I cleaned the cache and upgraded from 1.8.7 directly to 1.9.9-pre3. Everything worked fine.

I also installed Gapps via the fairphone updater, but there are some problems.

  • Everytime I start the fairphone some google apps randomly will close (e.g. “google play kiosk” wurde beendet; “Google Play Bücher” wurde beendet).
  • I cannot install the google keyboard (for swype)
  • I have the battery problems like it was mentioned before (e.g. drop from 40% to 15% within second)
  • the app “my phone explorer” does not work
  • I do not get any push notifications

But besides the battery charging status that are minor problems. Thanks for provding the update!



A few days ago, I installed the 1.9.9-pre3 ROM on the FP1U. The process was:

  1. Cleaned and wiped stock ROM 1.8.7
  2. Flashed CWM recovery from XDA-developers forum via adb shell
  3. Flashed unofficial ROM fp1-kk444-CH-0.9.7 by chrmhoffmann from XDA-developers forum via CWM recovery
  4. Flashed OpenGApps via CWM recovery
  5. Used it fp1-kk444-CH-0.9.7 for a couple of days
  6. Flashed 1.9.9-pre3 stock ROM via CWM recovery (apparently, only recovery was flashed)
  7. Flashed 1.9.9-pre3 stock ROM via stock recovery (now the whole ROM was flashed)
  8. Flashed CWM recovery from XDA-developers forum via adb shell
  9. Flashed OpenGApps via CWM recovery

So far I have been using 1.9.9-pre3 with latest OpenGApps for a couple of days and the device performs great, except for one thing:

To the best of my knowledge, the hardware supports Bluetooth LE, but I can’t be sure whether it’s the OS or the app.

Thanks for your work on updating the stock OS for the FP1U and I hope this Bluetooth LE issue can be fixed!

1 Like

rogerpueyo This is a known weakness with the 1.9.9-pre releases. It has its own thread at https://forum.fairphone.com/t/bluetooth-connections-are-unstable-in-fp1-alpha/22003




I installed the pre3 a few days ago and noticed the following bug:
If I go back from airplane mode, the SIM card will not automaticly be unlocked. The same thing happens when I reboot the phone.
To unlock the SIM card I have to call somebody or go to the preferences.

Doesn’t happen here. Might be a faulty sim card. How old is yours?


I’ve installed pre3 without any problem. It went smoothly.
One small issue GoogleNew is crashing.
Has anybody else got this issue ?


1 Like

After some testing I have to correct myself. At the first time I wrote too fast :wink:
If I go back from flightmode, the SIM card is automaticly unlocked without typing the PIN-Code.
Anyone with this issue?

1 Like

That is intended behaviour! I’m glad it’s like this because I don’t want to type in my PIN every morning when I leave flight mode.

But it was different before the update;)
I like it the other way because of security.

I know, it was definitely a bug! :wink:

Hello, I’ve installed Macadamia 1.9.9-pre3 Alpha on my FP1 second batch about one month ago, directly upgrading from Kola Nut.
I’ve been using it as my everyday phone since then so, from my point of view, I consider it almost “production ready”. Some small things I noticed:

  • proximity sensor: as already described in FP1: Macadamia 1.9.9-pre3 Alpha sometimes I seem to hang up calls with my face touching the screen. I installed the SatStat app and checked the proximity sensor seems to work fine (value = 1 when nothing is near, value = 0 when my hand is near or touching the screen).

  • the reminder that my second sim-slot is empty after power-on (not really a bug)

  • If I go back from flightmode, the SIM card is automaticly unlocked without typing the PIN-Code (already seen in this forum)

  • After booting the phone I always get a message box saying “System process not responding” Wait/Cancel? (the actual message is in italian, the translation might not be exactly the english version of the message). Clicking on “Wait” or “Cancel” apparently doesn’t change anything: the message box disappears anyway and the phone then works regularly.

I add my big thank you to the guys at Fairphone for providing this upgrade to FP1: I’ll be glad to contribute with further tests and information reporting as needed.

1 Like

I’ve installed pre3 on my first batch FP1 as a direct upgrade from @chrmhoffmann’s KitKat ROM.

It works good so far, but the first thing I’ve noticed is that the updater crashes immediately:

E/AndroidRuntime( 6573): FATAL EXCEPTION: main
E/AndroidRuntime( 6573): Process: com.fairphone.updater, PID: 6573
E/AndroidRuntime( 6573): java.lang.RuntimeException: Unable to start service com.fairphone.updater.UpdaterService@41c446b8 with Intent { cmp=com.fairphone.updater/.UpdaterService (has extras) }: java.lang.SecurityException: Invalid value for visibility: 2
E/AndroidRuntime( 6573):        at android.app.ActivityThread.handleServiceArgs(ActivityThread.java:2885)
E/AndroidRuntime( 6573):        at android.app.ActivityThread.access$2100(ActivityThread.java:151)
E/AndroidRuntime( 6573):        at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1418)
E/AndroidRuntime( 6573):        at android.os.Handler.dispatchMessage(Handler.java:110)
E/AndroidRuntime( 6573):        at android.os.Looper.loop(Looper.java:193)
E/AndroidRuntime( 6573):        at android.app.ActivityThread.main(ActivityThread.java:5299)
E/AndroidRuntime( 6573):        at java.lang.reflect.Method.invokeNative(Native Method)
E/AndroidRuntime( 6573):        at java.lang.reflect.Method.invoke(Method.java:515)
E/AndroidRuntime( 6573):        at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:825)
E/AndroidRuntime( 6573):        at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:641)
E/AndroidRuntime( 6573):        at dalvik.system.NativeStart.main(Native Method)
E/AndroidRuntime( 6573): Caused by: java.lang.SecurityException: Invalid value for visibility: 2
E/AndroidRuntime( 6573):        at android.os.Parcel.readException(Parcel.java:1465)
E/AndroidRuntime( 6573):        at android.database.DatabaseUtils.readExceptionFromParcel(DatabaseUtils.java:185)
E/AndroidRuntime( 6573):        at android.database.DatabaseUtils.readExceptionFromParcel(DatabaseUtils.java:137)
E/AndroidRuntime( 6573):        at android.content.ContentProviderProxy.insert(ContentProviderNative.java:468)
E/AndroidRuntime( 6573):        at android.content.ContentResolver.insert(ContentResolver.java:1217)
E/AndroidRuntime( 6573):        at android.app.DownloadManager.enqueue(DownloadManager.java:1018)
E/AndroidRuntime( 6573):        at com.fairphone.updater.UpdaterService.startDownloadLatest(UpdaterService.java:255)
E/AndroidRuntime( 6573):        at com.fairphone.updater.UpdaterService.downloadConfigFile(UpdaterService.java:170)
E/AndroidRuntime( 6573):        at com.fairphone.updater.UpdaterService.onStartCommand(UpdaterService.java:112)
E/AndroidRuntime( 6573):        at android.app.ActivityThread.handleServiceArgs(ActivityThread.java:2868)
E/AndroidRuntime( 6573):        ... 10 more
W/ActivityManager( 1565):   Force finishing activity com.fairphone.updater/.FairphoneUpdater

(Clearing the data of the updater doesn’t solve the problem.)

The design of the boot animation and layout looks great!

Just as a note: This happens with Telegram, too.

And it has happened with 4.2.2, too. (At least for me.)

I really like the new bootanimation, but I think the images 403 and on are a bit too bright.
This is mostly only distracting, but in some cases (Hello, broken USB connector!) this might be even dangerous, because in some circumstances the battery will only charge if the phone is mostly booted up.
So any bright screen can hurt.

I’ve simply made all images a bit more dark.

script for use in GIMP (extract the bootanimation.zip to a folder called "bootanimation"):
# to be pasted in the GIMP console
# GIMP is to be run from "."

import os

def load(name):
        return pdb.file_png_load(name, name)

def save(image, name):
        pdb.file_png_save_defaults(image, image.active_layer, name, name)

def main_func(arg, dirname, fnames):
       assert arg is None
       if dirname == "bootanimation":
       for file in fnames:
                # number = int(file.split(".")[0])
                complete_filename = os.path.join(dirname, file)
                image = load(complete_filename)
                pdb.gimp_brightness_contrast(image.active_layer, -50, 0)
                save(image, complete_filename)

# bottom
os.path.walk("bootanimation", main_func, None)

The resulting bootanimation.zip. (You can put this in /data/local/ and it will survive ROM updates!)

The differences:

before after

Disclaimer: I have just tested this in an emulator. But it shouldn’t brick anything. If it doesn’t work, just connect your phone to a PC, delete the file (via adb) and reboot.

(cc: @vhanniet)

edit: A note if you want to create your own: Be sure that you don’t compress the zip file. (I did that mistake first.)

edit 2: The weird thing is that it works fine when I run bootanimation by hand, but not on startup…