FP 3 won't start anymore

Dear community,

I’m desperate…

It was my own failure, but maybe you can help me:
I tried to root my fairphone.
It worked.
I disabled Googles applications
Then the Fairphone didn’t want start anymore.
I tried to restore the Fairphone with the original image: [HOW TO] Flash a custom ROM on FP3 with GSI
But I couldn’t boot the TWRP image.
I couldn’t boot any image. So I tried to activate via fastboot --set-active=a and b
But now, the Fairphone don’t want to start at all. The phone vibrates, shows the Fairphone-splashscreen very short and shutdown. If I plug the power cable, no LED glowing too.

Has anybody any suggestions?

Way for solving the problem
Pressing Volume-down & power-button to start fastboot
try to fastboot --set-active=a or b
in my case, if the b-slot is active, the device run fastboot (but the reason for this could also be flashing of the device (see #3 in FP 3 won't start anymore). in slot a the phone shows only short bootsplash and shutdown.

Anyway I can’t boot twrp, but that’s another problem…

Sorry, cannot resist: Why did you do it?

Otherwise, I do of course hope that someone here can help you out.

Do you still have a working bootloader? If so, please try this script.
If not, please refer to this thread


First it didn’t luck for me to root the phone. That had should be the moment to say: ok, it’s fine. Never change a working system blablabla.


Thanks a lot.
Do you know how to solve the problem with the system.img (Value too large for defined data type)?
I have only the long usb cable from Fairphone. Should I try to get a shorter one? Has somebody experiences with this issue?
Another usb-slot doesn’t work too.

#offtopic: Happy I<3FS-day everyone! Thanks a lot dear developers!

I think the problem could be I’m using a 32 bit system. Damn…

If it still shows the splashcreen, fastboot should still be working.
Did you try turning it on with the Vol Down + Power Button?

1 Like

Yes, but now after I followed the instructions from pigpig I could boot in fastboot again. Now I try again to install TWRP and Android.

I running it with the windows PC from my girlfriend. So I could flash the system.img with fastboot -S 256 flash system system.img

Wait, shouldn’t be the linked system.img in FP 3 won't start anymore an operating system? So why it can’t boot?