FP 2 + Android 6 Upd > boot freeze without option to recover

I am stuck in a bootloop of my FP2.
All instructions referring to recovery mode don’t work, i.e. my phone is ‘dead’ and I need your help.

  • I updated the updater this morning
  • I fully charged the battery
  • (Before that I frequently applied all incoming security updates).
  • I got a suggestion for the Android 6 update, at least that is what the strong version number increase implied to me.
  • Whilst the updater showed a progress of approx. 60-70 % the phone froze.
  • I restarted the phone by pressing the power button for 10 sec.
  • The phone started rebooting and is stuck whilst booting, i.e. black background, with white Fairphone Logo (and “powered by Android” text).
  • If I apply all suggestions for booting into recovery mode, – shutting the phone down, pressing power and volume up for a long time – I end up at the same screen. If I apply the pressing of the buttons to long, I runs in circles.
  • More details: Actually I cannot shutdown the phone by a long press of the power button, as the phone will reboot directly.
  • I tried various alterations:
    ----> Removing the battery and then booting into recovery
    ----> Pressing the power button for a long time to shutdown in conjunction with hitting the volume up button.
    ----> Unfortunately there is no instruction how to boot the FP2 into recovery only the FP1!

I would appreciate any assistance.

Regards
Christian

The recovery mode works a little differently with Android 6, see here.

1 Like

There is! -> #dic:recoverymode But you do it the right way anyway:

That should get you to the resting robot screen. If you are still on Android 5 (which I’d guess since you say the progress bar never got past 70%) you then only have to press the power button to open the menu. On Android 6 it would go like this:

But what you describe:

Sounds like #dic:fastboot mode. (Usually you’d get there by pressing Vol- + Power

Do you have a Slim Cover?
Slim Covers are known to cause Button Issues. It’s usually the Power button, but maybe your Vol- button is stuck. If so take the cover off and then try to get to recovery again.

Thanks for your quick reply!
I also assume that my phone is still on Android 5.
I conducted all tests without the slim cover. The buttons do not make the impression that they are stuck.
Everything is as described.

From the instructions:

When you see the Android robot: hold the power button, then press the volume up to display the recovery mode

This instruction does not work for me: Nothing happens when pressing both buttons once and if I hold them longer the system will restart to get stuck there again.

By the way: I did this with a recharged battery, just in case the installation should have drained it too much.

For me it worked to clear the cache via Fastboot but after that the updater was broken.
So I flashed the old Android version manually.

I cannot boot anyhow. Any suggestion how I could clear the cache?

Install the Android SDK or/and the Android Tools and connect your phone via command line:
https://forum.fairphone.com/t/fp2-android-6-0-fairphone-os-17-04-8/26387/272?u=kephson&source_topic_id=28170
The screen with the Fairphone logo is the Fastboot mode.

Thanks Kephson,

It says I don’t have access to the provided topic behind the link, no matter how much I shorten the URL

If I have my FP2 connected to my mac

  • “adb devices” gives me no device and
  • “fastmode devices” gives me no device

on the command shell.

There are manual update instructions to be executed from a computer:


Following these, my phone does neither make the impression of being capable to go into ‘fastboot’ nor ‘system recovery’ bootmode, as the depicted instructions do not appear to have any effect. My phone just hangs when the white fairphone logo is displayed with the footnote “powered by Android”. I get more and more the impression that I got a hardware defect during the A6 Updated executed by the Fairphone updater App. However this is a strange coincident, isn’t it?

Ah sorry, the link is from the beta area.
I think the driver is missing for the phone? I’m not really experienced with Mac OS…

I don’t think it is the driver, as the phone has been discovered for Android development for over one year without any issues.

As @Kephson already mentioned, that’s what the phone being in fastboot mode normally would look like.
Just to make sure:

  • Connect the phone to your Mac
  • Start up the phone with Volume down button pressed -> would normally mean booting into fastboot mode, giving the impression to hang just like you mentioned
  • Try “adb devices” or “fastboot devices” on the command line again

Given that, if adb and fastboot still don’t work, there would be indeed something wrong, I don’t know about Macs, sorry. Perhaps contact support?

Hi there,

I come to the conclusion that my phone is broken.
The Mac platform tool installation is ok, up-to-date and works with other devices, i.e. I can connect a tablet via adb.

I tried many times to get this thing into fastboot-mode, but no way. I have an offical fairphone support ticket and I will add a link to this thread.

Thanks anyway.
Let’s look for a replacement phone…

Hi…the exact same thing happened to me. Fully battery; most recent update May 17, phone frozen on black screen with white FAIRPHONE and powered by android. I have tried power+volume…but phone just reverts to same black screen. I have taken out battery but same screen.

This exactly describes what happened to me this morning. Fully battery/ Updated 24th May 2017/ Tried to restart as you describe and got the same screen as you describe. Like you applied all the suggestions for rebooting ie power+ vol/ pressing power for 15 secs. All that happens is the same screen appears.
I also tried the link that Kephson suggested but like you got the message cannot access the link…although I dont have a Mac.

Please help

Hi Corkie52,
I tell you how the story went for me

  • I sent the phone to the Fairphone repair center
  • I just came back: It works fine, came with an old Android, the Android 6 update could subsequently be applied smoothly by me.
  • According to the repair note, the motherboard of the phone had been replaced.

I would suggest to

  • find a local Android guy/developer, who might try to connect the phone from a computer via ADB. Ask Kephson if he can grant you the rights to access the instructions
  • try to repeat the button instructions with the sd-card removed (… I have not tried that, not sure if it helps).

Good luck.

Thanks Christian

I will try the with the sd card removed…but I think a trip to a local phone shop is probably next steps

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.