For a Better Camera on deGoogled Operating Systems

Would be great to have a fairphone #fdroid repository to get all app updates on custom-roms

3 Likes

That’d be the dream! I’d edit my original post to include that in the template message to customer support, but looks like it is too old.

Any change to get this Update in calyxos ?!?

Hi and welcome to the forum, jedie!

A couple of posts above is our best knowledge to your question:

3 Likes

Good News for CalyxOS users and also a little downer.

They working on getting the new stock FP camera app to work.
Unfortunately they didn’t add “libtctcameraalgo_jni.tct.so” to there recent 4.5.1 release. It’s in beta now and I installed it right away.
I was hopping to install the new FP camera app. But I guess only adding the library is not the solution. But I’m happy that CalyxOS invest some of there resources.
Old FP camera app is still working great, except some features are still missing, like before. I just did some quick tests.
Switching between the two main cameras is much faster. Taking pictures seems to be faster too.
I don’t see any improvements in the pictures. They are good, but not different than before the firmware update.
I use the following apps:

  • OpenCamera 1,52
  • CalyxOS Stock (camera2)
  • GCam sgcam 8.5 (only 8MP)
  • FPcamera 2.0.039
    There might be some details I missed. Please write your experiences.
3 Likes

/e/OS will provide new firmware with there os updates.
They have a great community forum for further questions.

1 Like

I’d like to give it a shot as well, but I’ve installed /e/ on my FP4 long ago. Is the FP4 camera app only available as part of the official image or also standalone so I can install it on /e/?

As of now, I am not aware that anyone has been able to make it work and available as a standalone app. However, some are trying, and Murena has not ruled it out yet either:

3 Likes

Thanks for the link, @urs_lesse

At the CalyxOS front there are no news apparently. I just tried to install the stock camera app on my FP4 with CalyxOS 5.6.0 from April 5. This is what I got:

$ adb install FPCamera.v7.00.04.0007.4.0.apk 
Performing Streamed Install
adb: failed to install FPCamera.v7.00.04.0007.4.0.apk: Failure [INSTALL_FAILED_MISSING_SHARED_LIBRARY: Reconciliation failed...: Reconcile failed: Package com.fp.camera requires unavailable native shared library libtctcameraalgo_jni.tct.so; failing!]

I have no idea why but for me installing FPCamera.v7.00.04.0007.4.0.apk uploaded by @hirnsushi worked just fine on CalyxOS. The camera app seems to work, I can open it, take pictures and videos, change settings, switch to the gallery and so on.

I am running CalyxOS 5.6.0. Before attempting the install, l had already installed

  • the previous FP camera version (which I rarely used because I preferred gcam and it always crashed when opening into photo mode, only Pro mode worked via the launcher shortcut)
  • CalyxOS GcamPhotosPreview immitating Google Photos
5 Likes

out of curiosity, how did you download the .apk? I used Firefox on my phone, but perhaps it garbles the file in some weird way and there’s no such problem when downloading on PC.

1 Like

I downloaded the camera apk with Chromium, directly on the phone.

huh. I just downloaded in on desktop and got the same error as on my other attempts (App not installed as app isn’t compatible with your phone), so I guess that’s not that.

1 Like

same happens to me. Just tried it on the phone directly. Installed gcamphotospreview from the calyxos page, downloaded the apk from the mega link. Installation fails because app is not compatible with the device.

1 Like

Did you both have the previous FP camera version installed before attempting to install the new one? If not, what else could be different on my end that may effect the camera installation?

no I didn’t. Is there an extracted apk somewhere of the old version I coild try?

Don’t remember where in this forum I had the apk from but you could test this one from 2022 which is the year I installed it:

nope, never installed Fairphone’s camera on Calyx before.

Hey @cosmic, could you add your findings to this issue?

Your input might help them to reverse engineer the dependencies necessary. Don’t feel the need to be super detailed, they’ll ask if they need more info.

(also I am jealous you managed to get it working…)