Foodora App logs me out instantly

Ooh nice competition! And congrats!!
Also so awesome that they listened!

That’s a safe bet for a start.
Although honestly, with all this installing this and that having been going on now on your phone, I personally would wipe the phone completely and set it up from scratch.

But I know (because I’ve done that a few times myself) that it’s a real hassle and you have to have confidence in your data backup and I understand everybody wanting to avoid that … but it really takes possible pitfalls in the current setup out of the way reliably.

Can’t hurt, but don’t expect quick results.
You could ask them which Google services the App exactly relies on. That would help in picking the right Open GApps package for the moment until they perhaps improve the App.

Yes. If you don’t want to wipe the phone, then remove microG at least, as you can’t count on it to reliably solve your case.
Then install Open GApps.

If all else fails, yes.

Of course you can, but it makes no sense.
Even the smallest Open GApps package, pico, installs the real deal, the Google Play Store.
If you have the Play Store, you don’t need Yalp or the likes.

I don’t have much insight regarding microG because I don’t use it, but it seems reasonable to me that microG and Open GApps could get in the way of each other.
The purpose of microG is to try to look like GApps as much as possible to the OS afterall.


In case you’ll follow @AnotherElk’s suggestion to wipe the phone anyway and want to deactivate microG, I would consider switching to the original LineageOS (i.e. the flavor without microG).
Then you won’t risk any interference between microG and OpenGapps.


The minimal OpenGApps package (pico) has all the necessary parts and libraries for third-party apps to work just fine. So don’t worry.

Yes. microG and original GMS are incompatible.

I’d say there’s no other way. Flashing OpenGApps on top of microG could go wrong, and OTA updates for the LineageOS for microG ROM could cause a lot of troubles, too.

Just for stating this here: official LineageOS can’t be flashed on top of “LineageOS for microG”. System certificates are different, and certificates are saved to the data partition, so it won’t boot without wiping the data.


Hi again, and thank you all for your help! I’ve really learned a lot!
I’ve now installed the newest version of LineageOS, but for some reason can’t find it in storage when the phone is in recovery mode (I think this is because of some setting I’ve changed way back but am not sure which one). Either way, from what I’ve learned from your comments, I am pretty sure just updating LineageOS won’t help me with my problem. So what I am planning to do now is:

  1. backing up contacts, photos, etc
  2. factory reset
  3. install LineageOS (without microG)
  4. install pico (GApps)

I’ve never done anything like this before so am excited but a little scared I’ll mess something up. Therefore asking you here, is that the right order to do everything? Did I miss something? Do you have some tips, or some info I just have to know before I start?


Really wipe the phone.
The factory reset only deletes all user Apps and data, leaving the OS as is (including possible problems).

1 Like

4 posts were split to a new topic: The Fairphone 2’s factory reset … or the lack thereof

now I’ve backed up everything I wanted, downloaded Lineage OS (latest version from here: and wiped my phone.
When trying to restart it tells me “encryption unsuccessful” and that I need to perform a factory reset. But when I click “reset phone” it restarts again and then just comes back to the same page. Have I destroyed it?

Encryption data needs to be wiped on its own. Hope you’ve backed up all your info in your PC.

Follow the instructions in the second paragraph of this post:


Ah, I see. Not sure I did that.
Yes I backed it all up in my PC.
My problem right now is that I can’t get back to TWRP, since it only shows me this one same screen saying “encryption unsuccessful”. Do you know how to do it? Press some certain buttons at the same time?

1 Like

So a few hours ago I managed to get into TWRP! This by shutting the device off and then first pressing the power button for like one second and then also pressing upper volume button (both at the same time.
Since then I’ve been trying to install LineageOS and wiping internal data (in case that wasn’t done before. Looks like it’s all gone though. Or where do i find encryption data?)
I have the latest version of Lineage OS on my SD-card as a zip file. When i try to install it it either says failed (if i tick the boxes "Zip signature verification " and “Reboot after installation is complete” before flashing) or succesful (when i keep those boxes unticked). In both cases the phone comes back to the “encryption unsuccessful” screen when trying to reboot into system mode.
Also restoring the backup fails, as well as wiping cache and dalvik (i think it’s already wiped though).

Is there some step in this that I’m missing? Do i need to do something before installing LineageOS? Do i need to download something else to install at the same time as LineageOS? Do I need to download a different version of LineageOS?
Any other ideas??

Possibly formatting data like @Roboe suggested?

Wiping doesn’t remove the encryption, formatting does. Well, most of the times.

If in your case it doesn’t work this way, please follow the steps given here from “Destroy the LUKS Header for Filesystem Encryption” on …

(I had to do this myself once.)


But actually now that i checked the wipe option again, i realize “format data” is actually what i clicked in the first place. So that’s the first thing i did before trying to install LineageOS again etc.

Hey!! So this just happened (before i could post this reply)! I formatted the data again once or twice and then my dad came by and clicked “wipe cache/dalvik”. I told him it would just say “failed” and then ask for a reboot, after which it would return to the screen saying encryption unsuccessful, because this is what happened to me several times today. But then suddenly a different thing showed up, there were two boxes already ticked, one saying something like “install TWRP app if not already installed” and i think the other said something like “reboot when done” but i am not sure. My dad clicked “do not install” because i told him i already had the TWRP-app. The LineageOS loading logo came up for quite a long time (a few minutes) and then the phone started into system mode!!! It asked me to choose a language, set my timezone and other things to get started, and now guys, i have lineage working on my phone again!! Hahaha sometimes you just need someone new coming in and pressing a few buttons! (i’m very happy but almost a little irritated it got solved THIS easily all of a sudden, and he didn’t even know what he was doing)

But a BIG BIG THANK YOU <3 to all of you who walked me through this and taught me so much!! I think from here on I will manage on my own, otherwise I’ll come back again (or hand my phone to my dad for 2 seconds haha)

NOTE THE EDIT: My dad did NOT install the TWRP-app when this option came up, as opposed to what i wrote earlier (asked him afterwards what exactly he had clicked).


Oh and another thing!
Now i’ve installed the pico Open GApps (link for anyone who might need it: ), and just installed the Foodora app Roadrunner (the one i was having problems with to start with, remember? :wink: ) and it works!! :smiley: THE PROBLEM IS SOLVED! Thank you again for this experience and i wish you all a very good night! :stars: :last_quarter_moon_with_face:


How about a free salad for all contributors?..:grin:
…just kidding, have a good ride.


Hahaha will come by your house tomorrow, with a salad in my foodora bag :smile:

1 Like

Great! I’m glad you can do yooyour work comfortably now! Have a good ride, :biking_man:

1 Like

Hahaha yeah thanks to all your rob(oe)ust answers! :heart_eyes::star2: Lol it literally took me all these 3 days to come up with that reply

1 Like

Hahaha, :blush:
Yeah, quite difficult nickname for puns I have!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.