English

Flashlight / torchlight / "Taschenlampe" grayed since update to Android 9

Hello,
since the update to Android 9 , the torchlight/flashlight (Taschenlampe) icon on my FP2 is grayed. So I can’t switch it on. Does someone know a trick to get it back ?
(Had helped me in the past, when I had been standing in the dark, with the light on my bicycle failing suddenly…)

2 Likes

Does the rear (main) camera work incl. flashlight?

1 Like

Obvious question…
Yes and yes: Camera including flash works.
I also read this, that this is no general issue ? Your’s is working ?
I had a stroll through the settings, but no obvious candidate for omissions…

Similar here also with Android 9 for FP2 (21.03.0-rel.2).
Torch icon is grayed, but only first 1-2 minutes after reboot. After this initial time the icon changes to normal color and can be used…

4 Likes

Note: There is a bug open for this one:

5 Likes

Thanks for the hint: After a reboot of my FP2, it started to work immediately.
Let’s see if it stays this way after the next shutdown/charging etc.

2 Likes

You might add the reboot workaround in the bug report now :slight_smile:

Done. Let’s see what will happen tomorrow, after shutdown and charging the phone…

2 Likes

Here is the unfortunate answer:
after the next shutdown + charge, the torchlight is grayed again.
I had the phone shut down and charging while in shutdown during the night. (Charging on a “Fritzbox” DSL USB port, because it is using standby power anyway; this always worked in the past)
When I started it, it came up with the torch grayed out again. I waited 10 minutes (while doing google store updates etc.),but it stayed grayed. Then I rebooted. It came up gryed as well. It is now running for 10 minutes again, but the torchlight is still grayed. So either it takes long, or there are other factors.,
And - oh yes - the main camera and the flash are working as expected.
Updated the bug report accordingly.

2 Likes

I’m just wondering whether there’s a connection to …

If the phone (wrongly) reads a battery level of 10%, perhaps the torch gets disabled because of low battery?
An internet search suggests there are Android OSes out there which even disable the camera flash with low battery.

Is the torch disabled, too, when the battery is charged and the
battery level is reported correctly?

Hello elk !

no, I assume there is no connection.
When the phone gets switched on, it shows some 9x % (98/99 here most of the time) of battery charge.
So that should be ok.
OTOH when I now checked in the evening (77 %), the torchlight was active.
Next try: Charge switched off with “real” USB charger, then recheck…

Edit: On start after that, it worked immediately. Back to slow charge tonight.
(Is there a connection???)

1 Like

Ok, there seems to be weird connection:
This morning after “slow” charge, the phone was at “10 %”. After start it showed 98 %. Flashlight disabled.

[Edit: And tonight, without charging but switched off, it was at 45 % on switching on - flashlight disabled. So it is not the slow charging…
Ok, I’m abusing this thread now, to collect indications, then updating the ticket with hopefully a reasonably summary…]

I have the same problem since the update to Android 9
Yesterday I could not use the flashlight anymore.
Rebooting with battery charged 98% did help this time but I wonder for how long…

1 Like

Two FP2s here at home. Almost identical installations. Currently, one has the flashlight tile greyed out, so it doesn’t work. In the other FP2 however the tile is bright, and the flashlight function works through the quick notification tile or through the camera apps.

The camera apps can activate the flashlight in the phone with a greyed out tile, same behavior mentioned by the OP above. The tile button however doesn’t work when it’s greyed out.

In the buggy FP2, some flashlight apps are able to always turn the flashlight on, while others will crash or give a message saying that the camera hardware wasn’t found.

The tile works intermittently or stops working on both phones. Rebooting works only sometimes, most of the time it doesn’t change anything.

Here’s however a consistent workaround: I installed ClickLight. This app is able to turn on the flashlight on both phones always, and creates another flashlight tile that is fully functional. It also adds some nice extra features, such as criteria for turning off the flashlight automatically.

I hope this helps anyone having similar problems.

3 Likes

Thank you! This has also been annoying me so at least I have a flashlight app that works now with the ClickLight tip!

1 Like

Hello, it works also with Flashy app

1 Like