Flashing SailfishOS?

Since my presentation I bought an FP2 two weeks ago (yay!), and didn’t had time to flash a new OS since (boo!) Still on my old phone …

Infos are a bit spread over many websites, wikis, community forums … I’m lost. And since I didn’t flash any Android since v2 I need some help :blush:

=> I have a recent version, so new screen hardware as I read (messages from Feb 2018) does all images (SFOS first) support this ?
=> It tells me I have a 18.04.1 version, but not sure if it’s an FP Open or FP regular Android version: Do I need to flash LineageOS before SFOS ?

=> I recalibrated the proximity sensor (the wiki page https://wiki.merproject.org/wiki/Adaptations/libhybris/Install_SailfishOS_for_fp2 will need an update to explain how I think) Is there anything else to do ?

=> I tried to flash TWRP following this: https://wiki.lineageos.org/devices/FP2/install it’s seems to be OK but when I try to boot in recovery mode I just get an Android mascot, opened with “no command”
I remember to have a menu to flash images, with vol + & vol - to navigate throught
How do I know the TWRP flash is ok ? If it isn’t What did I do wrong ?

=> What is the difference between Vol + & Power / Vol - & Power boot method ?
The Vol- methode give me a frozen FP2 with the “Fairphone powered by Android” screen (all B&W)

Bonus question: What happend to the “Alternative OSes” section in this community, all messages were deleted/moved, do all messages have to be in “Help” section ?

Thank you !

OK I got answer to 1 of my questions here: Dictionary Entry: Recovery Mode

If you follow the guide you linked to, it says after step 5 (flashing TWRP to the phone) …

“6. Now reboot into recovery to verify the installation”

That’s important. Boot into TWRP right after you flashed it to make it resident, because booting into the OS just after flashing TWRP will most probably result in the OS restoring its own recovery, and that’s what you ended up with … the stock Android recovery of Fairphone OS.

Vol- … It’s not frozen, this is what Fastboot mode looks like, there’s nothing more to it. This is also given in the guide you linked to (step 3).
Vol+ … recovery.

1 Like

Thank you

I really think I booted to recovery mode just after flashing, at least I tried because I didn’t want to boot the OS
But I may have failed, I’ll try again. The confusion between the two modes is almost cleared in my mind, it should be ok now. I’m waiting the battery to be fully charged before retrying :slight_smile:

Yes, Sailfish OS is now compatible with the new hardware :slight_smile: To install it, follow the instructions on the wiki

Edit: SailfishOS is compatible with new camera since Alpha5 - 5 March 2018


I finally managed to try it again

How do I properly quit fastboot mode after a flash (“OKAY” in my console)
When I hold power to power off it restart instantly and I don’t have time to hold vol+ to boot in recovery :frowning:

Thanks !

I got it ! Keeping vol+ pressed while power maintained to reboot

Whaw … I feel dumb

Finally I’m a Sailfish user !
I didn’t test with a SIM card for the moment but I am excited !
The only thing I found is the shortcut for the WLAN which doesn’t power off WLAN, it only permits to activate it and connect.
But it is the same on others mobile OSes as far as I know

Edit: I was wrong, we can disable WLAN from shortcut menu !

So many thanks to all of you here and to Sailfish contributors on Fairphone :smiley:


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.