Firefox: Laggy scrolling

The scrolling in Firefox is really awful, very choppy / laggy.

Did someone already find a solution for it? I tried setting mousewheel.min_line_scroll_amount to 50 in about:config, but that didn’t really help much.

I do not have this problem. Does this problem occur with Privacy Impact enabled?

Is it just in Firefox?

Maybe you simply have this bug:

Yep, still quite laggy.

Until now I only noticed in Firefox. It’s not related to the touchscreen I think. Firefox implemented their own smooth scrolling algorithm, maybe either the parameters need to be tweaked or Firefox doesn’t properly use hardware acceleration.

Maybe you can try to disable this feature?
Athough I could not find this option at the mobile version, I know it exits in the desktop version.
Thus it should be possible to acces via about:config


I had the same problem. On the web I found some suggestions on how to change about:config settings in firefox - those did not help. I reset to the original settings.

After a reboot, the problem had gone. At least for a while - when it came back, I killed ff (via settings->apps) and the problem was gone - this time permanently (at least until now).

I hope this helps you, not sure what the real reasons for this problem / solution are.


Hm, that did improve the situation significantly :slight_smile: Strange… Maybe it had to do with some initialization that occurs on the first boot?

The scrolling is still a bit strange, but that’s probably just the physics settings in Firefox.

1 Like

I’ve seen it while scrolling in other places too, like the built-in Browser, or Tinfoil for Facebook.