FF2 reports no compass


I tried to start Sky Map and there is a long message at start-up saying that my phone reports not having a built-in compass. I used the A Compass app which state the same. Google map is not rotating as I rotate the phone etc…

Restarted the phone and it’s the same. I can find no option when the compass could have been disabled. Location services are set to High Precision.

Is it a software bug or a hardware failure?

This app https://play.google.com/store/apps/details?id=com.simplywerx.compass3d works fine with the compass on my FP2 and I checked just now that I didn’t give any permission to the app (I’m running LineageOS 15.1 on my FP2).

What OS are you running? Is your FP2 rooted and do you use any special app restriction software?

Hey. Thanks for your reply.

Just tried the app you linked. It ask me to do the 8-motion calibration thing. But everything stays at zero. There is no intensity, or magnetic field direction detected.

The FF2 is not rooted, I’m using the last version installed by FF Updater: 19.02.1

Did it work before the update to 19.02.1?


I actually did the update yesterday and I had the problem before.

Le mar. 5 mars 2019 à 09:01, Ingo Strauch via Fairphone Community Forum noreply@fairphone.com a écrit :

Maybe you should contact the Fairphone support then. Sound a little like a hardware problem.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.