Fariphone doesn't turn on

Last night I plugged my Fairphone into the charger.
On the next day my Farphone was turned off although it was on at the previous day.
My Fariphone didn´t reacts when I press the power button.
I already exchanged my accu with an other owner of a Fairphone and it showed 100% at his
so the accu is not the problem.

Please respond to my problem.


Same problem as redbeefeater

I suggest you to contact the support team directly, maybe they will help you in the best way.

I have had this problem for a few times now. Only a hard reset works.
This time, I’m waiting for support feedback before wipîng all my data again, but so far I don’t get any answer…

Did you try again, after you had taken out the battery?

PS.: Do you have Google Apps installed?

I tried it again but still doesn´t work.
Hard reset is not possible either =(

Suggest you report this to Fairphone Support. See Fairphone is dead and competely unresponsive

That’s strange. Hard reset worked for me the last 5 times.
Last time, I had to wait two days before the FP “magically” decided he wanted to charge again. Even through it was almost completely charged when the problem began, it turned out the battery was completely empty. So maybe by now you can try again to charge the phone and do a hard reset afterwards? Don’t forget to “turn off” the phone first by taking out the battery!

As soon as support sends me feedback, I’ll let you know what could be a solution. But so far, I didn’t hear anything from them…

1 Like

Yeah, sometimes one needs to be patient for a while, and then out of nowhere, everything works like before…

Apparently, the problem could be caused by an “old” SIM-card. If your SIM card is older than 1,5 year, replacing it could help prevent this problem from happening again in the future.

But of course, first you will have to do the hard reset and loose all your data…

1 Like

Please also search here for an answer to your problem.

This topic is now closed. New replies are no longer allowed.