Fairphone updater app doesn't stop crashing. Unable to open it and to update

Hi there.

more or less 3 month ago my Fairphone started trying to download updates every day.
I thought it was a usual way to keep the phone updated, then the updater stopped working completely.
When I tried to open the app it got stucked giving this message “Fairphone updater crashed unusually”.
I have been waiting for the OS update but even in that case, there was no way to let the updater working. I’m not even able to check which OS version is running (as far as I know: FP1, upgraded storage, previous OS version than the last one available) .

Any suggestions?
thank you in advance,

Try to perform a manual update

I’d first go to 'Settings > Apps > All > Fairphone Updater and clear both cache and data. Maybe there is some file corrupted. Doing the above would help you get rid of a possibly corrupted file.

thank you both.
I found the cache already cleared, then I cleared the data and actually it works!
My FP is now downloading and installing last OS version.


I have been having an issue for months where I can not download kola nut. Google Play has disappeared and I can not download new apps or update whats app which ahs stopped worked. Please can you tell me how to upgrade to kola nut as eveything I have tried has not worked. Thanks

What happens when you try to install the update?
Did you try the “stay awake trick”? (settings > developer options > tick stay awake, then plug in your phone and run the update through the updater app)

…now my data backup is impossible to be restored.
Backup & restore app crashes everytime I try to restore data…
Applications backup only could be restored.
Any suggestions, please?
I have already cleaned cache and data.

I actually just tried ‘stay awake’ again and it worked! I had tried umpteen times before. Also if I down load titanium backup, will it delete anyinfo on my phone? Many Thanks :grinning:

1 Like

@Es_Ter You might have to install Fairphone OS 1.8.7 again. By doing so, also Backup & Restore would be installed again and, hopefully, work afterwards.

@toganeger Titanium Backup is there to backup apps, not to delete them! :wink: On a serious note: Titanium Backup should not delete anything on your phone.

Hi again. Sorry for the late reply. And thank you.
Something weird happened.
I didn’t reinstall the OS but suddenly the contacts weren’t available anymore.
Then, without doing anything, the phone restarded with the presentation of Fp, you know, that introduction that starts when you reinstall the OS (and you chose the language and install the wifi)
Than I found my desktop cleared (no app) but the google pack available. No way to access to the contacts, nor the phone itself.
Then I reinstalled the google pack, but no contacts available and no way to find the sign of the phone, no way to make a call.
Then I came back to this post (and to others, without solutions) and I decided to reinstall the OS and the google pack.
In addition, I tried to restore my old backup, but backup&restore app keeps on crashing.
Now I can read the names of my contacts, when I open the sms app but no phone app is available. I’m not able to make a phone.
I tried through the sms app pushing the phone botton which is up on the right, but then only skype is available.
Please, help me find a solution.
I’m tired, I’ve many other important things to do and deadlines to meet too and the only thing I shouldn’t be worried about is maybe my ethic smartphone. I would like to have my phone back.

Can anyone of you help me anyhow?

I think you should do a hard reset. Then try to restore the backup.

it absolutely didn’t work. The hard reset, I mean.
Before trying this solution, I connected my FP to the PC in order to copy everything on it, but the FP couldn’t be read.
Then I tried to make a new backup with a different app (sms backup) but It crashed.

ironic. What a wonderful birthday.
Anyway, I tried the hard reset.
well done…but…backup&restore app crashed again, so that I could only restore the applications, not the data.
All my sms lost.
and whatever I had before.

Now I’m scared of any other OS upgrade.

Any suggestions for any recovery program?
I’m tired, annoyed, depressed, disappointed.

Hello, this all really sounds a bit depressing. As far as I understand it, you have a working old backup of your data somewhere, but you cannot restore the data right now, because that app “Backup & restore” keeps crashing, right?

Could you verify that the backup worked? (Check the files on your computer/mail that the backup created?)
Could you tell me if the app was always around or if you have installed it from an app store? What is the apps correct and full name? I just want to make sure we are talking about the same application. I’m thinking about the one that “comes” with the phone (The apps icon looks like a clock with an arrow around it).

Could you post some more information about your phone and it’s current state? I wonder why things crash on it all the time, so it would be interesting to know what software currently runs on your phone.

System settings -> System/About phone

Should give you some information. If you could post that (Android version, Build number) we would know at least roughly what’s is running on your phone right now.

Don’t be afraid of upgrading … but check first which version you are running right now. And better do not install any google services until you have upgraded to the latest version “1.8.7 Android: 4.2.2”. Verify this by checking the update app/About phone.

Good luck! Don’t give up!

Backup & restore paths:

Latest update:

I’m not sure if I have the time to come back here this often this weekend, but if I were stuck like you I would do the following:

  1. Check if my backup with the standard app has worked. (If not, there will not be much left to restore, so make sure the backup worked. Your phone is “clean” after the hard reset anyway.)

  2. Get a miniSD card and put the latest software on it. Put this SD card in the phone. (I don’t trust the updater software. The linked page will explain you how to update the phone without the upgrade software.)

  3. Boot the phone into the Recovery Mode.

  4. Install the latest update from there.

  5. Try the “Backup & Restore” app again.

There is a better guide for this here, just follow it:

This is just a tip so you can do something and to get your phone up and running again. Maybe others will also read here and have better ideas if you tell them more.

Thank you for taking care of my case.
Here you find the screenshot of my “about the phone” from the settings.

I would like to add something to complete the sequence of steps that I have been following before the hard reset, yesterday.

Just for information, I already use a micro sd in my FP, 2 sim cards. The memory of my phone was occupied with 8,8 gb data and had the rest as free space.

  1. As I wasn’t able to make calls and as my last backup (through backup&restore)
    hadn’t worked after last OS upgrade (but still everything was there, then I thought I wouldn’t need it), and the only suggestion I could get was “try the hard reset”, I have tried a sms backup with SMS backup and restore app (a different one from the one included in the phone) but the backup couldn’t start, then I downloaded Titanium backup (free edition) and launched a different new
    backup which was ok and I looked for other ways to solve my problem.

  2. Meanwhile I have been searching useful tips in the fp forum regarding what was happening
    to my phone and I realized that having the wifi signal grey instead of blue, could represent an explanation the problems with the contacts. Unfortunately, I wasn’t able to find any way to find and “open” the required accesses which were supposed to be –no idea how come- closed. (I have no idea how to let google play services connected, I suppose).

  3. Then I tried to reinstall the OS upgrade and google apps in order to try to restore any kind of backup.

At that point, as I reboot the FP no google app was available, nor contacts, nor sms even if I could see a 5sms green envelop and 2 lost phone calls sing in the “stand by” display (the one with the clock, before you swipe to access the phone).

I launched the restore through the backup&restore app and it crashed, then I tried with Titanium and it get stuck at a certain point. Then it wasn’t able to restore/reinstall most of the applications, almost all the google and the system apps, giving them as “strikethrough” in the list.

  1. I have connected the phone to my pc, in order to see what I could do, and to copy everything on
    it, as I am used to do, sometimes, but the FP wasn’t readable at all, no way to “see” it.

  2. I disconnected the phone and tried to reboot it and something more worrying happened: once it
    was turned on, no pin code (the ones connected to the sim cards) was requested, actually non sim was read.

Once I swiped to access the phone, I got a black scree with the “Android.process.media”error.

  1. I looked for explanations on the web and on the forum then I tried to reinstall the OS from recovery mode. Actually my micro sd only could be read. (No way to see the requested “updater” line).

“Fortunately”, as I had encountered problems with another OS upgrade, and I had to do without
using the updater app, I still had a copy of the .zip file of a former OS version in my micro sd (fairphone os v1 ota 2014 11 24) then I launched it.

Unfortunately, it didn’t work. The google app pack was grey on the desktop, but couldn’t be
launched. No backup could be restored but wa and telegram were ok.

No way to access settings or whatever.

No way to read the phone via PC

The only thing to do was a hard reset, I thought and try the restore through the official backup&restore app.

Fingers crossed.

OS ok, google apps ok (wifi signal was blue, but Backup&restore was not able to restore my data.

I could restore the apps, but later I have realized that many of them are actually missing (sorry for the naïve question: could it be because I haddeleted the .apk files?).

No way to restore any data. The app gets stopped.

So, no sms, no pictures, and so on.

As I had syncronised my FP with a gmail account, I had my contacts back and I could access my pictures, with the exception of the last taken and of the wa ones.

I tried to use recovery programs -Jihosoft android phone recovery and df fone-, to save whatever, but the first one couldn’t find anything and the second one didn’t work, or better to say, stopped working at a certain point (and I really didn’t ant to spend 60 euros for the pro version).


  • I can use my FP and that’s fine (and telegram saves everything somewhere else than on my

  • The .vmsg backup file is available in my mycro sd (inside the backup folder) and it can be open with notepad.

  • the wifi signal is grey (what does it mean? What does it imply? What am I supposed to do?)


looks like you have already come a long way already. I’m not sure if I can help you with every question because I do not use the Google App store or the Google services.

  1. It’s good to hear, but I don’t know anything about the “telegram” app.

  2. The same software that you have used to “backup” your data should be able to bring it back. For the “normal” software that comes with Android, the process and it’s limitations are described here: How to backup/restore the FP1. If it was a different software, try to reinstall it.

Missing .apk files could be a problem, not sure if your backup software took care of them … can you “see” them on the SD card? (Using the standard application “File Manager” you should be able to “walk” there -> SDCard-> backup->App/Data)

The “standard” backup tool should also work without the google services and should bring back most of your stuff, but not all the settings.

  1. There is a lot about the “grey wifi” signal in the forum, it looks like a google services issue. You can read about it in the forum, I never had this issue. Not sure if your problem is related to the google services. Maybe reinstalling/manipulating the google services will help? They change the underlying system a lot, this can cause issues.

  2. Also write the FP support. This forum is just users helping each other. But if the upgrade process and the integration of the google services is broken, they should know more about it.

  3. I still do not understand in what “condition” your phone is in right now, even after the screenshot. I would have expected to see a “W20-HL.Base.V0008” (stock android) or a “W20-HL.V0035” (FP1) after using the latest rom. You have already “W20-HL.V0036” interesting. But the Android version looks right. Maybe someone knows a better way to check if your phone is running the latest software correctly.

If think it still makes sense to do a clean install from scratch and once you know that it all works well, you can create a backup and play around with that a bit … just in case. But if you need your phone for staying in touch with friends and work, I understand that this is difficult.

  1. So if you do not have much time … and want to do this “fast” fixing the google stuff should make most of your stuff work again … hopefully. Try all the tricks the people describe here in the forum. If that does not work, write the FP support, again.

@Es_Ter: If you write here again, add me with the @-symbol, else I might miss it.

4 posts were split to a new topic: Issues with the Fairphone updater