Fairphone Update: FP gets stuck during "Installing system update"

Hi there,

I’ve tried to update my Fairphone to 1.8.5 twice.

A couple of days ago I tried it the first time. The Fairphone froze in a state of “Please wait” or something like that; and some cache/zip file wasn’t there. The update wasn’t installed, but Youtube and other Google Apps didn’t work any longer.

Today I tried it the second time, downloading worked out fine. Then I restarted the Fairphone. Now it’s been “Installing system update” for about 15 minutes and I cannot do anything. I cannot even power off. Each 5 seconds the screen flickers and the progress bar returns to 0 again. I guess the Fairphone will repeat this process until the battery is empty.

What shall I do?
I haven’t done a backup by now since the Update Installer didn’t recommend me to, so I’d like to rescue my data beforehand.


Phew, lucky me: by removing the SD card I could restart the phone and access all data.

The update from 1.6 to 1.8.5 doesn’t work nevertheless…

Here are recommendations on backups.