Fairphone OS 18.09.2 (Android 7) update on encrypted device

I recently got a notice for an available update:

When I was starting the update process, the following screen appears:

But on the security screen, I don’t find any option to temporarily store a PIN during startup:

Thanks for any hints how to proceed the FP2 upgrade with the officially available update.

It looks like you do have a screen lock set, the option to set it should be somewhere above ‘Automatisch sperren’. What the message is asking you to do, is to set up the same screen lock as you already have, but when asked whether to use the code for secure startup, select no. You can then install the update. After the update, set the screen lock again, this time enabling secure startup again.

In case it helps, the instructions posted elsewhere are slightly clearer:

  1. Go to Settings > Security > Screen lock .
  2. Re-enter your current screen lock and select a screen lock. You can re-use your existing pattern, PIN, or password.
  3. Disable secure start-up when asked if the new screen lock should be used for start-up.
  4. Install Android 7.
  5. Re-enable secure start-up.

Thanks for your hints. Now I got it working. :slight_smile:

For those who also are looking the needed settings, I made a series of screenshots.

Disabling PIN during boot:

(entering current PIN)

(entering your PIN twice)
Now you are able to update the phone. A reboot before is recommended to avoid any issues with hanging processes/crashed apps or similar.
So we got it. :slight_smile:

Re-enabling boot-PIN:

(enter PIN)

(enter PIN twice)

And the boot behaviour is as at the beginning.

Upgrade worked flawlessly in my case, I successfully tested several apps after the upgrade.

To the Fairphone developers: Great job done. :-))


Here the garbled screenshot during edit:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.