English

Fairphone Open OS 17.08.1 and 17.08.1.1 (Android 6.0) release

Looks like this problem:


Check the first post or refer to the official Fairphone troubleshooting guide and use the Checkup tool for diagnosis:

Hi everyone.

I’ve trouble with installing Fairphone open. I tried to install it twice with no success. My phone is working now with marshmallow, but I will be pleased if someone have a solution for me.

Here is what happened: I’ve just received a fairphone 2 with the standard OS Android Marshmallows 6.0. So I try to change the OS to Fairphone open.
I followed the fairphone instructions. As the link for “OTA Build switcher” was dead at the time, I did the manual installation (using fastboot), with this file: fp2-sibon-17.08.1-manual-userdebug.zip
It worked pretty well until the reboot. During the installation of the open android OS, the screen freezed on the step “optimisation des paramètre” (= parameters optimisation) So, after a long time with no change, I try to turn off the phone with the button. As it didn’t work I took off the battery, and then restart the phone. At this time, The phone freezed on the screen “change is on your hand”, the phone seemed to run but nothing more happened, even after a long time ( maybe 30 mn)
So I did the process to go back to fairphone marshmallow, it worked well. Then I retry to install Fairphone open, but the same occured. So I’m back now with marshmallow and all the google apps that I don’t want and can’t uninstall.

Anyone have a solution?

Hallo, seit dem Update auf OS 17.08.1 habe ich das Problem, dass die Anzeige “nur Wecker” dauerhaft eingestellt ist und ich sie nicht mehr abstellen kann. Dabei scheint es nur ein Anzeigeproblem zu sein, denn Anrufe/Nachrichtentöne kommen weiterhin normal an. Da ich aber dienstlich ab und zu die Funktion nutze, um kurzzeitig nicht gestört zu werden, ist es auf Dauer aber unbefriedigend. Hat jemand eine Idee, was ich machen kann?

You could try the TWRP way …
Attention! This will remove the installed OS and all your data from the phone (which the “factory reset” available in the OS will not completely do by the way, so don’t bother with that).

  • Put a microSD card into the phone.

  • Get TWRP running as recovery:
    Download a TWRP image already adapted to the slightly changed hardware of the new Fairphone 2 batch here, currently TWRP_3.1.1-0-ota-fix.img.
    To install this image, follow the “Fastboot Install Method (No Root Required)” section given here, mind the image filename (they give a different one in the instructions).

  • Put the right OTA file on the microSD card, currently fp2-sibon-17.08.1-ota-userdebug.zip, not one of the switcher files.
    If you want, you could combine this with the next step:

  • Boot the phone into TWRP.
    If you connect your phone to your computer now, you could transfer files.

In TWRP:

  • Settings - uncheck “Zip signature verification” - back to main menu

  • Mount - check “System”, “Cache”, “Data” and “Micro SDCard” - back to main menu

  • Wipe - Advanced Wipe - check “Dalvik / ART Cache”, “System”, “Cache”, “Data” and “Internal Storage”, do not check “Micro SDCard” - Swipe to Wipe - back to main menu (if it doesn’t return automatically)

  • Install - Select Storage: “Micro SDCard” - select the OTA file from the list - Swipe to confirm Flash - when finished, reboot (this reboot really might take a while, so be patient)

1 Like

The Updater app suggests me to install FPOOS 17.08.1.1 which is also available at code.fairphone.com. Is there any changelog available for this - maybe bugfix - release?

4 Likes

I would be interested in that, too.

Yesterday I counted 3 random reboots with the phone just lying around … my first random reboots with the phone … Hoorr… ahem, no.
I flashed the previous modem files just out of curiosity, no random reboot today.

Same question here. Was prompted today to upgrade to 17.08.1.1 and am a bit surprised about the lack of an official announcement. This is a legit update from Fairphone, right?

I found an “official” statement on code.fairphone.com where its stated:

The Fairphone Open 17.08.1 release was missing some of the security patches for August, the new build, 17.08.1.1, includes all of the August security fixes.

Hope that helps/ calms you down :slight_smile:

6 Likes

Too bad that platform specific patches still reside on the June level. :frowning:

2 Likes

I’d rather write this in the 17.07.6 release thread but it’s locked already and there seems to be no related changes in the latest update anyway:

Has anybody experienced a regression that started with the 17.07.6 update regarding apps just hanging pretty often (several times a day)? It seems to make no difference which apps I’m using… so far it happened on my most frequent used apps like juicessh, realvnc, firefox and total commander and it always occured when scrolling or wiping. When I press the power button to let the phone enter standby mode and waking the phone up the same way, everything seems to be fine again.

However it seems the notorious spontainous reboots have reduced since… so I’m not sure if this is a good or a bad thing - or just a coincident. And I can’t find anything in the changelog except some added security-fixes… does anybody know how detailed these changelogs are? Do they really record every change?

Yes, I noticed sluggish scrolling in dolphin, the content was already loading so I couldn’t blame the data connection.

Firefox hangs about twice a week, I wouldn’t consider it dramatic. I haven’t seen any other apps hang since then.

Hi there,
I hope, you can help me?
I have massive problems with the last two updates of the open OS, because my twrp always gets stuck in the home screen (symbol with 2 arrows up/down). A restart of the system is only possible by removing and replacing the battery.
The “normal” mode and the save mode are running. And I know, that TWRP has worked before.
Thanks a lot for your help!
Heike

@paulakreuzer : No, I can’t get into TWRP “normally” without updating. Even if I try to start it separately, it doesn’t work.
hmmmm… how can I re-flash TWRP via fastboot?

the recovery mode is notworking, too… :frowning: it always shows the black screen with “fairphone powered by android”…

TWRP is the recovery mode. If you press Power + Volume down you get into Fastboot mode, and that looks exactly like you describe, there’s nothing more to it :wink: .

Em… I ment the fastboot mode, sorry. :wink: I guess I have found the mistake: I have removed the sd-card - and now the recovery and the fastboot mode are running well. :slight_smile:
Weird…

I had stability issues with stock TWRP, too. Since I need a recent version for backups anyway (encrypted data partition), this problem didn’t affect me very much.

2 Likes

Hi all!
A few days ago I noticed that my contacts are damaged/corrupted. I am not sure if that happened after 17.08.1 or 17.08.1.1 My FP2 is unmodified.
I restored a contacts backup (vcf) but after that all contact-photos were pixelized. So I restored a TWRP Backup (17.07.6) yesterday and all my contacts reappeared. Before that I did a full threema-backup.
Meanwhile the updater doesn’t show 17.08.1 any more so I had to update to 17.08.1.1 again. After that my contacts were still all right, at least I think so. I restored my threema-backup and was happy again.
As always I switched off my phone in the night and started again this morning. The contacts are corrupted again!!
It seems to me that one of these two updates damage my contacts.
Anybody else having this problem?
Is there a work-around?
Maybe I should report that to the bugtracker?

Edit:
I just made a new, full threema-Backup again and I have just restored my TWRP Backup (17.07.6) again and restarted my phone. Contacts are all right!
Now I am restoring my threema-backup again…
All my contacts are damaged again so it’s not the fp-update but threema!

1 Like

I can not get into Fastboot. I just want to Flash OpenGapps but pressing VolDown+Power gets me stuck in the first Fairphone screen. Now my phone is only half working and furthermore my SD-Card is not accepted anymore, cant even format it.
I also removed the card and tried booting without it cause someone posted that as a solution but it did not change.

Considering the fact that I have more problems of this kind with each Update, I’m really thinking about switching back to FP OS :frowning: