Fairphone Open 17.10.1 is now available

Hi all,

Together with the GMS release of 17.10.1, we’ve made Open 17.10.1 available through the Updater app or through code.fairphone.com.

For more info about the 17.10.1 release, have a look here.


Product team


Just flashed it manually and it works as usual. How the hell did you manage to assemble the package this fast? Although rather unusual this is very appreciated! :grinning:


I just wanted to say to @Juulll here since the thread was locked, I just upgraded from 17.04.1 to 17.09.3 about an hour ago, on an encrypted phone with no system modifications, and it went just fine; very fast installation after downloading about 330MB and a slow boot & optimisation as to be expected.
However, when the phone booted it froze up as soon as BetterBatteryStats tried to ask for root permissions (as in, no physical buttons responded and the screen was frozen though it displayed a spot where I touch as per my usual setting, but nothing responded to that touch input). That app was definitely the problem because two other apps both got their permissions without a hitch.
So, on reboot I very quickly went to F-droid and uninstalled that app, and now it seems to work fine as far as I have tested. So take that as a warning to un-install BetterBatteryStats if you have it before upgrading to Android 6, as it seems to have some serious compatibility issue.

17.10.1 did not appear when I launched the update app about an hour ago, although it might not have checked for any updates, but the device has been on all day with an internet connection for nearly all of that time, so I would have hoped it would pick that up. :unamused:

Edit: Found another big problem with an app & A6.0: Trying to connect to my WiFi produced the errors “Connected, no internet”, “Wi-Fi Connection Failure”, and eventually “No Internet Access Detected, won’t automatically reconnect.”.
This seems to be because A6 no longer allows an app to see a list of network connections without Location enabled, meaning that the app Wi-Fi Privacy Police could not see that you were connecting to a trusted network without allowing all apps to know your location. Also see the issue with pings to google’s server’s that I found in the article linked above. Fuck you, google.
I feel a bug report brewing, but I need to sleep first.


Thank you 4ndy for your detailed answer, I really appreciate your effort. :slight_smile:

So if I’m not mistaken 17.04 was the last Android 5 update, meaning you’re upgrading from A5 to A6. Fortunately I already went through that step (I am currently running 17.06), and I don’t have the BetterBatteryStats app installed. I was mostly referring to this thread and this post on this thread and its replies, that left me wondering whether maybe waiting a little would be better. But it seems that problems are not a thing for most users, so I will give it a go and update soon!

Cheers mate! :wink:

Yesterday I tried to update my FP Open phone (no GApps, not encrypted) using the updater app, and after the usual reboot was greeted with a screen in TWRP asking me whether the system partition should be left untouched or to authorize modifications. Did not know what to respond and chose to leave it untouched. I then had many options to install patches, reboot the phone and others I don’t remember. Chose to reboot the system and the phone went back to the old FPOpen 17.09.3. After less than a minute it rebooted spontaneously without any apparent reason and then was back to normal operation in the old system.

I tried the install again today, the app downloaded the update again, and this time TWRP installed everything as usual and after the usual reboots the phone is updated now and everything seems to work well.

Great work on pushing the update for FPOpen out so fast this month!

1 Like

FP Open 17.10.1 installation via the updater overwrites my TWRP 3.1.xy, as it seems to come with TWRP 3.0.xy. TWRP 3.0.xy does not start, so I install TWRP 3.1.xy via the TWRPapp, which I already did with the previous two versions of FP Open.
If anyone knows which TWRP I should use and/or how to prevent the updates to overwrite it it would be appreciated.

Aye, the problems I read in those same threads were also a main reason I left it for so long until there was some clearer verification, as my schedule was far too busy to be getting on with an unusable device.

It would be nice if someone around here was looking into, compiling and clearly listing conflicts, regressions and what configurations cause them.
Even better if the updater app could detect and notify of potential conflicts from user reports before restarting. That may be too much extra work though.

There’s a howto for that. I wrote it myself. :wink:

Had read it, but had hoped there would be a way to use the OTA updater.

Update went smoothly.

Update to Fairphone 17.10.2 fixes for the Krack vulnerabilities

1 Like