English

Fairphone Open 17.07.6 (Android 6.0) release

Fairphone Open 17.07.6 has been released. You can get it through the updater, or by downloading from Fairphone Open Downloads

  • Fixed the sound recorder app not being able to ask for the storage permission

Security fixes

Android Public Security Bulletin from July (partial).

Please note: Due to one missing platform vendor specific patch, the Android security patch level will remain June 1, 2017. Protecting our users is our top priority, and as this month’s software update addresses some important security issues, we have decided to not wait with releasing this month’s update. We are working closely with our platform vendor to address the remaining issues as quickly as possible.

*Security fixes:

CVE-2014-9731, CVE-2015-5707, CVE-2015-9000, CVE-2015-9007, CVE-2016-2109, CVE-2016-5863, CVE-2016-10389, CVE-2017-0469, CVE-2017-0475, CVE-2017-0540, CVE-2017-0664, CVE-2017-0670, CVE-2017-0673, CVE-2017-0674, CVE-2017-0675, CVE-2017-0676, CVE-2017-0677, CVE-2017-0679, CVE-2017-0680, CVE-2017-0681, CVE-2017-0684, CVE-2017-0685, CVE-2017-0686, CVE-2017-0688, CVE-2017-0689, CVE-2017-0690, CVE-2017-0692, CVE-2017-0693, CVE-2017-0694, CVE-2017-0695, CVE-2017-0696, CVE-2017-0697, CVE-2017-0698, CVE-2017-0699, CVE-2017-0703, CVE-2017-0710, CVE-2017-3544, CVE-2017-5970, CVE-2017-6074, CVE-2017-8246, CVE-2017-8253, CVE-2017-8254, CVE-2017-8260, CVE-2017-8262, CVE-2017-8263, CVE-2017-8266, CVE-2017-8267

6 Likes

Hi!

The updater app just notified me about Fairphone Open 17.07.6 (as an update to 17.06.4).
https://code.fairphone.com/ does not yet have any information.

Regards,
Thomas

I got a notification about 17.07.6. The updater dowloads something, but when I try to restart the phone to complete the update it can’t find the right file.

I also got the message to update.
I used the app Updater.
The file was downloading and before it was 100% I got a spontaneous reboot.
Second time I was asked to restart after a complete download.
Before restarting I got a white screen saying something like "android preparing reboot"
Then the phone restarted and went straight to TWRP and started the update unzipping.
After TWRP was finished, again a reboot, followed by Android is upgrading…
And the update was a succes.

@ThomasAH and @Tubb3. Perhaps it’s an idea to try the app Updater again.
And like every update make a backup first.

@Lidwien yeah, I will try that again when I get home.

I didn’t have problems with the updater, because I only use it to get the notifications, and I’m doing updates manually. I’m not even sure if updating with the updater app would safely work with gapps installed.

Went smoothly, thanks!

All went smoothly, but the USB is no more running except for charging!?!

Did you use Android 5 before? If so, the following might help:

I know that function and I already tried that, but it is not available…
(I have been using FPopenOS for nearly a year now.)

it works, thank you :slight_smile:

Update works without problems. Thanks!

Worked fine as far as I can see. Just had to reinstall the xposed framework.

One thing I noticed: The “optimizing app” when restarting the phone took pretty long for two restarts… didn’t restart my phone in a while though, this may also be a reason.

I had the same problem as you. I solved the problem with these steps:

Developer Option - USB Configuration.
Uncheck “Charging Option” and activate “MTP (Media Transfer Protocol)”.

1 Like

Sorry, to late. I just swapped to Lineage OS. First impression are quite nice, so probably I will stay there.

Thanks for this, I only had to remember how to activate the Developer’s Options (I found it) :wink:

I have used UnifiedNlp (no GAPPS) successfully with Fairphone Open 17.06.4, but now (Open 17.07.6) it says “Your system does not support this UnifiedNlp package. Either install a matching package or a Compatibility Xposed module”.

Are location providers still supported by Fairphone Open 17.07.6?

Hi!

I’ve done my upgrade and it went smooth with an encrypted phone, zero problems with installing and installed apps. After a few days, it goes great.

Thanks for your great work :slight_smile: