Fairphone Open 17.06.4 (Android 6.0) release

Hi jeanrjc

I don’t know if it makes any difference, but I was able to update twrp to version 3.1.1-0 from within twrp. I went into recovery, copied the twrp .img file to the sd-card via adb, then installed it with the “Install” button. What you have to be careful about: After install is finished, you need to restart directly into recovery again; in case you do a normal (system) restart, twrp gets set back to the previous version.

Anyway, my os downgrade didn’t work (no luck with @maba007’s suggestion either since I couldn’t get into fastboot anymore), but I managed to get 17.06.04 running by following @Roboe’s instructions, only with the 17.06.04 (OTA Build switcher version) instead of the 17.04 file.

If you want to downgrade, it looks like your only option might be a factory reset. Unless someone more skilled than me can come up with some other magic.

Good luck!:four_leaf_clover:

Ok, so I just made a standard wipe and installed the last version from scratch. I lost my apps but not my documents or photos. My contact and calendar were sync so it was ok.

Not what I expected when updating though ! It was quite annoying. Hope it won’t happen at every update!

thanks but I eventually did a factory reset. Actually, I still have the apk I downloaded before, so I can install the app I had “easily”.

I still wonder whether there was something that I could have done to prevent that apart from reading the forum before updating…

Nothing. Only some beta testers were aware of the bug. Fairphone has released an irresponsible upgrade by not reading their beta testers reports. Full stop.

###I suggest all of you suffering the failed update contact Support and report your losses, lost time included, even if you already recovered your data.

State clear than the bug was reported by four different beta testers (I, @Roboe, plus @tukss, @freibadschwimmer and @lklaus)

I submitted last night the critical bug to the Fairphone bugtracker:



Try this one:

The release notes just say, that the TWRP codebase supports the CM 13.0 encryption but not that a build of TWRP supports it (it needs to be configured in a certain way). Download the official TWRP from twrp.me version if you want encryption/decryption to work.


The update went well on my FP2 with encrypted data partition and multiple users. No data or configuration seemed to be lost, also no reboot problems.

There was one problem though: I wasn’t able to connect my Pebble 2 smartwatch to the Pebble app on the phone. The Pebble 2 is special compared to other Pebbles (or even other smartwatches) as it only supports BLE (Bluetooth Low Energy). I didn’t have any problems with “normal” Bluetooth connections. So I wonder if there are other people who had problems with BLE connections with FP Open 17.06.04?

I am not sure if the following info is useful: The BLE connection with my Pebble 2 worked well with the previous version of FP Open and it also works well with LineageOS 14.1 (which I just tried).

I made a complete reset. Tried oanbackup but it didnt worked. Titanium Backup went fine. Now it runs with Xposed, pico gapps and gravity box. Thank you :slight_smile:

Edit: GhostComander cant delete apps. Does someone has an idea?
I copied already permission.xml.

Edit2: Found the solution in the FAQ from Ghost Commander:

Q: How to access the special mode “which provides full access to the external file system on Lollipop” (my device is not rooted)?
A: Please try the following:

  1. Navigate to the home: list (Main menu->Location->Home)
  2. Look for the “Storage Access Framework” item (the icon look like a menu button)
  3. If you tap it for the first time, the system will ask you to pick a directory where you want grant access to.
  4. Use this mode as a regular file destination.

note that there’s something like ‘all contacts erased after the upgrade’ issue.
a backup before is (unfortunately) necessary in any case.

unless you’re up for some pain in the…

A backup should be common sense before an upgrade that is a whole new OS version. The following updates of that then unchanged base version would be another story.

It’s no different on a PC with whatever OS. Backup before updates for an unchanged base version of the OS? Should not be necessary. Backup before an upgrade to a new base version of the OS? Common sense.

how right you are. and more than that!

[ i would have done that for sure if the ‘updater’ would have told me that it’s an OS update, not just a regular one. (in my case it’s even worse: the phone started the update by itself via ghost touches.) sitting on a bench and keep telling that everything is fine to people passing by and struggle trough no fault of one’s own is not helping the fairphone communtiy at all. in my case it just drags me away personally…]

1 Like

I apologize, that wasn’t my intention, and I understand your situation and the unfortunate part Fairphone played in it with deploying the upgrade this way.
I’m just a bit allergic to giving backups a seemingly negative touch with “(unfortunately) necessary” :wink: .
People don’t backup enough as is. And I for sure know I don’t.

actually i just wanted to encourage every lazy ass like me doing the effort to backup.

as a friend of mine, part of the international dance music scene just screwd his *book without any backup there. it’s not the first one in my surroundings. i’m just lazy with the phones man…newer the studio works. :wink:

njoy ur sat nite…


Hello necrosis,

It seems that your battery is deep discharged. Connect it with a charger and wait 30 mins.
If the LED is still flashing red, your battery is dead or your phone can’t charge it due to a damaged boot and/or system partition.
Turning on the phone with a connected charger results in reboots due to the drained battery.

Flashing the phone without inserted battery might help:

Follow the steps described in Installing Fairphone Open OS using Fastboot (Step-by-step Guide)

Start your phone into fastboot mode as follows:

  1. Remove the battery.
  2. Press and hold volume down and power button, then connect the phone to your pc. The fairphone boot logo appears. Now, release both buttons.

Your phone is now in fastboot mode. If the phone still reboots, verify if both buttons were pressed while connecting the phone.
Install the previous 17.04.0 version as described in the wiki above.

Insert the battery and connect the phone to a charger (don’t turn it on). The LED will start flashing red, then flashing should stop and the battery loading animation shows up.

Your data should still be in place since the manual update package does not contain a data partition, and the flash.bat and flash.sh scripts do not contain wipe commands.

You may now try again the update to Android 6.

Good luck!

A backup shouldn’t be necessary*, but a recommended precautory measure. Android has a well-designed migration system to avoid troubles —far better from most desktop OSes, IMHO. I’m sure you say that in the best of intentions, but can be interpreted as blaming the user, which has no fault at all.

*= if you run FP Open as is, without Xposed or system-wide mods (microG and stuff)

Well, just to add my experience - quite the same as previously stated.
We have two FP2, both FPOpen and “rooted”, one with XPosed/XPrivacy one without.
When the Updater showed up “new version available” I did not imagine it would be the long awaited upgrade to Android 6 - so I did not take any precautions (backup apps / nandroid-backup).
Both phones were in a boot loop after the OTA-update. Sometimes I managed to enter the PINs, most of the time the phones did not accept any input.
Finally I decided to down- and upgrade the FPOpen as described further up. In Detail:

  • downloaded fp2-sibon-17.04.0-manual-userdebug.zip (Link somewhere up in this forum)
  • downloaded fp2-sibon-17.06.4-ota-userdebug.zip (from https://code.fairphone.com/)
  • unzipped the ...17.04.0...zip
  • started the FP2 in Fastboot-Mode (Power-On + Vol-Down)
  • run the ./flash.sh in the unzipped folder
  • rebooted phone (Android 5.1, stuck in boot-loop, optimizing apps)
  • switched off by pulling out the battery
  • booted into Recovery (Power-On + Vol-Up)
  • in TWRP went to Advanced -> Sideload, on PC did adb sideload ...17.06.04...zip
  • rebooted
  • phone started normal with Android 6.0.1

My system settings were all there (including photos, SMS, contacs, call-log), but all application settings (including data) were gone.
I managed to recover the most important settings from old Titanium Backups and a nandroid-backup (I made after the first upgrade in TWRP).

The recovery of the two phones took me about 10 hrs. :disappointed::angry:

I really appreciate the work the Fairphone-Team is doing, but an major upgrade has to be announced in some way - this one showed up like any other upgrade before.
And on top it seems like the bug was well-known before - this is not professional work. :-1:


I haven’t been able to find that link. There’s links to 17.06.4, but not the earlier version.

I found this:


…but it doesn’t have 17.06.4 and I’m not even sure it’s the right thing.

Also, I would expect to be able to edit the URL to browse for earlier versions, but it doesn’t work:


Can you point me to the right link?

Oh OK, found it:


And if, like me, you’ve never used Fastboot before:

1 Like

Gah! That’s not manual-userdebug.zip it’s ota-userdebug.zip. Again, can anyone point me to the right link?

Here you are.
Luckily it’s still in the Installation Guide.