English

Fairphone Open 17.06.4 (Android 6.0) release

After OTA Update, I can’t switch it on anymore.
If I charge it, the LED only pulse red.
My battery was full.
What can I do? It seems to be broken. :frowning:

Upgraded today. First I encountered UI freeze issues like others reported. Then I completely wiped my phone in TWRP and reinstalled from scratch, and now everything works like a charm! I’d recommend installing major upgrades from scratch anyway.
Many many Thanks Fairphone team for finally releasing FPOOS Android 6!!

2 Likes

Hi

I think I have the same problem here. I updated to 17.06, and after update the phone hangs and reboots randomly and I have no access to any app nor to anything else.

So I removed the battery to shut it down and I started up in recovery mode.
Now I have a screen with

Unmodified System Partition:
Keep System Read Only ?
TWRP can leave your system partition unmodified to make it easier for you to take official updates. TWRP will be unable to prevent the stock ROM from replacing TWRP and will not offer to root your device

Which I don’t really understand. So I stopped here. I downloaded the zip file you provided with version 17.04, but then I don’t really know where to put it. I plugged my FP into my computer and I have access to the file system with Android File Transfer.

I don’t have back up per se, all my data are sync in a cloud, so I don’t mind starting from scratch, although I’d prefer not to if possible.

I must say that it’s quite amazing that an official release is posted on the updater and that there is no warning whatsoever on the instability of the release, apart from the fact that it is release as it. What should we have done to prevent that beforehand ???

1 Like

Okay. If I remove the battery, and put in the cable of my charger, the “Fairphone” logo appears. But it just reboots. If I put in my battery again, my phone does absolutley nothing. Only the LED is pulsing red. I guess my phone is bricked now.
Thank you for the update. :frowning:

ok, so kept the system read only, and moved on as @Roboe suggested:

  • Download Fairphone Open 17.04 flashable ZIP
    -> ok
  • Boot into TWRP (#dic:recoverymode)
    -> ok
  • Connect your phone to your computer and copy the downloaded ZIP linked above
    -> ok
  • Wipe (Advanced Wipe) Dalvik Cache, System, and Cache
    • WARNING: keep Data, Internal Storage and Micro SDcard
      -> ok
  • Install the downloaded ZIP
    -> I did that, it told me that it was successful, but that I did not had any OS install, and asked whether I still want to reboot or not ?
  • (if you had Xposed or mods, install them, because not doing that could cause that your phone don’t boot at all)
    -> doesn’t apply to me
  • Reboot and cross your fingers. Seriously, do it
    -> NOT ok as said above, I rebooted eventually, but nothing happened;

I’m now stuck. When I reboot in recovery mode now, I don’t have the partition message anymore, and I have what seems to be an older version of TWRP (v2.8.7.0). I tried to install again the same zip but it did not work, despite the successful message at the end, I still don’t have any OS.

Please help !

I can’t even boot into TWRP.

@necrosis did you boot in recovery mode ? (volume up + power)

Yes. But nothing happened…

nothing happen like it doesn’t even start ? did you unplug every cable from the phone ?

Yes. It doesn’t even start. I tried it with and without cable.

So I tried to install instead the last version (fp2-sibon-17.06.4-ota-userdebug.zip).

I then rebooted, and I did not get the “no OS installed” message. I got the Fairphone new welcome screen with blue dots moving for quite a while. Then I have the application optimization step that runs, then it goes back to the welcome screen…

I also got this first. So I put aside because I thought everything is going well.
But when I check my phone after a while it was off and I was not able to switch it on anymore.

damned, it’s been 3 times that it’s looping on moving blue dots, android starting/app optimization… I’ll stop

I still have access to TWRP but version 3. It still doesn’t start. How should I proceed ?

No. Amaze is gone. But you can go onto Settings - Storage & USB and click there onto your SD card to get a file manager.

Or you reinstall Amaze via the Play Store or F-Droid.

1 Like

Unfortunately, I don’t have a system backup - I didn’t expect an upgrade to a new android version, at least not without any warning.

So, thanks for your detailed instructions. I did everything as you said, but without success (app optimization bootloop).

I ultimately decided to go for a clean install of 17.06.4 (which is working, thank you, @freibadschwimmer !) and will have to install everything from titanium and data backup now - not exactly tricky, just a lot of unnecessary work. :rage::zap:

1 Like

I updated without problem. I’m curious if the battery drain is fixed.

How can i remove the bottom 5 apps in every home screen? I did remove the outer 4, but “All apps” is just there. I don’t want it to be just there. I loved the edge swipe, gonna miss it.

2 Likes

FPOOS now includes TWRP 3.0.1 which should support an encrypted data partition, regarding to the official release notes: Link. But if I try to mount my encrypted data partition it does indeed nothing, which is a bit frustrating. Any information on that?

Thanks! Mine also just worked after the upgrade :raised_hands:

The upgrade on my side went flawless. On the other hand I didn’t have an encrypted partition, I didn’t have TWRP, and I also didn’t have XPosed. Those seem to be the main culprits…?

Crazy touch input issue also seems to be solved, or at least much better :raised_hands:

well update worked without problems.
but i miss the clock widget ( The lock screen Clock widget wasn’t working as we intended so we took it out. This feature showed you “Your Fairphone since…/ Your piece of mind lasted…/ Battery lasts until…”)
is there any app out there that is similiar or is it planned to bring back that nice feature?

necrosis, your battery most likely is deep discharged. You should be able to get it running again with the battery reset from the #batteryguide

1 Like